Kwikset 910 Contemporary ZigBee Won't Identify


#1

Trying to connect my Kwikset 910 Contemporary (ZigBee version) Deadbolt to a new v2.0 hub and the darn thing won’t identify. I’ve added/removed the device numerous times. It seems to get stuck on “Identifying Device” and won’t go any further. If I back out of the menu, I find an Unconfigured Thing that only shows “Unknown Status”.

What’s the trick? After removing the device from ST, I hit Button B 9 Times to reset the lock. Then I choose Add a Thing and Hit Button A 4 times on the lock.


#2

What’s the full model number?


#3

KS-99100-018 ZigBee Contemporary Style Motorized Deadbolt w/Smartcode - Satin Nickel


(Joe Young) #4

I am having the same issue with the same lock today. Any advice?


#5

Here was their suggestion. It hasn’t gotten me anywhere. Frankly, I may just return the hub. Between not being able to log in yesterday due to their server capacity issues, their ios application constantly hanging and requiring a force quit and restart, and not getting my first “thing” connected, the product just doesn’t feel like it’s ready.

Thanks for reaching out! This sounds like it could be an interference issue. I know you’ve brought the deadlock close to the hub, but how close is the hub to your router? I would suggest moving the hub as far from the router or any other devices that might be hurting that connection, and trying again.
If that doesn’t help, unless the batteries are brand new, try replacing them.
If that still doesn’t help, attempt a hard reboot of the hub:

  1. Disconnect the hub from power and remove the batteries.
  2. Wait 30 minutes.
  3. Reconnect everything and wait for the hub to restart. About 5-10 minutes.
    Let me know if this helps.
    Thanks,
    Jared
    Smarthings Support

#6

I am having the exact same issue. I’ve tried every type of pairing option. The hub DOES recognize there is a zigbee device and it does successfully pair. However it has no idea that it is a 910 kwikset lock. When I did this with the Zwave version of the 910 contemporary it worked straight away.

I’ve already gone through multiple iterations of pairing and un pairing as well as even swapping the zigbee card into the original zwave lock I had after talking to kwikset as another troubleshooting option.

If you read in the smarthings options it calls out 910 “Touch screen Electronic Deadbolt” (Zigbee).
THat is not the CONTEMPORARY 910 Zigbee…

There is a “Kwikset Contemporary Dead Bolt” option however this is for zwave…not zigbee.

SMART THINGS: Are you sure you have the correct profile for this lock? Also you need to change your naming because right now it is confusing as it says the correct lock but doesn’t specify z wave or zigbee.

I would really like a solution to this issue so I don’t have to return my lock (yet again…zwave range was poor hence why I switched to zigbee).

NOTE: I spoke at length via email and chat with “Christopher” if you want to dig up further history on this.

Product Information:
(Smart Things v2.0 Hub)
NAME: 910 SmartCode Contemporary
MODELNUMBER: 910 CNT ZB 26 SMTCD CP C4 HA1.0
ID: 99100-020


#7

Did you ever get any sort of resolution on this issue??


#8

Tyler, this seems to not be a problem for multiple users. Can you please let me know if you guys are working to fix this issue?


#9

This is because we now support these models in both Z-Wave and ZigBee. We’re also updating our compatibility page to be by SKU instead of generic name.

I’ve tagged an engineer on this so they can look. I think this is the issue though:

MODELNUMBER: 910 CNT ZB 26 SMTCD CP C4 HA1.0

You have the HA1.0 model of the lock which is not certified. This is the Control4 model that uses a proprietary type of ZigBee. It is only compatible with Control4.


#10

This is certainly the best answer I’ve got so far.

Are you aware of a zigbee contemporary 910 lock that is a different model (newer perhaps that is compatible?)

Thanks,

-Sandeep


#11

This one potentially:
http://www.homecontrols.com/Kwikset-SmartCode-910-Zigbee-Deadbolt-KW9910005x

The ones that we certified originally were also available at Best Buy. That includes the 910 HA 1.2 model.


(Jim) #12

@Tyler I have the kwikset 910 from best buy and worked perfectly up to the latest update now smartthings will not lock and unlock it. I can see when I manually move the lock from lock to unlock and see the battery but it will not control the lock anymore. Can you please help I sent in a trouble ticket to ST request #219249


(Eli) #13

My issues is somewhat related… and it is strange. I bought the SmartCode Lever Lock by Kwikset. The 912. For some reason, when I ask ST to add a device, and even when I ask specially for the Kwikset 912, which is on the list in the app, it still finds it as a Z-Wave Schlage device… now… it is all OK, b/c it works well… until it big time drained my batteries, 3 times already. I tried using the programming button on the lock that starts a ZigBee inclusion (pressing button A four times) and it still added it as a Z-Wave Schlage Lock…
Whatever I try, it always recognizes this lock as the Schlage… and maybe that’s what drains the battery?
Anyone had the same issue?


#14

This is happening because you have a custom Device Type Handler published that is conflicting with this device.

Remove it from this page, or go to your new lock, click Edit and change the Type to ‘Z-Wave Lock’.


(Eli) #15

Thank you, Tyler. I did that now and will check if that Z-Wave Lock type drains the battery as well.
Mind you, I asked the app to find a Kwikset 912 ZigBee device… and I pushed the A button 4 times, as the manual says… and it still found the Z-Wave Lock… so, not sure what goes on there… but I will try.
Thanks again,
Eli