Kwikset 888 lock not pairing

Kwikset Zwave plus lock Model 888 is not pairing with our v2 hub. I have excluded it, moved it within 6 inches of the hub and tried pairing it a dozen times by pushing A once on the lock. Also excluded it several times between those tries. It excludes, no problem. It just isn’t showing up when I try to pair it. Possibly a faulty item or am I doing something wrong? We have multiple other locks that work just fine including another Kwikset but different model.

If you have any custom device handlers previously installed in IDE for locks, go in and open them and save/publish for me again, then exclude your lock again and attempt to add it. Also, which app are you using?

2 Likes

Thank you! That solved it!

I am having the same issue but I don’t know what the response you gave means. Can you help me?

That solution only works if you’re using a custom device handler like this one.

If you’re using the stock handler that comes with ST then most likely your lock and hub are having pairing issues. Try this:

  1. Exclude your lock using the ST app (this is one reason locks won’t pair, they need to be excluded first, see your lock manual)
  2. Reset the lock (see lock manual)
  3. Reboot the hub (power cycle it if you don’t know how to reboot)
  4. Bring the lock within 5ft of the hub and then try pairing it
1 Like

Forgive me for reviving a very old post, but I am also having trouble getting the Kwikset 888 to pair successfully. I have attempted the steps above and nothing worked. My hub sees the lock, but will not operate it at all. Anything else I can try?

Any update on this. I have the 888 as well. Pairs fine but will not function with any command sent from ST.

You could give this a try: FAQ: why would I need another beaming repeater if my zwave lock is already close to my hub?

Same issue as above. Repeater less than 2 feet away. It pairs fine and fast, but no functions are available and shows as last activity as the pairing. When I pair with the new app it states “Some security features not supported. Your device has been connected, but it isn’t using the highest level of security. Use a newer Z-Wave device for the highest security”. When paring with the old app, it doesn’t say anything but still doesn’t work.

See this post on how to check if your lock is communicating directly with the hub, through a buffering device or through an unknown device (if you see an unknown device then it’s definitely an issue).

You can safely ignore this, if you want to use S2 pairing you need to select Generic Z-Wave device while trying to pair the device in the new ST App instead of “Scan nearby”, but it has no effect on the functionality of the device and the issue you’re seeing.

Since it’s pairing it most likely needs to be routed though a known buffering device.

Thanks, online says Route [This Device (19) ]↔ [Home Hub]

Any other thoughts? My 916 Kwikset works fine.

Looks like lots of people with this issue

S2 vs S0 doesn’t have any bearing on the communication but you can always pair it in S2 mode (if you have a supported DTH) as explained here:

Try the steps in this post otherwise try adding a buffering device as explained in the previous post link.

I have the kwikset 888 and when I paired it to my Samsung SmartThings app it doesn’t show as a kwikset lock (as my other one does), instead it only shows as Z-Wave Device, which doesn’t do anything. I can’t get rid of the “z-wave device” and can’t get the lock to show up. Help!

Did you try the steps in the post above?

Zwave device means that it’s having trouble with the mesh and losing packets which is causing a lack of definitive identification.

You can try to force it to use the correct device handler but it’s better to get to the root of the problem to avoid issues in future.

I have to admit, I’m really confused by all of this. I don’t know what “a stock device handler” is, or what “mesh” is, nor do I know what it means to be “losing packets” or to force it to use the “correct device handler.” I’m not a techie person at all. I’d really appreciate clear directions.

I also thought I was not supposed to use the classic app for this lock – do I need to use the classic lock just to “exclude” it?

You’re correct, only use the new ST app. I’ve updated the post to reflect that change and also the link on how to exclude devices using the new ST app.

As for what are device handlers, read this short blog which explains the various components of SmartThings and the purpose of device handlers (TLDR: they allow SmartThings to communicate with devices). There are some built device handlers like Z-Wave Lock for the Kwikset lock which allow basic control and ability to program it and then there are custom lock device handlers which allow you to access your locks advanced features, improve the stability/reliability of the lock etc.

When a lock doesn’t pair correctly, the hub doesn’t know which device handler to assign the lock (this happens due to radio interference which impedes the communication while pairing and thus prevents the hub from correctly identifying the lock leading it to be assigned a generic Thing designation). The solution is the post above or manually assigning the lock the correct device handler.

So part of the problem is that the ST app won’t let me exclude. It says that the device is functioning appropriately and denies the exclusion

Try using the exclude instructions here under Z-Wave Devices. It’s a general exclusion, not device specific so you won’t get that error.

Tried that, still getting an error message and I can’t exclude it

If it’s already excluded it may not exclude again. Try to factory reset your lock and then pair it using the remaining steps in the post linked above.