KOF Zigbee Fan Controller and new ST App


I am having issues getting the KOF Zigbee DTH to work in the new ST app. I removed it and readded it, but it doesn’t actually complete the creation of the device. I do get a “thing” that is found but it won’t do anything.

Has anybody tweaked this DTH to work better with the new app? I have a feeling it is a pretty small change, but I am no expert.


  • King Of Fans Zigbee Fan Controller
  • To be used with Ceiling Fan Remote Controller Model MR101Z receiver by Chungear Industrial Co. Ltd
  • at Home Depot Gardinier 52" Ceiling Fan, Universal Ceiling Fan/Light Premier Remote Model #99432
  • Copyright 2017 Ranga Pedamallu, Stephan Hackett, Dale Coffing
  • Contributing Authors:
    Ranga Pedamallu; initial release and zigbee parsing mastermind!
    Stephan Hackett; new composite (child) device type genius!
    Dale Coffing; icons, multiAttribute fan, code maintenance flunky
  • Licensed under the Apache License, Version 2.0 (the “License”); you may not use this file except
  • in compliance with the License. You may obtain a copy of the License at:
  •  http://www.apache.org/licenses/LICENSE-2.0
  • Unless required by applicable law or agreed to in writing, software distributed under the License is distributed
  • on an “AS IS” BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the License
  • for the specific language governing permissions and limitations under the License.
    def version() {“ver 0.2.170515”} //update as needed

I’m running into the same issue - I’m trying to move over to a new Smartthings Hub at the same time so I thought I might be able to pair it in the Classic app but no dice.

Did you ever find a solution. I’m having the same troubles as well.

I was able to use Rafael’s DTH for my KOF fan in the new app.

1 Like

I used @Rafael_Borja DTH and it started working. I did remove the device completely, along with the old KOF DTH and then added the new DTH and repaired the fan.

1 Like

Does the Alexa - SmartThings skills work with this too? I just enabled the new skill and readers all my devices but Alex reports the fan as not responding. The SmartThings classic app still works to turn it on but it didn’t seem to work with the new Alexa skill.

Works fine with my Alexa…both the fan and the light.

I updated the KOF Fan and child light with the new code and published. ST Classic app shows the new changes and I can control fan and lights there. However, in the classic app, I can only change the fan to 3 speeds, Low, Med, and Med-High.

Alexa: I deleted ceiling fan, ran discovery. Alexa finds the ceiling fan again but won’t do anything. Shows “There was a problem” if you try to turn on ceiling fan.

New ST app. Devices not responsive. Deleted them. Ran discovery. “Thing” showed up. Renamed “Thing” to “Ceiling Fan”. If I try to open Ceiling Fan icon I get message “Can’t connect to device. Check device and try again”.

Google Home still shows old Ceiling Fan Light and Ceiling Fan Low, Med… but says “not responding” if I try to access them.

Can someone tell me what I’m doing wrong? Thanks.

Update: Went back and edited IDE. Noticed it now calls ceiling fan “Thing”. I edited and changed type to KOF ceiling fan.

Device now works in new ST app!!

Alexa: Works! Just have to remember to control fan with percentages instead of Low, Med, Med-High, High.

Google Home: Unlinked ST account and relinked. Works!!!

Thanks for the help. Hopefully, my struggles will help with someone else.

I’ve installed the new device handlers but when I scan for new devices, it still comes up as “Thing”. How do I get the fan and light device installed?

You have to log into the IDE and manually change the device handler to the correct one. It will then create the device and child devices automatically.

Please forgive my ignorance. I’ve logged into my Samsung Smartthings account, but I’m not sure where, how or what I’m to change the device handler to? Any further guidance would be appreciated. I’m still learning all this.

Thank You

Go here: https://graph.api.smartthings.com/

Goto “My devices” and click on the ceiling fan (will be listed as a “thing”). Edit the device and make sure the type is changed to:

Save it and you should be good to go!

Thank you. I was able to get the light and fan to work within Smartthings App but only able to get the light to work with our Alexa device.

I’m doing it wrong. I do not get this selection on the “type” drop down list… DTH installed, device discovered, device renamed but can’t select type.

UPDATE: I’m dense. The “KOF” type was there just listed later, in another alphabetized group. I didn’t scroll down far enough.

1 Like

haha - not dense - SmartThings does strange things to how they are ordered when they are native versus custom device handlers. I did that the first time as well until I scrolled all the way down and found all fo the good ones :slight_smile:

Anyone use this in actiontiles? When I add the fan, it works fine in smartthings, but when I create an actiontile, the slider bar controls the light and not the fan.

Did you change the slider action in the fan settings? Maybe try that?

1 Like

Amagawsh! THANK YOU!

1 Like