How can I replace KOF Zigbee ceiling fan control with something else

I’ve given up on KOF for my ceiling fan. It works MAYBE one out of every 10 times. Surely, there is a better solution by now. I have my ceiling fan (with the hampton bay controller in ceiling fan shroud) connected to wall switch. As I am using the controller in the ceiling fan for both the lights and fan speed, there is only one power wire going to fan (or else I would just replace wall switch with a smart fan/light switch that could control two power wires).

Can someone please recommend a better module/driver combination than KOF. If the only solution is to rewire an additional power wire to ceiling fan I will do that, but would prefer to just find a better one power wire solution to control the fan and lights.

Thanks in advance!

I’m surprised the KOF DTH still works at all for you. There has been a new DTH for this fan since the new app came out. The new DTH works well in the new app. You can find it here…
rafaelborja/SmartthingsKingOfFansZigbee: Smartthings device handler for Home Depot Home Decorators Zigbee Fan (and fan controller) produced by King of Fans. This device handler is based on, refectored to work with new Smartthing app and to provide simpler user experience.

1 Like

Maybe I already updated? Because it looks like what is in link (in new app). How can I tell? I can’t remember how I loaded devices and code. When I try to go to this link (in your link) “ /en/latest/tools-and-ide/github-integration.html”, it just jumps back to Thanks

youll have to copy and past the code from the link i sent you to make the 2 device handlers in the ide

Finally got in. Looks like I’ve already done it. Do I need to delete dcoffing? If so, how? Do you think I have an older version of rafaelborja? If so, how to update? Thanks again for the help.

I updated code and republished. When I go to My Devices, select activity, and then tell Alexa to turn off ceiling fan lights, she says ok. When I refresh activity history, it shows that Ceiling Fan Light switch is off, however, it never turned the bulb off. So in other words, smartthings thinks it’s working, but it’s not doing anything. Any ideas? Thanks.

Your issue (most likely) isn’t the device handler, it’s flaky communication between the KOF controller and the rest of your mesh; it’s widely reported that the antenna on these sucks, and it’s typically parked inside a metal housing so you lose a lot of strength of that weak signal. Do you have a Zigbee repeater (smart outlet or switch) in close proximity to the fan? Note that, with the fan on the ceiling, an outlet in the room above can be as useful as one in the same room. You can also try to position the antenna (the flat white plastic part) outside the fan canopy, if access isn’t too much of a challenge.

Ok, I will try your suggestion. I don’t have any repeaters that I know of. I’d have to go look at my system and see which ones are Zigbee vs just wifi.

2 questions: Are there Zigbee bulbs that would act as repeaters, and if this doesn’t work (or isn’t the problem), do you think deleting the KOF inside Smartthings app and then re-adding (which I don’t know how to do, by the way) might help? Thanks.

PS. It used to work fine, so I don’t know what could have changed connection wise.

Also, the SmartThings hub is in the room directly above the fan if that makes any difference.

You can reset the fan by turning on and off the wall switch (or circuit breaker if there is no switch) 5 times. the light will flash 3 times if the reset is accomplished. delete the fan and light from the app and then rejoin. If it worked fine before it is worth a try. Things can get messed up when they are run in the cloud as this device is.

Shouldn’t I delete the two devices from the app first and then do the power reset? I didn’t think it was the other way around.

Also, you said delete fan and light from app and then rejoin. Can you be more specific in what you mean by “rejoin”? What does that mean exactly? Thanks!

Ok, Deleted items from app, did power reset, scanned for new items in ST app. Created Thing. Went back to IDE and assigned Thing to King of Fans. Renamed Thing to Ceiling Fan, and Ceiling Fan Light. Both show up in ST app correctly. Both light and fan will turn on in Alexa and Google. However, in ST app there are two sliders for Fan: Dimmer, and Fan Speed. If I say turn on ceiling fan 75%, it adjusts the Dimmer slider but not the Fan Speed slider. Dimmer slider has no effect on ceiling fan speed, only “fan speed”. What do I say to Google or Alexa to adjust Fan speed? Thanks.

Ok, if I would learn to read I might be dangerous. Saw in the readme to change brightness to control fan. Everything working fine now. So in future if it stops working, just need to reset and reinstall in ST. Thanks again for everyone’s quick response!

1 Like

One oddity. In Ceiling Fan Light, the light will only go down to 20. If you try to go lower than that, it just comes back up to 20. Is this correct? If so, is there a way to change that? Thanks.

CAN’T GET THE POS TO PAIR. No combination of on/off five times works. I tried 1 second intervals, 2 second, 3 second (like manual says), etc. I’m about done with this thing. Any idea why it won’t pair?

Finally got it to pair, so I will leave you all alone. Thanks for the help!