Just lost my harmony integration. that REALLY isn't cool

just lost all my harmony integration. i have 3 hubs and it is used to control my hometheater as well as wake up and in many other routines.

i’m on the new app. unfortunately, i can’t install the classic app. i tried.

removing harmony integration is not cool at all. those hubs aren’t cheap.

i have tried to install the harmony smartapp in the IDE but i get an error when launching it. “we’re having trouble connecting. check your network connection and try again”

tried through wifi and mobile internet.

am i supposed to enable oauth? i tried and that didn’t seem to work either

any pointers? thanks!

my harmony app started working in the app. i went into the harmony app and refreshed the smartthings credentials there. then when i came back to smartthings the harmony app was showing like it used to. i then selected login and entered my harmony credentials.

this isn’t the one from the ide because i deleted that in groovy and it still is working on my phone. if i was using it it wouldn’t have let me delete it

Mine still works

Was there anything you did? I have three as well and the Activities are incorporated heavily into my Smart Home theme.

This would blow!! Is Harmony available on Hubitat?

Didn’t have to do anything. It’s been working all along for the last 3-4 years.

and it disappeared from menu > smartapps?

and also from IDE > smartapps?

I read somewhere on here that someone installed version 2.12 of the classic app on Android and it worked. YMMV

That might let you reinstall it.

Yes, and it’s a local integration. Does not use the cloud. It’s a community integration.

1 Like

i went into the harmony device and when i exited a message saying “we had trouble connecting to the server” or something like that was displayed. then it was gone from smartthings that then removed it from alexa… which killed my automations and routines :frowning:

do not go into the harmony device on smarrthings. mine was working fine until i did that - when i exited, it got wiped out

yep - it is gone gone… cascaded to alexa and all my routines are missing the harmony activity/scenes

This is good to know. Yeesh this is all messed up.