Entering Harmony Credentials

I accidently logged out of the Harmony Connect smart app. When I click “Click to enter Harmony Credentials” A page opens that reads “Sorry, you’re not authored to view this page.” and my only option is to click done.

On the main Harmony Connect smart app page it will allow me to select next and add SmartThings devices to Harmony.

How do I reauthorize Harmony so that I can access my Harmony activities in SmartThings?

1 Like

tagging @nathancu

1 Like

Thanks j… that’s a new one… let me take a look…

1 Like

I’m trying to repro on a dummy account with a spare harmony but wont be able to do it until later.

Considering it’s already broken, what do you think about deleting the Harmony Connect smartapp and starting the setup over (I wouldn’t recommend if it were working of course…) from the Harmony side from scratch?

Can you set up a new Harmony/SmartThings connection? I was under the impression that if you didn’t already have them linked you could not add the smart app any longer.

You have to add it from the Harmony side first, using their instructions to connect to SmartThings. ( Harmony and SmartThings (myharmony.com)) Their process adds the smartapp in your account (this is the only way I know to get it… and when that goes away we’re all hosed) THEN you go into the newly added smartapp and finish the configuration as you were trying to do - BUT it should have the initial auth completed.

Yesterday afternoon it let me log back in. It was a little laggy and took a couple tries but it worked. Thanks for helping.

Hopefully Harmony hangs around until something better comes along.

1 Like

Yeah no kidding - I was LESS THAN ENTHUSIASTIC about their announcement.

Hi @nathancu

I am trying to connect the Harmony IDE but it looks like Logitech have changed their system to a new SSO. I use a federated Gmail account to login but that button doesn’t work in the app (can’t open a pop up window) so I can’t login.

Any ideas how I can fix this?

With federated - no - you’ll probably have to fall back on the actual logi.com account. (Which even though you’re using Google or FB to login - isn’t disabled, I just logged in to mine to check as I also use a federated ID) You can use the Harmony desktop software to verify connection with a logi.com account directly and then try to use that to sign-in instead of the federated ID?

If that doesn’t work you’re - no we’re - probably hosed now that Logitech stopped making them. They say they’re going to continue supporting clients who have them - but we’ll see how long that lasts. I’m already researching alternate options, myself.

thanks. I have tried this but I still can’t login. On the desktop software I also login in using Google and if I try and change the password in the account it fails. Any other ideas?

Update: I managed to get this to work by following the forget password option. The Smartapp has connected and found my Harmony devices and activities. Thanks for your help.

I would love to know what you find on your research @nathancu as I am struggling to find a good alternative. I mainly use Harmony Hub to control all my AV locked in a cupboard and use matrix switches to manage it to TV’s. I can’t find anything else that can do what Harmony does on the market.

2 Likes