Issues with Iris Garage Opener!


(David Hamilton) #1

Ive had no issues for several months with this unit. I installed a custom DTH to get my iris garage opener added. But it never read the battery stats of the Door Sensor. SO I switched over to Rboys DTH about a month and 1/2 ago. Battery stats resolved and everything working fine. So recently I noticed my Core was not opening the Garage. After investigation seems core is sending the command but nothing is happneing. So I power cycled the iris opener. Testing the device thru ST app, it seems to show information and registers core runs as well as other information. However, if the garage is open it doesn’t show it. If I press open, it says its opening but doesnt actually open garage. Refresh device still shows door closed. So the DTH doesnt seem to be doing its job. So I switched back to the old DTH and device still acts the same. Has the new ST Hub upgrade cause this? Is anyone else having this issue?


(James Yeo) #2

Mine worked when installed for a week, then went wonky. Similar behaviour.

I had to add a z-wave device as close as possible in the house to act as a repeater to boost the signal out to the unit and another thing inside the garage (I used outlets).
Nothing had really changed between installing and wonkiness, it just decided the signal wasn’t strong enough any more. Do you have something z-wave to relocate and test?

You could also fidget with the unit, different orientations get better reception relative to where your signal is coming from.

Weather has seemed to affect the signal getting to my unit as well.

Also, I think if you relocate any z-wave devices or even if you paired your opener close to the hub and then moved it, a z-wave repair is needed for proper mapping (I’m not sure on this one, I Just do it any time I move z-wave stuff)


(David Hamilton) #3

My hub is in the office next to the garage. But I do remember set had to be closer to the hub to register correctly. I will pull it down and test it in the Office. Thanks for the suggestion.


(James Yeo) #4

Sure. This thing was particularly finicky for me. I had to do a lot of resetting to get the unit and the tilt sensor all in sync and paired.

When that was finally good to go, I had to do more messing as described to get it reliable. Just adding the repeater outlets and changing the orientation a couple times.

There are several reviews on Amazon that mention folks having the unit just quit on them, hopefully you don’t have an issue like that.


(David Hamilton) #5

Yea, looking through the logs. Friday 8/18 it randomly opened the Garage at 5Am on the dot. I remember checking the video footage as I got a a text from core the Garage was auto closing because it had been left open. Seems that’s the last time it worked.

I also realized I had a Aetoch Siren Im putting in the garage. Its been reported that its a z-wave repeater. So I installed it in the garage, but no change in device functionality. I suspect its dead. Should be under warranty as I have not had it that long.


(Ron Talley) #6

Check wires…Check battery on sensor.


(Jimmy) #7

mine does this a couple times a year. Sometimes a power cycle works. the most recent time i had to reset it (5 button presses on the unit), exclude it and then use the replace function in the device settings.