Issues Connecting with Cree Connected Bulbs

Two of my Cree’s are getting stuck at turning off today (pre ST hub firmware update) and in the IDE it shows as On and Level 0. I may have accidentally switched it off probably manually in the Powder Room. Will check once I get home. If not, it goes in the trash to be replaced by Hue White. Its a PITA getting these to reset and add them back. As such they don’t work locally.

Other than Hues and things for LED strips, I think I’m completely done with smart bulbs, I just hope something like a GE 12722 can turn on/off a single ~12W LED bulb…

Neutrals are a major issue in my late sixties house. So, it’s like already 25 hues and family products and 6 dimmers/remotes to control them. Just a couple of Crees that I am getting rid of.

Good point, I’m fortunate that (in the switches I have looked at so far) there are neutrals. That being said there is supposedly a minimum load.

Slightly off topic here. I bought dozen plus zwave switches from that Amazon deal couple of weeks back but returned them coz of freaking neutrals.

Btw, others are reporting Cree connected issue. I did not bother trying to fix it.

Update: it miraculously started working again.

Although j don’t believe the Cree bulbs were the issue, I got them working again. I flipped the breaker to “reboot” the bulbs and rebooted the hub again. All is now working.

Nice! If that it worked for you! :slight_smile: what’s the breaker you talk about (with due respect) which you had to flip. :slight_smile: and honestly want to know.

Hey, the circuit breaker in my house. I have those outlets wired hot all of the time and have switches acting as remotes that are sending the signals to my ST hub to turn them on and off. That way I can automate them, schedule them, and I’m not tied to slow reacting and reporting dimmer switches that are way more expensive.

Actually I am still having issues but think I know what’s going on. Unfortunately I don’t think there’s an easy fix.

It’s the app that’s acting up. I’ve noticed 2 things since having issues yesterday and have NO clue why any of this started.

  1. The “things” screen for the Cree connected bulbs is now different in the app for some reason. It used to have a horizontal slider bar with % for the dim level and now it has the stupid round half moon with no indication of % for the level. No clue why the app just changed yesterday and ever since then it seems as if one of the bulbs at a time doesn’t work right.
  2. The wall switches which are essentially just buttons that tell ST to turn the bulbs on to 100% or off. They work and activate the bulbs perfectly fine.

It just seems to be an issue with the app which sucks because if I have to remove the bulbs and re add them I will have to rebuild a ton of programming and routines.

Anyone else see any of this? Weird part is when ST announced that they would be updating the hub, that’s when I noticed the app changed and the bulbs started acting up. Keep in mind this was one day prior to the hub updating. Almost makes me feel like they updated something early and it broke. Don’t know.

Exact same situation. The icon changed a few days ago and ever since, my Cree bulbs have been hit/miss.

Trying to sell my wife on the HA set up and this isn’t helping.

Yeah, I honestly don’t even know what to think about it… I’ll try to find some time later to play around with it some more. What a complete pain to reset the bulbs so I can delete them and re-add them… I sure hope that if I go through all of that, it fixes it. I don’t know why the app icon would have changed since the app didn’t even update.

K. My 4 Cree’s will be thrown in the dumpster tomorrow. May be its the bulb or ST changed something on Cree’s! They are acting weird all four of them. I was looking for a reason anyways. So, 4 hue whites tomorrow…

Okay… found out what changed for us (and everyone)… and it’s all fixed and working (for now anyway).

I spent a decent amount of time with support troubleshooting this on chat (which they are very responsive on BTW). First off, the device type definitions which also includes the tiles (I think that’s what support called them… where you click and go into the details for the individual “things”) are controlled/updated centrally and have nothing to do with the mobile apps or actual devices themselves. They periodically update the code for them which is why we suddenly saw the change on our mobile devices.

In terms of what is wrong, I still feel like this is all one hell of a coincidence and won’t be sold on this being the actual problem until a great deal of time passes to prove it. I feel like someone fat-fingered the code for these bulbs which ultimately screwed them up. FYI… PLEASE contact support regarding this… they need to hear it from us directly so they can log the issues to get developments attention to look into this. They won’t do a damn thing if we ignore or throw them away.

Anyway, we power cycled everything as I have been doing, then the one bulb that was acting up, ended up “resetting” it (I had to remove all other bulbs, put just that one into a lamp as it’s easier to control the on/off cycles… and very specifically, every 1.5 second (not 2), go from on to off to on to off… and so on. Before doing this, support had me put the hub in discovery mode on my iPhone, they took control in the back end of the hub, and then I reset the bulb. After 5-6 cycles, the bulb will flicker once indicating it has been reset and is now discoverable. They were able to essentially place the bulb back into the same name as it was before which completely resolved me from having to delete it and re-add it to all of my routines and settings for everything… this saved all of that (by having support do this with me). Then it seemed to act okay for a little then quit again and so did one of my other Cree bulbs.

Then after all of this, I ended up physically moving my hub much closer to all of these devices and walla… everything started working just fine. I don’t know why all of a sudden there seemed to be some sort of interference or distance issue when I have NEVER had one in the past but once I moved the hub, everything now works just fine.

Again, I feel like it’s one hell of a coincidence and don’t believe that this is the core issue… I’m sure someone screwed up the bulb type in ST when they updated the tile or whatever for the “new” and de-contented look. I expressed my dislike for the new look too BTW… not that it did anything but it made me feel a little better anyway.

So I don’t know. Try moving your hub… I feel like something got jacked up with the device type code on their end and it’s somehow causing this… I’ve been screwing with it for a while now and all of the issues what were present are gone after moving it closer… hell, I didn’t even reboot the hub, I moved it (left the batteries in it) and just plugged it back in… it refreshed all of the devices right in front of my eyes on the app and now everything works.

Don’t throw the bulbs out, if you do that, send them to me and I’ll pay for shipping :wink:

All four of my Cree’s are still turning on/off sunset/sunrise just fine and I checked on the app and they have the new slider…

All, Up until a couple of days ago I was ready to toss these bulbs in the trash (Really Just Return them) but after a nearly 2 hour phone call with Cree the engineer brought up a seemingly isolated oddity that’s related.
In California the energy companies there have replace the analog power meters with digital AMI (Smart Meters) in particular a brand called iTron.
Users of the Cree bulbs have reported pairing problems with their Smartthings Hubs and it turns out that those meters use the Zigbee protocol to communicate statistics back to the energy company. The RF signal is generated in an Omni-Directional manner so it has and does interfere with the communications of the Cree bulbs and I assume other Zigbee devices.

After my long discussion with the engineer and the inability to get ANY bulbs to pair I took a flashlight and when out and looked at my meter. Sure enough it’s an OpenWay meter made by iTron. Now I don’t live in CA I live in Michigan.

So the next day, as a test I took my ST hub to work along with the 3-4 bulbs I could not for the life of me pair. I plugged in my hub to works Internet connection and with my clip on lamp that I used at home to test I installed a bulb. I set my ST to look for new devices and then turn on the bulb, Kazaaaa Paired !!!

Next bulb, same story and each bulb performed the pairing in less than 5 seconds. No resets no fussing with on/off cycles, it just WORKED.

Now I have a probable culprit. Took my newly paired bulbs home with my ST hub and ALL works as it should.
Now I located some specs of the meter I have and I posted those with a link to the iTron site and meter info for your viewing pleasure or discomfort as it may.

I also looked up some of the crap the power companies are doing with these meters and how they can potentially affect my health or at lease my aggravation level when my home automation’s don’t work or my wifi is acting badly.

Hope this helps someone because I put lots of hours of phone calls, forum reading and trial and error into this.
PS. I’m also going to install a RF isolation mesh to see if I can reduce the Zigbee interference.

Specs:
OpenWay RFLAN Module » Two-way, unlicensed RF module »
Adaptive-tree RFLAN architecture provides easy installation and self-healing capabilities

Home Area Network (HAN) »
Every OpenWay CENTRON meter includes a ZigBee radio for interfacing with the HAN, in-home displays and load control devices »
The OpenWay CENTRON can store consumption from 2.4GZ OpenWay gas modules utilizing the ZigBee radio

https://www.itron.com/na/PublishedContent/OpenWay%20CENTRON%20Meter.pdf

Other links of interest:


http://emfsafetynetwork.org/make-your-own-smart-meter-shield/

3 Likes

Great investigative work and thank you very much for sharing your results/work with the community, you will help lots of others!

1 Like

This is the EXACT problem I’m having. I have an OpenWay meter by iTron (I’m in CA) and for the life of me could not get either GE Link or Cree bulbs connected. I was able to get a zigbee multipurpose sensor paired though.

I followed what you did and took my hub and bulbs to work. After getting the hub connected, I was able to connect 2 Cree and 1 GE Link bulbs without needing to reset them. They all showed up nearly instantly when attempting to connect!

I’m headed home to see if the connections hold. If so, you probably saved me from giving up on SmartThings, so thank you!

One question, have you been able to connect additional bulbs at home? It would sure be a pain to have to relocate the hub each time I add a new bulb.

I only have 4 of the Cree bulbs and I didn’t have trouble with the GE bulbs as far as pairing.
I did however put a screen over my meter and when I have a change to reset and re-pair a cree bulb I will let you know how it goes.
I used some aluminum screen door mesh with a ribbon clamp to secure it and an alligator clip to ground it.
Here’s a pic: https://goo.gl/photos/HUpN1HuzhXJHXUrcA

2 Likes

Update on Cree pairing with iTron Meter onsite:
I have reset ONE of my working bulbs after getting it to pair away from my home at work.
I took the ST hub AND the Cree bulb to the furthest point from any iTron meters I could think of and tried to pair the bulb back.
I wasn’t able to get it to work in a standard bathroom multi bulb fixture so I moved to another part of the house. Actually it was the garage, I used a clip on lamp pictured below and clipped to a 2x4 aiming up. I tried to pair and NOTHING.

https://goo.gl/photos/dJQGaS3ZmsbDbYyQ9

So I took the clip light and aimed it at the ST hub, BINGO… It Identified and paired.

Next I took the ST hub and put it back to it’s original location. I reset the bulb again and aiming the hood of the clip light at the ST hub at about 2-3 feet didn’t allow the bulb to pair. So I covered the ST hub with the clip light hood and because the hood is aluminum I believe it shielded the RF interference from other Zigbee devices including the iTron meter it paired.
https://goo.gl/photos/BaWD4zxqQsqVq6LL7

Hope this helps anyone having pairing issues with this bulb and maybe with the inexpensive clip light and other problem bulbs.

3 Likes