Can't connect Cree Connect (Zigbee) Bulbs

A good while back I had a power problem, a failed leg on the electrical feed to my house. All my lights were flashing on and off for several minutes. After it was fixed by the utility company 6 of my Cree Connect Smart bulbs were offline. Other Cree Connect bulbs came back online. I don’t know for sure, but I think the ones that didn’t come back were on when the power problem started.

After trying multiple times, I could neither reset nor connect them. I gave up on those bulbs and just let them stay offline because at the time I was being treated for an illness.

Now that am recovering, I am trying to fix things. I had some used Cree Connect bulbs that I reset so I could use them as replacements. I used a small lamp located close to the hub when trying to connect them to the 3ed gen Hub . I was unable to connect any of them. I tried with 4 of the reset bulbs.

To make it even more complicated I have not used the ST app in over a year due to the illness. The app has changed, and I feel like a newbie and perhaps that is the reason I can’t connect these bulbs. My ST Hub is connected and working ok with other bulbs door locks and routines. Any help would be appreciated.

let’s start with the reset of the Cree bulbs:

Start with the bulb powered ON, and then follow this procedure: :

Step 1: Power the bulb OFF for 2 seconds.

Step 2: Power the bulb ON for 1 second.

Step 3: Power the bulb OFF for 2 seconds.

Step 4: Power the bulb ON for 1 second.

Step 5: Power the bulb OFF for 2 seconds.

Step 6: Power the bulb ON for 1 second.

Step 7: Power the bulb OFF for 2 seconds.

Step 8: Power the bulb ON and leave it ON.

After this, the bulb should blink one time to show that it is in pairing mode.

is that the steps you took and did the bulbs blink/not blink one time?


Do the offline bulbs still light up if you manually turn the power off then back on? If not they were probably damaged by the multiple power surges.

1 Like

Also… sometimes the radio inside, which is what makes the bulb smart, will get damaged by power surges while the lighting part of the bulb is not. So the bulb will work manually, but you won’t be able to pair it.

So if the bulb turns on manually, the next troubleshooting step is to go through the reset process that @jkp mentioned. If the light doesn’t start blinking in the correct pattern at the correct time, then it may be the radio controller that was damaged.

1 Like

Yes, I can turn them on/off manually. The bulbs I tried to use as replacements for the installed bulbs were bulbs I had in storage and not part of the original electrical problem so the radios could not be damaged. I also successfully reset them before trying to connect them.

1 Like

Yes. I said in my original post that I successfully reset bulbs I had in storage and tried to connect them as replacements for the bulbs that lost connection during the power problem. Could not connect them either.

Yes I successfully reset bulbs that I had in storage using the same method you described. They blinked but I could not connect them.

Are all your other zigbee devices working after the power problem? How close is the bulb to the hub when attempting to pair? You have removed all the non-working bulbs from ST?

Yes, I have other Zigbee bulbs that are working fine. I always use a small lamp to connect smart bulbs. I put the lamp about 5 feet from the hub and then connect it. Once connected I name the bulb and move it to the location where I want it. I have now tried multiple Cree bulbs I previously reset without successfully connecting a single one. No, I haven’t removed the non-working bulbs because it isn’t an issue until I actually get a replacement bulb connected to the hub and ready to be named.

I wonder about so many of the non-working bulbs still listed in ST might be what is causing the issue. @JDRoberts can step in to offer you advice.

I can’t really do either (step in or offer more advice), but I do agree that leaving nonworking devices in the network tables can cause problems. Speaking just for myself, I would remove any non working Devices from the account altogether and get everything cleaned up and working before going back and trying to add just one of the problematic bulbs back into the account. But that’s just me, I realize that can mean a lot of work.

I don’t see how it would, but I haven’t anything to lose by trying it. I will remove them and retry connecting later. Will let you know results.

I will remove them now and try reconnecting later.

I removed the 6 non-working bulbs from ST. Only connected devices are in ST. Tried connecting 3 of the bulbs from storage that I had previously reset. They didn’t connect. Reset one of them a second time just to be sure it was ready to pair. It didn’t connect. So, I’m still stumped

I’m having the same problem. I’ve had Cree connected bulbs installed and working for years. One bulb became flaky recently, so I decided to replace it with a used Cree spare bulb. No go. Then I grabbed a new Cree bulb - also nothing.

Something has changed on the Smartthings side.

Reset the bulb, reboot the hub and try one more time

Tried that for each bulb. No luck. Tried to let Smartthings find the bulb along w/specifying it was a Cree device. Both no luck. If I recall correctly, back when I installed the original bulbs (years ago), they paired right up.

Adding to my post above, I looked at my existing Cree Connect bulbs that still work. The driver is for a ‘Zigbee switch’.

Just a WAG, but I’m guessing that driver went away for new Smartthings ‘Add Device’, but old devices are still supported? That happened previously on some devices (ended up throwing perfectly good devices away I got so frustrated).

I wonder if the switch to Matter is somehow involved? Stuff like this makes me want to migrate to Hubitat.

Are you able to get the bulbs into pairing mode (probably blinking)? If you can’t get them into pairing mode you will not be able to connect them to any system (SmartThings, Habitat, etc.).

1 Like

I can reset them (on /off x3, then the bulb blinks to confirm) and that should mean they are ready to pair. I still have the instructions (from the new bulb), but it’s written for Wink - so that tells me they were purchased awhile ago!

I have maybe 30 or 40 devices, all different varieties. Usually I can do an un-pair/re-pair w/o issues.

I wouldn’t be surprised if they were installed via the old version of the app. At some point, I just order a cheap Zigbee or Z-wave bulb from Amazon and call it a day. :slight_smile: Looking at Cree’s website, the Connect series doesn’t even show up, I think they moved on to WiFi/Bluetooth to be compatible with Alexa/Google. I suspect these aren’t even supported anymore.

BTW, I’m electrical engineer. Not trying to sound smart or anything like that. I’m just pretty methodical at trying to get these to work!