Cree & GE ZigBee Bulb Issues


(Chuck Pearce) #1

Just purchased one of each to try them out. All of my current devices are either Z-Wave or SmartThings. I was able to connect both of these bulbs to the SmartThings Hub, however neither of the bulbs will let me control them. I power them off/on using the app (switches are powered on) and there is no activity on the light.

Is there a trick to getting these bulbs to work? Am I required to have their individual hubs? I thought the ST hub could control the ZigBee devices without the manufacturer hubs.

Any assistance would be much appreciated.


Cree connected bulb configured in Mobile app but no control
#2

First, contact support@smartthings.com as there is a zigbee firmware update you may need. They’ll be able to tell.

After that, Cree bulb should work, no hub required, but these can be a little tricky to pair. See:

At the present time, SmartThings is recommending that Philips bulbs be used via the Hue Bridge. Much discussion in the forum on various aspects.


(Scott G) #3

First thing to troubleshoot is your zigbee firmware version (should be 1.5.4). See my post below for the same issue with a different zigbee bulb. The solution there was to have support push the updated zigbee firmware. When zigbee bulbs just don’t respond at all it’s typically the firmware issue.


(Chuck Pearce) #4

Wow okay, that must be it:

zigbeeFirmware: 1.3.1 is what my hub currently reads. I will contact support.


#5

Yeah, that’s the older firmware. The Cree bulb should work after that. :sunglasses:


(Chuck Pearce) #6

Update to this. Support upgraded my firmware, I removed and readded the bulbs and everything is working 100%!

I have been a big HomeSeer fan for the past 8 years but backed the ST project back in the KS days finally getting around to converting everything after a few failed integration tests. I have to say ST has come a long way since I received my hub. Very impressed. My two biggest holdups was my DSC security system (used wireless sensors so just replaced with ST sensors and siren/etc), and Rain8Net irrigation. Looks like I will have to wait until EVE/Adam succeeds as a project.

Thank you again community!


(Todd Whitehead) #7

Why won’t ST push the zigbee update?!?!?!

They just don’t seem to care.


#8

Hey Todd!

I certainly care :slight_smile: All of my colleagues do as well!

A small subset of our customers have an older version of ZigBee firmware. We’re a few weeks away from finishing our platform wide updates for that type of firmware, then we’ll begin bundling updates together so that this should be one process in the future.

In the mean time, we’ve added a note to some of our support articles for devices that require this update. As those articles mention, send us a quick email to support@smartthings.com and we’ll get that update handled for you.


(Phil) #9

I guess I’m part of that small subset. I’m anxious to get these bulbs connected, and sent a request to support yesterday. I have never tried or needed assistance with my hub (and currently have 30 things connected). How quickly can I expect a response?

Love this platform.


(Chuck Pearce) #10

Philip,

I submitted two tickets over the course of 24 hours and both were responded within 1 hr of submission during normal business hours. In my experience support has been very attentive.


(Phil) #11

I have to agree chuck_pearce. Tyler responded to my support ticket directly, and pushed out the firmware update last night. He indicated I should be able to pair with the old firmware, however, so I may have a different problem. In the past I have been able to pair anything from anywhere in the hourse. Tonight I’ll reset the bulb, get it close and personal with the hub, and try again . . .


(Chuck Pearce) #12

I was able to pair prior to the firmware upgrade, but the ones that were paired had to be removed after the firmware update and readded in order to control them from ST. Once you are in the pairing mode in the ST app turn the light on/off/on within a few seconds and then just leave it on. I noticed that seems to get it to show up on the ST pairing. Good luck!


(Todd Whitehead) #13

@Tyler,

It’s frustrating that I spent 3 days trouble-shooting the bulbs before I found out I needed an updated firmware. Every other day, there is another customer coming to the boards reporting the issue and having to manually request the firmware update. That’s just the people who take that time. How many people are just returning the bulbs, or using them as non-smart bulbs because they do not take the time to post here?

This has been an issue for quite a while. ST shouldn’t REQUIRE people to post on the forums or request a manual update to get supposedly supported items (Cree and Wemo bulbs) working.

I just feel like it is inexcusable that this update has not been pushed to all hubs that do not have it.

With all of the issues we have seen lately, this is one that there is a fix for, why wouldn’t ST want to do whatever they can to improve the user experience?

-Todd


(Chuck Pearce) #14

@Todd while I understand your frustration their support seems to handle these situations pretty fast. As a developer myself we typically don’t like to deploy major changes to everyone all at once. It sounds like they were pushing this out as a as-needed updated until they can have everything QA tested with their full deployed update.

Imagine if they pushed out the firmware update and it bricked 10% of the ST units out there… there would be many more pissed off people.

To your point though, they should implement some sort of auto check to notify a user and create a ticket if they attempt to add one of these bulbs and they have the old firmware.


(Phil) #15

Hi @chuck_pearce, thanks for the tips to get the bulb recognized. I’m having no problem getting the bulb reset, now I’m quite the expert. However, still struggling to pair.

One thing seems odd. When using the app to connect “Light Bulbs” -> Cree (at bottom), the app presents a page indicating it’s looking for a “Switch or Dimmer Switch”, and lists video links for the SmartPower Outlet, and the GE/Jasco Power Outlet. Odd I say because I am trying to connect a device listed in the “Light Bulbs” section of Things, not “Switches & Dimmers”. Is this consistent with your experience?


(Chuck Pearce) #16

It is, which I agree was confusing but I believe it is just their generic presentation for switches that control lights. I just go to “Connect New Device” when adding rather than the individual category. Not sure if there is a difference, both of my bulbs are within 10’ of the hub and both took a minute or two to be recognized by the pairing (required the on/off/on).


#17

This is unrelated to pairing the device. The bulb doesn’t have a pairing video yet so it takes a generic video for switches. Not ideal and we’re looking to remove that entirely.


(Phil) #18

Thanks guys, that’s good to know. I’ll have another go at this tonight.


(Phil) #19

I guess I’ll be taking these bulbs back this weekend. I’ve tried every permutation I can think of, including the tips from @Tyler and @chuck_pearce, without success (thanks guys). Knowing others have been successful is a good thing. Who knows, maybe I have a bad batch (3).


(Chuck Pearce) #20

@philglov were you able to at least pair them? Or did they not ever show up?