V2 Hub Migration and Cree Connected Bulbs

I finally got around to moving to the V2 hub this week with my relatively small automation footprint. With a little trouble, all my z-wave devices were excluded successfully from the old hub and included to the new hub. A couple of Zigbee Peanuts also moved without problems.

The trouble I’m having is with the Cree connected bulbs. One joined easily but the rest won’t connect after resetting (I know the sequence quite well at this point).

I’ve tried to put the bulbs physically next to the hub when connecting without success. I’ve read about possible interference issues related to wifi networks, so my next attempt will involve a long CAT6 cable to get away from the range of wifi. Will this help? Any other suggestions?

Thanks in advance for reading and your thoughts!

Hi @jeffreyropp,

You are correct in your line of thinking.

  1. Use the factory reset you talked about to reset each bulb.
  2. Move the bulb with in 1 to 2 feet from the ST Hub.
  3. Put the Hub into pairing mode.
  4. Intermittently turn ON/OFF the bulb(s) individually.
  5. You may want to Stop the Pairing process in the ST Classic app and start it again if the bulb doesn’t seem to connect after turning it ON/OFF for a few times.

I had to this a few times when I was playing with different HA hubs.

Anyway…Good Luck.

Thanks @lmosenko

Tried a few more things tonight.

  • Bought a new Cree Connected bulb and tried to pair it just inches away - fail
  • Shut off wi-fi and tried to pair new bulb - fail
  • Shut off wifi and tried to pair old bulbs - fail
  • Wrapped a clip lamp and hub in an aluminum foil tent - fail (I now feel like a crazy person)

Is there anyway to run diagnostic on zigbee?

I have 2 bulbs that paired miraculously and a Peanut. They all reliably respond to commands.

Called the support phone number and was instructed to send email - did that. No response so far.

Last thing I can think of is all of the above from the garage using a looong network cable.

Losing my patience rapidly with the platform.

Any thought or suggestions?

Thanks,
Jeff

1 Like

Have you tried after restarting your hub?

@TonyFleisher - Thanks for your reply. Yes, I’ve tried restarting the hub as well.

Going to also try to pair the bulbs with my old V1 Hub to see if that has different results suggesting a hub problem.

I tried running a 75 foot cable out to the garage and tried to pair the new and old bulbs to the V2 hub. No success.

Curiously, I can’t get the new bulbs to pair to the V2 or V1 Hub.

Am I just living in some weird electro-magnetic environment? That would explain my rapid loss in sanity trying to make this work as well!

Still no response from Smartthings support. Is it worth approaching Cree?

It really should not be this hard.

Try unplugging the Peanuts and powering off the two bulbs that did pair. Then, try adding a fully reset Cree bulb in the same room as the hub. I am wondering if you have a bad Zigbee device messing up your mesh?

@ogiewon - For a moment, I thought you were really on to something (perhaps you still are). I did as you suggested and unplugged the other zigbee devices.

First bulb (new) - paired right away!!! I really thought things were going to start working.
Bulbs 2-10 - not a single other bulb paired. Half of these were new, half old from the previous v1 steup.

I put everything back in place (including the newly paired bulb) and all pair zigbee devices are behaving properly.

I REALLY appreciate the help. Any other ideas come to mind?

If you’ve ruled out all other issues and they still won’t work, you can contact cree about a warranty replacement. I did that once for a connected bulb, and another time for a regular dumb bulb.

Both times they promptly sent me replacements without any hassle.

Not suggesting that’s your only option at this point. But if it comes to that, cree customer support is actually supportive, which is refreshing.

The only other idea at this point is the one I am sure you have already tried. Put the hub in device discovery mode, and then factory reset the bulb (make sure you see it respond after the on/off cycling). Or reset the bulb, and then put the hub in discovery mode.

Getting these bulbs to reset can be a little tricky, but don’t give up. I have about 5-6 of them working perfectly.

Another thought comes to mind… has your power company recently changed out your power meter by any chance? Some power companies are upgrading to smart meters that use zigbee. These are known to cause zigbee mesh conflicts for some users. Changing your zigbee channel might help, although I believe that requires ST Support to make that happen.

Thank you @ogiewon.

I checked and Southern California Edison did install a Smart Meter (not sure when)! It’s an Itron Openway which apparently does operate over Zigbee. How can I go about asking ST to adjust the zigbee channel (assuming SCE won’t do anything to help or acknowledge causing a problem)?

Still have hope! Not dead yet!

I am about out of my are of expertise. Tagging @JDRoberts as he will probably recall what solution, if any, is possible to deal with the “Power Company Power Meter Zigbee conflict” issue.

I do recall a thread a long time ago, where the user took his hub to his workplace, and managed to pair all of the devices there without issue. When he brought them home, they continued to work. Not a great long-term solution, but maybe something to help in the short-term?

Here’s the old posts regarding this issue that I somehow recalled! :wink:

I’ve heard about the itron issue before, but remain skeptical. For one thing, there’s been no comparable report of trouble with Phillips hue bulbs, which sell very well in the same markets. And lots of people have multiple zigbee networks in their homes and don’t know it, for example, cable set top boxes frequently use zigbee.

I think as a field engineer, my first test would be to get a Phillips bridge and Hue bulbs and try to set them up in the same home. If they don’t have a problem, then it’s likely the issue is the Cree bulbs themselves.

All of that said, it may be that for some engineering reason the Cree bulbs are more vulnerable to pulse interference from the itron meters. It’s not impossible that that interferes with the pairing process.

If that is it, then by far the easiest thing is the workaround that was already described: just take the smartthings hub and the Cree bulbs to some other building, pair them there, then bring them back home again.

1 Like

Thanks @JDRoberts and @ogiewon
Dumb question: can I setup a small local network without internet access just for pairing the bulbs to the hub? If not, I’m trying to figure out where to go to “borrow a network”.

The hub has to be connected to the internet to work.

Another crazy idea… how about building some sort of a faraday cage around the hub and bulb to see of that helps? Or, maybe you could wrap the power meter in aluminum foil? I am just brainstorming at this point.

You may want to try th Sengled Element bulbs from amazon. They are only $10 each, and most users seem very pleased with them.

As @JDRoberts mentioned, it seems this problem may be specific to the Cree bulbs.

Thanks @ogiewon, @JDRoberts, @marktheknife, @lmosenko, @TonyFleisher

SUCCESS!!! :joy::joy::joy:

I can’t prove it, but consider me a believer in the Zigbee interference from the itron power meter theory.

After taking a look at the likely positioning of power meters in the immediate vicinity, I figured it was worth a shot to try and pair the bulbs out in my front yard. Using a long extension cord and network cable, I also put the bulb in a metal clamp light, sat the hub directly on top and then wrapped the whole thing in aluminum foil. It didn’t work every time, but it worked most of the time.

The neighbors must think I’ve lost it. Jiffypop anyone?

4 Likes

Glad to hear you got the bulbs paired with the hub!

1 Like

No more GD cree connected for me. I have 8-10 of them and one is always either stuck on or not found. I currently have 2 that won’t reset. About a year old. Brought them to within a foot of the hub and did the on off trick with both. Nothing. I think their radios are dead. Garbage and not especially cheap either.

DO NOT BUY CREE unless you enjoy living in the dark, or conversely, having the lights on all day and night.

That sounds frustrating. I’ve been satisfied with my cree connected bulbs, as have many other people, so I would disagree with the assessment that they are “garbage.”

As I mentioned above, I did have to contact cree re: one bulb that may have been defective, but they sent me a warranty replacement in about as painless a process as it could possibly have been for me. Bad devices can happen, even to very good brands, but Cree gets a thumbs up in my book for their excellent customer service.

Have you ruled out the possibility of zigbee mesh routing issues? Or zigbee interference, which the OP seemed to be affected by?

It’s a little hard to tell what you mean by this statement without some more details:

For instance, did the bulbs flash after you tried to reset? If not, then the bulbs did not actually reset; they are very particular about the timing of the power on/off toggling. Do you have other zigbee devices in your home? Specifically mains powered zigbee devices that will act as repeaters?

1 Like

Dozens of zigbee devices Including several other cree bulbs. Last winter I had a lot of problems with the 4 cree’s I have out in the garage. They kept dropping from the network, getting stuck on or off. I had to reset them all several times over a period of a week or two and now they work fine again. Not sure what happened there.

With these 2 from the basement, I reset them each about 10 times with no luck. Eventually I bought new (cree) bulbs, stuffed the old bulbs in the package and returned them to the big box. The new ones connected immediately. I suppose this is somewhat douchey, but I don’t see why I should eat the cost of replacing their broken product.

looks like this all may be cree firmware update related?