Iris garage door control

Having trouble getting my hub to connect with my linear/iris garage door controller. Any suggestions?

Hi Lee:

  1. Plug in the door opener about 10 ft from your hub
  2. On your smart things app connect to Iris garage door opener
  3. Take the battery off of the door sensor, and simulate your door
    moving up then moving down
  4. If it does not connect, get out of connect and go back in.
  5. Keep on doing at 2 times.

Mine connected.


Try to reset and exclude it first before pairing it.

I have tried these steps and I’m still not able to connect? When you say take the battery off the door sensor and simulate your door moving up and then down… do you mean this “HAS” to be done in order for the controller to pair to with Smartthings hub? I had the controller almost sitting on top of the hub when trying to pair and the sensor was within a foot or so, but I wasn’t simulating it opening and closing. Is this a necessary step? Do i need to be pushing or holding down the link button on the Iris Controller during pairing? Thanks in advance

Any suggestions on excluding? I went into the utilities settings and tapped Z-Wave Utilities and then exclude and during the next step it never found anything. I tried resetting multiple times.

You need to follow the controller instructions to put it into exclusion mode, unlike pairing exclusion isn’t automatic (ie it won’t show up as a device, however when a device is excluded it’ll tell you it’s excluded).
Also bring the hub within about 20ft of the device

Reviving this thread. Every few months, it will drop the device (and 20 minutes away from the house I’ll get my heads up that I left the garage door open). Of course, the door is actually closed. So, it dropped the device (lost connection) three days ago. I excluded it, removed it, reset it (pushed the button five times), and reinstalled it. The hub adds the device (this time as a linear opener), tells me I don’t have the latest Z-wave security compatibility, and the door control and contact sensor both show disconnected (gray cloud with line through it). Have repeated three times.

Any advice?

I added the rboy Z-Wave Garage Door Opener with Switch Capability Device Handler and it’s working like a champ!!!