iOS presence sensor wasn't working; deleted now can't re-add!

bug

(Nicholas Head) #1

Ever since the whole iOS log off stuff started happening, my wife’s iPhone presence sensor has been stuck in “present” status and won’t update. Tried launching app, logging off then on again, uninstalling app and reinstalling, no luck.

So finally I just removed all the smart apps using the sensor and deleted it and went to re-add her phone as a presence sensor- now I get a alert dialog: “warning: this device is already setup as a presence sensor” and then nothing happens. Sigh.

Anyone have any suggestions on moving forward?


(RH) #2

Is it still a part of any existing rule or routine? You may have to remove any reference of it having every existed, add the phone again, then put it back into the rules/routines. If you haven’t I’d do a hard reboot of the phone too either by powering off or holding home button and power switch until you see the apple logo on the screen. Hope my ramblng is clear and/or helpful. Keep us updated please. I know you have done some of these steps but if it were me I’d check again. I assume you powered the hub off for a few minutes, the repowered.


(Nicholas Head) #3

Thanks for the help. It actually wouldn’t even let me delete it until I had removed it from all smart apps and such.

I just powered cycled the hub and it didn’t help. I’m gonna restart the phone now and see if it helps.

Update: nope. Still says warning, already set up as a mobile presence device. This has got to be a bug.

Logging into the IDE I don’t see the sensor listed anymore.


(Nicholas Head) #4

Wow. I feel dumb.

I was logging into my OWN account on my wife’s phone.

This was the whole issue. Sigh. Of course that won’t work. But the error maybe could be clearer. Hopefully someone else can learn from my silliness.


(RH) #5

That’s a drag. I’m not suggesting you do this but if I had the problem, I’d delete and reinstall the app after checking for more obvious things a few more times. Hopefully someone will have a smarter more helpful idea. Hang in there.


(Mike Balay) #6

I’m having the same problem. Logged in my account on two phones. Logged out of the work phone, created new account for that one, and then ran into the same “phone is already a sensor” note. I deleted the app and same issue came back.Help??


(Stephan H.) #7

Delete all presence sensors from your “Thing” page. Make sure you are logged into each phone with the correct (different) account. Add each phone as a presence sensor again. Should work fine.


(Mike Balay) #8

I was able to delete my personal phone and add my work phone, but now the personal phone won’t hook up. I’ll keep trying, including deleting the app off my personal phone and re-installing.


(Mike Balay) #9

I’ve deleted and reinstalled the app, removed all presence sensors, removed all presence triggers from SmartApps and routines, and power cycled both phones. Managed to get the work phone deleted again, and the personal phone back on the system. Not really sure what’s going on, hoping that tech support can figure it out. I don’t have the little gear that was mentioned to auto-import presence devices.


(Mike Balay) #10

Marshall form the help chat walked me through it. I had used the Safari browser on the second phone to log into my Connect account. The app was pulling that info into the app when I downloaded it on the second phone. Thus, two phones attempting to log in to the same account. I cleared the cache in the second iPhone and re-downloaded the app. Then logged into the invited account on the second phone, and now both are seen as presence sensors.

Huge thanks to Marshall, he actually called me on my land-line (I know, but it’s at work so I still have one) and we got both phones set up.


(Matthew Pitta) #11

I have the same problems with the warning that my iPhone is already a presence sensor when it is not.

My iPhone presence was stuck in ‘present’ no matter where I was. I removed it, and the attempts to re-add have all failed.

Have tried logging out/in, un-installing and re-installing the app, clearing Safari cache.

Since all my automation is keyed via iPhone presence, ST is useless to me currently.