IOS app "Something's wrong"


#1

Since yesterday I am getting a “Something’s Wrong” error in my IOS app and the dashboard or devices will not load. Automations are still happening but I cannot see or control devices. I tried IOS hard reboot as well as a hub power cycle. Anyone else seeing this issue?


Recent Tile Bugs (2.14.0)
(jkp) #2

#3

Yes I have the latest update… Is there another fix coming soon?


(jkp) #4

Did you read through the thread posted above? There are some users reporting crashes when they open the iOS app but maybe it applies to your Ooops something went wrong problem.


(Jimmy) #5

There is also a potential fix in the linked thread


#6

Thanks guys, I’ll dive into it tonight and see what i can figure out.


(JSTMYSTIC) #7

Been chatting with someone from support and they are telling me theres nothing they can do. They are telling me that I have to go and figure out which device handler is broken. SMFH. I hate Smartthings more and more everyday.


(jkp) #8

the WebCoRE presence sensor DTH is one - if you happen to have it installed. There is an update for it in IDE


(JSTMYSTIC) #9

I only have the Nest Manager which was alrady updated and 3 other handlers that dont use multiAttributeTiles


(JSTMYSTIC) #10

What I don’t understand is why didn’t they code for backward compatibility? Why break everything instead of just the one that is in violation?


(jkp) #11

I have NST Manager and it works for me so we can rule that out


(Brad) #12

Previous mobile builds protected against this so there was a regression which is being investigated.

In the meantime, I took a look and it seems you are being impacted by something else. In this case, I am able to reproduce your issues by creating a device with the Aeon HEMv2 device type you have installed.


(JSTMYSTIC) #13

Thank you! I deleted that one its working again. Someone on your support staff said they couldn’t do what you just did.


(Brad) #14

I will keep digging into your issue but the specific error seems to be:

Can not deserialize value of type java.math.BigDecimal from String "0 Watts": not a valid representation


NEW: Aeon Home Energy Monitor v2 Device
Recent Tile Bugs (2.14.0)
#15

I also have that device type. Delete and reinstall fixed?


(JSTMYSTIC) #16

I kinda depend on that device though. Whenever I go over a certain wattage I get alerted and turn off some electric heaters. I’d really hate to have to buy another one for $100 if its a software issue.


(JSTMYSTIC) #17

I see this dispValue = newValue+"\nWatts", line 276 I’ll play with it and see.


(Brad) #18

I flagged the issue internally but don’t have a device to test with.


(JSTMYSTIC) #19

No worries, thank you, I’ll dig through it.


(JSTMYSTIC) #20

Turns out all you have to do is remove “Watts”. It works perfectly again.

            backgroundColors:[
                [value: "0",      color: "#153591"],
                [value: "500",    color: "#1e9cbb"],
                [value: "1000",   color: "#90d2a7"],
                [value: "1500",   color: "#44b621"],
                [value: "2000",   color: "#f1d801"],
                [value: "2500",   color: "#d04e00"], 
                [value: "3000",   color: "#bc2323"], 
      	        [value: "6000",   color: "#90d2a7"],
                [value: "9000",   color: "#44b621"],
                [value: "12000",  color: "#f1d801"],
                [value: "15000",  color: "#d04e00"], 
                [value: "18000",  color: "#bc2323"]  
            ]

NEW: Aeon Home Energy Monitor v2 Device