iOS App Showing Empty Things


(Jeremy) #1

Work around seems to be using "Rooms"
Anyone else experiencing this issue?


(Andrew) #2

Yes. So much yes. For two days. It happens on all versions of my iOS app from v1.x to 2.0.8 and 2.1.0.

I reported this to SmartThings. They replied with a canned email (about Windows Phone no less) that this is a known issue, they are working on it, and they’ll email when it’s fixed. That was yesterday.

The Rooms workaround only works if your thing is already in a room. At least half of my things are not in a room, and the app reports an error when I try to add new things to a room. Because, hey, the Things list is empty!

Half my things have been taken away from me by SmartThings. I swear, I’m so done with this platform. If there were any viable alternative, I’d be gone like yesterday.



Grrrrrrr!!!


#3

As temporary workaround, use the IDE to add your devices to a Room (seen as Groups in the IDE).

@jscoleman, I recommend also emailing support at support@smartthings.com.


(Mike Elser) #4

This did not work for me! By adding items from the IDE causes me to loose the items I was seeing in the Rooms tab all together.


#5

@macmedia,

That’s really, really weird. When that happens do you get any red bar of death messages at the top of the app? I’ve noticed that this has come back to haunt us again.


(sidjohn1) #6

I’ve seen poorly written devicetypes cause this. If any of your devicetypes are custom, switch them to the defaults or delete them and see if that doesn’t resolve your issue. So it’s still possible that the issue is self inflicted. the last time I saw it it was cause by an old version of nest protect.


#7

While it’s always possible that it’s a custom code issue for some people, I am having exactly the same issue with standard device handlers and devices on the compatibility list and no custom code at all. I had not made any IDE changes. This is new in the last two days.


(Andrew) #8

I know, let’s blame the user!

I have many custom device types, but I haven’t made any changes to my configuration in about a month. When things go south out of the blue with no changes on my side, my first reaction isn’t “what device type just broke my previously stable SmartThings setup that I haven’t touched in a month.” Rather, it’s “what did SmartThings screw up now?!”

It’s called regression testing, folks. Try it sometime.


(Andrew) #9

I’ve seen this once or twice now, too. Hitting try again has fixed it for me so far.


(Ed Meredith) #10

I have rooms with things in the ide but no things in iOS app. It is all jacked up. Hopefully ST will fix soon.


(sidjohn1) #11

I guess i take a different approach to ST than you do. I do IT support for a living and i understand the importance of a hardware compatibility list. ST has one too and my home is a mix of devices that are and aren’t on the list, but i’m not about to say that smartthings sucks because some devices don’t work, stopped working, works wonky, that ST never said would or a supported device with a driver i tweaked out. And as far as your comment about regression testing… trust me you can’t test for every smart or dumb thing a developer might try to do.

Now i never said ST was perfect, and i’m well versed with the ongoing issues with this platform, i helped kickstart it so i’ve been effected by every issue ST has ever had. Over the years i’ve found that enough of my issues were self inflicted that i start there first and double check any stupid thing i may of changed or not fully considered. I’m in the same cloud as you and my setup pretty much just works, it must be because ST likes me better than you then, and not possibly something you could be doing better :slight_smile:


#12

More likely it’s because, as SmartThings staff have said in these forums, they have some database flooding and corruption issues. That becomes a musical chairs game. Everything works fine for some accounts, and doesn’t work for other accounts. But there’s a fair amount of randomness to it.

I have no doubt that your system is working perfectly, and I’m happy for you. That just doesn’t change the fact that it isn’t working for everyone.


#13

We tried try again 25 times over two days. Same error every time. :scream:


(sidjohn1) #14

Seriously, my ego is not that big… that was pure sarcasm… While there maybe some randomness to who/what is effected, but I have seen wonky devicetypes cause issues in the ST app. If you are completely using supported devices and stock devicetypes then my post is not valid for troubleshooting, but if your not it is worth considering, unless you just like to complain on the forums, then by all means please continue and I apologize for getting in the way on the complaining.


(Andrew) #15

No,I’m sorry. This is still blaming the user. Props to you for supporting the kickstarter and being in IT. I guess the rest of us are just incompetent.

The first rule of troubleshooting is always to ask “What changed?”

Nothing on my side changed. So it’s completely rational to go pointing the finger at ST. take it as complaining if you will. Mind you, I’m definitely doing some of that. But I’m also offering a valuable observable to anyone actually trying to do a fishbone.

Also, did you see where I said that ST support said this was a known issue that they are working on?


(Andrew) #16

Yeah, that’s happening to me, too now. :frowning:


(Andrew) #17

Hey, whaddayaknow?! My Things came back all by themselves!

Anybody else?


#18

Yeah me too this morning.


(Glenn Smith) #19

Mine is blank, as is the family list.