Why are no things showing under "Things"

smartapp

(Peter Richardson) #1

Strange behavior in my app. The “Things” screen is completely blank, but when I select a room all of my things show up. They are listed correctly under the IDE and associated with the correct hub. Everything else seems as normal - and I have the same problem on both iOS and Android devices…

Has anyone seen this and how can I try to fix it?

Thanks


All things disappeared from the IOS App
(Kevin) #2

Try logging out of the app and logging back in. And for good measure do the usual… reboot the hub by pulling power and batteries for 15-20mins. Seems like that is the go to fix… like rebooting your pc. But also log out of the app and log back in after you do that power cycle.


#3

I have the same problem (“Things” list blank) since the hub FW update and have submitted details to support. My custom images also disappeared but returned after restarting/power cycling the hub and app. This did not fix the “Things” problem - the support team is apparently working on it.


(Peter Richardson) #4

Thanks- have been through the reboot of the hub and logging back into the app - nothing.

I notice when trying an android tablet I just get a spinning wheel on the things page.

Also, when selecting my my second location (and hub) things show up correctly when I switch to that location but now also show up under my main home! Very bizarre …

Fortunately still able to control through apps and by selecting room then the device to control.


(Eric) #5

I lost things view since iOS 2.1.3 updated. Waiting for support commentary.


(Mike Elser) #6

This happened to me after the last hub update. Turned out to be a custom device handler that was causing the issue. It worked before the update so I didn’t think it could be that, but it was. If your using any custom device handlers, try to remove that device or change it in the IDE to something else.


(Brian Murphy) #7

Same problem, ended up a custom device handler was the problem.


(Peter Richardson) #8

You guys are awesome. Had a handler, unpublished, for a DLNA device I was trying to customize. Changed that to the DLNA standard handler and the problem fixed itself.

Never thought a bad device handler could show up this way. Guess error trapping is something we could have more of in the core application!

Thanks - Ill let support know as they had passed this up to the developers.


#9

Deleting the custom device handler fixed it for me too, thanks!


#10

How do you know which to delete? I have a few…

Also, I have a device that just won’t delete no matter what I do (no dependencies), and bugs out when I try. How do I deal with that?


(Eric) #11

How did you know which custom device handler to delete??


(Peter Richardson) #12

Afraid it was trial and error - in my case I suspected one that I had modified myself.


(Robert) #13

Mine was a smart weather device, added the generic one back and deleted the old one, back to normal.