Introducing Companion Apps - not working/displaying

Ah well, looks like I’m gona need Mulder and Scully to solve this one

This is new with the latest release, wasn’t supported before because I didn’t have One UI 3.1 on my S20.

Perhaps @Brad_ST can throw some ideas in the hat ?

As far as I know Companion Apps requires One UI version 3.1 as others have stated. @fido if you go to Settings → About phone → Software information does it list a One UI version?

One Ui 3.1 installed, framework installed, unlocked Galaxy S10, just can’t seem to figure it out Brad, I have tried uninstall of framework, reboot, re install framework, re boot , tried every setting I can find in account settings incase it is something odd in there ?

I have no other ideas, the setup button on each companion app is just … non functional ?

Now tried re installing the ST app and framework Inc reboots, still setup is non functional ?

I just received the Android 11/One UI 3.1 update on my U.S. Tab S6 WiFi version. After updating, I opened the Galaxy App Store and there were a lot of app updates available including SmartThings Framework. I then opened the Google Play Store and an update to the SmartThings app was also available. After updating all of these apps, SmartThings is showing the Companion Apps now, and when I select them, they show a Setup button.

UPDATE:
And to answer my own question, ‘yes’ the Calendar feature for notifications on smart devices (my Samsung HDTV) exposes all of the Calendars linked to the Samsung Calendar app including Google Calendar. This setting even appears in the Samsung Calendar app settings.

What is the version number of your updated Smartthings app ?

SmartThings version 1.7.63.22.

Hopefully that version will sort some of my issues

I connected ST with the clock as a companion app. It wants to know bedtime and wakeup time and you can link devices to it as actions (like turning lights on or off)

Now that I’ve tried it, I want to delete it… but I can’t! I can’t seem to find anywhere to disable the link to the clock.

I’ve taken to setting a bedtime once per week on Saturday at 4:00 p.m. and wakeup after the minimum 10 min at 4:10 p.m. I have the no actions on the clock, so in essence, it does nothing. But why? Why can’t just delete that activity?

Did you select any devices to activate within the setting ? Tv ? Lights ?

Or moving on from that, drag your finger down the screen twice, search icon, search clock, select clock, this will show your alarms, simply flip switch to turn off alarm or keep your finger on the set alarm time until a tick appears next to it and hit delete at bottom

Or swipe up from bottom of home screen to access all apps installed and find ‘clock’ that way

Thanks!! I didn’t put “two and two together” as I didn’t go into the Clock application on my phone. I use it all the time, but didn’t look closely. When I did go in to look at alarms, there was the alarm that was set in ST. I simply deleted it like I do all the other alarms I add or delete.

Thanks for pointing out the obvious, which wasn’t too obvious for me!

1 Like

How to they resolve your issue I have the same problem now