Where to find the smart app i just published?


(Douglas L) #1

So, I thought I had this working yesterday, but now I cant find it. After I publish my smart app (“For Me”), where do I find it on my iphone app? I tried logging out and logging in. Yesterday, under Marketplace, I had a category call My Apps, but now that is gone. Thanks!


(Jim Anderson) #2

That’s the correct spot to look, in My Apps. If you have published a SmartApp for yourself and don’t see the My Apps category, you should contact support. Try quitting the app and restarting first though.


#3

Also try logging out of the app and than back in.


(Nicole) #4

I just tried publishing my first Smart App and I’m also not seeing the “My Smart Apps” category. I’ve tried logging in and out with no luck.


(Douglas L) #5

I contacted support. For me, I needed to log back in to the developer site and (again) hit the link that says become a developer. So, in my case, the system is not keeping me as a developer. Switches me out when I log back into the developer site. That seems to toggle “my apps” on and off.


(Nicole) #6

Thanks Douglas! I just tried this and it worked for me as well!


#7

Where’s the “become a developer” selection?

Thanks!


(Nicole) #8

Go to https://graph.api.smartthings.com/ and login. Once you do, the last sentence on the main page should say something like “become a developer.”


#9

I see a list of all the things I can do as a developer so I’m guessing I’m already in that mode. I’ve successfully deployed custom device types before although all the association was done via the dashboard, not the app. Still waiting for support to reply to my email to them.

Thanks.


#10

I just re read the thread and figured it out. There are two menus called smart apps! One is one the menu with rooms, things, and family, but the other is under marketplace. I hadn’t seen the marketplace one. Now I see the my apps selection and the custom smart apps I deployed.

Thanks!


#11

Hi @katgolightly, what is the issue you’re having? Perhaps someone in the Community can help.


#12

There seems to be an issue with the developer site in the EU - this seems to make this disappear and reappear (load balancing ??)

I can see Hubs, Locations and devices under graph-eu01-euwest1.api.xxx URL but for
SmartApps and Device Types they seems to have disappeared
it switches me to
graph-eu01-euwest1.api.xxx after logging in e.g
https://graph-eu01-euwest1.api.smartthings.com/ide/devices

If you remove the eu01-euwest1 part to graph.api.xxxx then the devices and device types reappear - but then the Hubs, locations and devices disappear.

Makes it impossible for me to add a device with a location as it can’t seem to see data from graph.api.xxxx and graph-eu01-euwest1.api. (e.g. no locations are defined in the dropdown)