SmartThings Community

Important Changes to SmartThings Classic Login System

Chargebacks are only possible for up to 60 or 90 days, depending on the particular credit card you have. Check your card agreement.

While it’s unlikely that the SmartThings Classic App will be deprecated in 90 days, there’s no guarantee of what will happen after that.

So it seems the clock is ticking for that … chargeback…

5 Likes

Not trying to be nasty here… Good luck with doing that.

4 Likes

You can’t change your browser to finish the log-in process then change it back? Why not?

4 Likes

Agree. That will wipe everything. I did that and had to rebuild my entire system from scratch. Gave up on the new app and just using the classic one.

2 Likes

Question, i finally got moved over to the new login and Android App. Many of my devices are “unavailable” now and i can’t figure out how to fix them? Do i need to remove and re-add them?

You should use the Classic app instead of the new Samsung Connect app.


5 Likes

If i use the classic app, everything is gone.

Go to locations and choose the other home location :slight_smile:

7 Likes

My hair is turning grey and developing bald spots waiting for the the new app migration while missus already has the dreaded message. Meanwhile I have the v3 and tearing off the rest of my hair and burying my head in the sand. :frowning:

2 Likes

While @jkp is downing a couple of cold ones. :frowning:

3 Likes

I’m in the same boat. I have a US account, and I’m currently located in Brazil.

Classic App shows SHM, and I currently have 9 water sensors and a siren to warn me of water leakage. I’m also able to add zigbee or z-wave devices using the “add” button in the Classic app.

My water sensors show up in the new app; but SMH is MIA; also, no option is presented to add zigbee or z-wave devices (sensors, light switches, etc) when I try to add a new device in the new app.

I might be able to live without SHM; but not without having the option to add new zigbee or z-wave devices.

I get that I am bringing the Hub out of a “supported” region; and although it is understandable that Samsung might restrict somefunctionality ; doing it while migrating users to a new platform, without informing these users that their hub will not work as it did before, well… that isn’t cool.

My point: Will this be permanent? Or is this happening as part of the migration process? If this restriction is permanent, I for sure am moving away from SmartThings platform before Samsung turn the lights out on the Classic App.

@vlad, do you have any information to share in this regard?

@dequinho
Get a temporary VPN with servers in US, have your router connect to it and add your new devices.

1 Like

That wouldn’t help as it’s a catalog issue.

The catalog in the new SmartThings app is driven by your Samsung account’s region. So a user in Brazil will likely have a Samsung account with a region of Brazil. As SmartThings has not launched devices in Brazil at this time, the Brazilian device catalog is sparse.

The frustration of this is not lost on me but this is currently an account migration and not an app migration. Users are still free to use the Classic app.

So…

What if the Customer created a new Samsung Account using a VPN to temporarily be in the region of the USA? Would he thus “appear” to be a user in the USA whenever logging into the SmartThings App?

2 Likes

If your Samsung account’s region is the US, you will see the US catalog.

Where it gets tricky, and potentially in violation of local laws, is that you will only be able to add US devices. For example, Brazil’s Z-Wave frequency differs from the US.

3 Likes

Just moved over to a Samsung account (banner has been showing for a while but I was holding off until change of tenants in the property).

Complex setup, tonnes of devices, webCoRE pistons for everything, ActionTiles, Nest etc. all rolled over perfectly so very relieved.

Have the two locations everyone else is mentioning, but they both appear identical with the same devices etc… not entirely sure which one to use lol but I’ll figure it out.

GitHub references all survived as well, so that bug must have been squished.

Hopefully not speaking to soon :crossed_fingers:

7 Likes

Question to anyone who has had this:

I am the main account holder, my wife has a secondary account to whom added to ST.

She has the upgrade notification on the ST Classic app (been there for about 2 months).

I have yet to receive the upgrade notice, so I messaged ST Support and get a pretty useless and pointless answer which didn’t address any of my questions (no surprise there).

I also asked them if my wife (Secondary user) is receiving the upgrade, why am I the primary user not?

SO my question:

  1. How can I upgrade her account to the latest ST app /account as surely her account does not have the rights to start the migration process of all the things?

  2. What happens if she upgrades now, does it effect her login if the things do not migrate ?

  3. If they somehow did migrate, then what happens to my account?

  4. Why can’t they manually trigger my account to migrate as the primary account holder?

Anyone have the answers here or have had the same scenario, support could not give me an answer as to when I will get the upgrade notice. all in all pretty unhelpful.

1 Like

Well, I had the same issue. My wife was listed as available to upgrade before my main account.

Waited until my account was ready.

Confusing process!! Lol

1 Like

Had the same – my wife received the upgrade notification several weeks before me (account holder). I upgraded her as soon as the notification showed (to avoid questions & confusion) and it was not an issue to have her upgraded and me (the main account) not.

1 Like

Ditto. Same here. Credit goes to support when I reported and was “upgraded”. :wink:

1 Like