IKEA Trådfri LED Driver 30W will not connect to Smartthings

I have severeal Trådfri lights connected to my Smartthings hub, but the Trådfri 30W LED driver is not discovered when searching for new thing. If I go to the hub’s event list however, it seems to discover it, but just ignores it. Any tips on how to solve this?

From hub event list:
zbjoin: {“dni”:“0C11”,“d”:“086BD7FFFE6175A0”,“capabilities”:“00”,“endpoints”:,“parent”:“0000”,“joinType”:17,“joinDurationMs”:0,“joinAttempts”:1}

I’ve tried holding them close, reset several times, update firmware, even replaced the LED Driver with a new one, but still nothing.

I talked to Samsung Customer Service, but that was a waste of time. Their conclusion was that I had to reset the hub, which I refuse to do as I have spent months to connect all the things. I asked them to change the zigbee channel on the hub as recommended on this forum, but since both products were bought in the same region (EU) they said it was not an issue. Does that make sense?
My hub is on channel 24.

1 Like

Your Zigbee channel 24 is good. Just use your wifi with channel 6 or below to avoid interference.

Try to move your LED driver to another location. Use the Classic App, start pairing, and then reset the LED driver to start the pairing process with it.
Or try the new app, add device, IKEA, Lighting, driver for… (you will see which one). Then follow the on screen commands.

Some IKEA bulbs are not pairing easily. You might need to move it to other locations first. And it might take multiple tries too.

1 Like

Bu the way what version of the Hub are you using? And can you just check what is the Zigbee radio version of it in the IDE?

Any custom device handlers installed in IDE? You can try opening them in IDE and Publish for Me again . Then reset the ikea device and attempt to add it.

  • Hub: v3 EU, firmware ver. 000.027.00009.
  • Zigbee version: 3.0.14.
  • Installed device handlers: edvaldeysteinsson IKEA-Tradfri and bspranger for xiaomi things.

I’ll try your suggestions later today. Fingers crossed!

On a side note:
Interference seems to be an issue while trying to add new things.
But I wonder; if interference is the problem, would that mean it wouldn’t find the thing at all, or it would find it but not be able to add it (like in my case, where the event list shows something is discovered but not added).

You can look at these topics.

People had already similar problems as you. Support’s suggestion to reset the Hub is to have it change the Zigbee channel from 24 to something else. It assigns zigbee channel when it is initialized.

By reset here, they mean factory reset which isn’t feasible for most people. It sounds like a developer can somehow force the channel to change without the factory reset, but I haven’t heard back from anyone about getting someone to do that.

Finally did it!
I’ve tried all the tricks mentioned in threads and forums that I’ve come over and probably 50 join attempts over several months. This is what did it for me:

  • Turn off all zigbee things nearby.
  • Turn hub off and on again (restart) (not sure if this is necessary)
  • Reset the Trådfri driver by pushing the pin in the driver reset for 10 secs (lights shall blink)
  • Wait 20 seconds then turn off the Trådfri driver
  • Wait 10 seconds then turn on the Trådfri driver
  • Search for Trådfri driver using the new ST app (add thing - Ikea - Lighting - Trådfri driver for wireless control).

It seems that interference from other things is more important than I thought. The hub discovered something with interference, but did not recognize it. I hope this may be the key to add any thing in the future.

Some other info that may be useful.

Wifi channel 1. Zigbee channel 24.

The event list now shows a zbjoin event where it was recognized as an Ikea Trådfri Driver.

The next event is probably just for information:

IKEA TRÅDFRI Driver for wireless control 30W added

2 Likes

neither this nor all other solutions didnt have results .
no hope anymore
i believe it’s pure luck … or you reset the hub…to change channel

I followed all methods mentioned in this post religiously trying for about a week but couldnt connect my Tradfri LED Wireless driver 30W to ST. Then I came across a post on connecting to Philips Hue hub. I followed the same method and it connected within minutes to ST!
Im not sure if there is any difference in earlier models of the Tradfri driver, but if they are same then all methods in this post are missing one crucial sequence. Here is how I connected:

  1. Connect atleast one led light to the wireless driver and switch it on. Do Not start pairing mode or reset yet. Keep the device as close to ST as possible. Mine was within 10 cm.
  2. First, on your ST start search for new device which will be Ikea → Ikea Tradfri Driver for wireless control.
  3. Next, then press and hold the reset button using a pin until the device shows up on your ST search. (When you press the reset button the light will dim and brighten up a few times and then will remain steady bright.)

For me within a minute or two the device was connected to ST.

Hope this helps people like me still struggling to connect!

1 Like

Hi. Thanks alot the input - but still not able to make it connect… What setting do you have on the led light? On, off or auto?

Thanks!

@haakonhenriksen: You just plug the Tradfri LED wireless driver 30W / 10W (the grey ractangular shaped device) to power supply and add atleast one led light as load to the device and the press the reset button (inside the pin hole). But before you hit the reset button make sure your ST add device is started and in search mode. Im not sure what you mean by setting on led light to be On, Off or Auto.

Thanks reply. Regarding the on-off-auto, its the setting on the light bar itself. Auto is responding on the infrared sensor when you have the light in a closet.
Ive tried your method several times but unfo its not popping up on my ST :frowning:

I see which light you are talking about. This post is about Tradfri Wireless LED driver, not a closet led light.
By the way, what do you want to achieve by connecting closet lights to ST? I mean, closet lights are automatic in the sense you open closet then light comes, you close the closet then light goes off. What else are you trying to do by connecting to ST?

Indeed, the led driver is connected to 3 closet lights in which one is outside the closet in the hallway corner. I would like to be able to turn on an off when it gets dark in the evening and in the early morning but off during the day.
The strange thing is that i had the led driver connected to my ST before but not able to connect it after i had to reinstall the entire ST. That is the big mystery why i cant have to to connect again…
The led driver is a few years old so not sure if may be the reason…?

By reinstall entire ST if you mean you did a reset of your ST then one probable cause could be your ST zigbee channel changed to 24. I have read many places that some Ikea devices dont like channel 24. Otherwise there is no reason why it wouldnt connect when all hardware are same and they were connected just before reinstallation.

Yes correct, reset the entire ST as my account was registerd in US and not Europe where I live so had som issues.
You are right, in the IDE page my Zigbee shows as channel 24.
What channel is recommended to be used?
Will it affect any other zigbee units?

Thanks a lot your help on this :slight_smile:

You are a saviour!!! It worked changing the channel from 24 to 20!!
Thanks a lot mate. Greatly appreciate fine support.

To those who want to try the same:
Go to the IDE page, log in and go to “My Hubs”.
Scroll down and click “view utilities”.
Select drop-down menu “change zigbee channel” max click “update” just below the drop down menu.
Refresh browser to see change.
Voilà!

@haakonhenriksen Glad to know it worked for you!! :slight_smile: