Ikea trådfri driver 30W fails to connect

Hello!

I am new to this forum hoping for someone to help me out.

I have bought two of Ikeas trådfri drivers, the 30w ones.
It feels like I have tried everything to pair them with my SmartThings V3 hub but it does not work at all.

Tried different button presses with the reset button, short press, long press etc.

Tried a guide involving pressing the button for 10 second, wait 20 seconds, then power off and back on after 10 seconds.

Tried pressing the button while plugging in the drivers.

Tried placing driver everywhere on top, under and around the hub.

I even gutted the driver in case the plastic housing would do some bad stuff.

I have read that wifi signals can mess things up and that it would be possible for some smartthings developers to remotely change the channel on the hub, but who would that be? Who do I contact about something like that?

The drivers worked just fine when connected to Ikeas own gateway so they are not broken or something like that.

Please someone, help me with this!

if you paird the with the ikea gatway 1st will they need unpairing?

To my knowledge all that is needed when “unpairing” is to reset them with the reset button. Cant think of any other solution to that perticular problem :man_shrugging:

Hi, I have the same exact issue With 2 of 3 Drivers. I’ve tried everything. Moving the drivers near the hub, which was not needed for 1 of the drivers, it just one day popped into smartthings. But With the others I have not been able to Connect. Added it now back to the trådfri gate to see if it needed a firmware update, that was not needed. Any ideas?

I have also tried the 10+20+10 Seconds suggestion.

Sound like we tried basically the same things and it sucks that it don’t work. If there only was some answer to why it won’t work, like if there is a known problem that ikea are aware of or Samsung for that matter. I am not ready to give up on this but this is not what I think of when hearing the term “Smart home”

As for now I am fresh out of ideas :confused:

Maybe this will help?

I figured out why Im having this issue. My hub uses Channel 24 for Zigbee, whicch is not a good fit for Ikea it seems.

Hi, I’m having the same problem as you @Jaggenite. Did you manage to connect your Ikea Driver?

@Foley Did you do any progress? Do you have anything to share?

I have tried all the above solutions. I am using ST Hub v.3 and tried in both New App and Classic App.

Anyone have a suggestion for me?

I finally got mine to connect. I reset my hub and the hub changed my Zigbee channel form 25 to 19. Then I just reset the driver and Smartthings found it. Did not need to have it anywhere near the hub or do any of the steps mentioned above. :slight_smile:

I was able to connect it as GE Dimmer control. I had to do couple of 10-20-10 resets

Hi All,

For anyone having trouble with adding a driver I am on channel 24 and was trying for hours to connect this. I put the driver on top of the Smartthings hub, then wrapped it all up in aluminium foil. pushed the pairing button and it paired instantly, worth a shot for anyone struggling still.

I tried for days with no luck after taking apart my closet install and taking the driver down to my hub and setting it on top. Gave up and reset the Ikea equipment and just used the 5 button remote alone directly with the driver (the button paired fine with ST hub v2 the first try while the driver wouldn’t).

I hated the solution, but my Zigbee channel was on 24, so I had to do a factory reset on my hub and it set it to 19 on reset since ST doesn’t let you modify the channel. My driver is installed in my closet 30+ ft away through walls and I didn’t want to disassemble my trim that hides the wiring. It paired the first time after resetting the driver with no issues and didn’t have to bring it close. Some Ikea devices just don’t like channels 24/25, some are just fine with it.

Now I have to go re-join all my equipment and set up my automations all over again but at least everything works now.