Ikea Tradfri Button (square)

Same here. Started a few days ago…

Hi @Brad_ST, has there been any progress on this?

When I create a dud device using the IDE with the IKEA Button DTH I can see all of the tiles within the device page but as soon as I try setting up an actual device via the app I just get the blank screen.

I understand this is a 3rd party device so not Samsungs issue but the main reason most people use SmartThings is for its ability to use sensors and remotes/buttons.

If there is anything I can do as a user please do let me know.

The IDE and Classic app don’t use the device plugin that the new app does. The appropriate team within ST is working to get their fix out to users. Unfortunately I don’t have insight into the timing of the release. Thank you for your patience and offer to assist where possible!

Interesting. The child devices are updating their name but the parent device is failing to save. After testing, it seems limited to the IDE but applies to other multi-component devices.

As a workaround, you can rename the device in the Classic or new app. For the new app, from the Device list, tap the kebab menu in the upper right corner to edit the device. This pathway doesn’t load the plugin so there shouldn’t be an issue updating the device name or room.

Isn’t it just, and when it is first noticed at the same time as the display issues affecting the same types of devices the apparent correlation does raise eyebrows, if not suspicions, even if it is just coincidence.

I always use the Device Label for the friendly device names anyway.

Changing the Device Name field and updating is my standard approach to force the new app to reload the device presentation, so I was trying it to see if it made any difference to the display issue in the app.

I have the same blank screen issue with Hue Dimmer. Again in the old app everything just works… the new app seems to be too complicated for your own good. And as a user, with the new app I see no benefits.
Only still some custom DTHs don’t work as well in the new app and I can’t be bothered, and shouldn’t have to be bothered to investigate myself how to use this CLI thing to fix things myself.
And this is one of the reasons after 4 years as a happy ST user I’ve just purchased a Hubitat. The ground is shifting under my feet and things that I’ve come to take for granted are breaking. The outages this past week were the last straw. I’m sure in time this system will evolve into something better from a Sumsung perspective, but I see so much pain ahead and so many breakages ahead.

Wow! Just checked my Ikea Tradfri square button on the new app and the blank screen isn’t blank anymore! Battery level, button configuration settings & switching history all there.
Able to configure button actions too.

yup, minimotes working again too.

I would be interested to know what the root cause was.
But great news on finally being able to ‘push all the right buttons’

It is still blank on mine

Still blank on mine…

Kill app and restart with the auto update set to WiFi in your setting.

Yes, mine just came good, also.

YES! It’s back!

Force close and cache clearing did not help. Uninstall and reinstall of app worked. However, rooms were rearranged in some random order.
Anyway, Ikea devices look normal now.


I just attempted to add an IKEA Tradfri dimmer (round, A/V Receiver style) to my SmartThings Hub (V2, Firmware Version It seemed to pair fine (including the four quick pairing button clicks), and it showed up in the app. When I try to select it in the app, however, I get the “Can’t connect to device. Check device and try again.” message. It shows up in the online portal (graph.api.smartthings.com) with a Zigbee Id, a DNI, and status ONLINE. It even shows activity at about the right time. Force stop and restart of the app did not help, nor did repeatedly resetting the dimmer and re-pairing it. @Brad_ST, any thoughts? Is there any information (logs, versions, update times, etc) I can provide to help troubleshoot? Thank you for your support!

This is still happening… I also tried detecting the device (when in pairing mode) and both the Classic and the New apps discovered the device, but could not interact with it afterwards. @Brad_ST, it would be great if you could at least confirm that the ST team is still working on the issue, or if it’s supposed to be fixed for everyone. Thanks again for the support!

@aburst42, Have you used any custom DH with that device or just the stock one?
With the stock one you should have a dimmer with on/off.
Check first what DH are you using and report it back. Otherwise what version of the App are you using and what operating system?

If you are talking about the tradfri remote control with 5 buttons, i just re added one to the new app the other day, it uses the device type: ZigBee Battery Accessory Dimmer.

I still had to do some final pairing it by holding it next to the bulbs I wanted to control though.

@impee, this is the rotary dimmer (Simfonisk) and switch (continuous turning, rather than 5 buttons). I’m trying to pair it with the SmartThings Hub, so it can participate in Automations, rather than directly controlling devices.

@GSzabados, I’ve tried the built-in integration, as well as the two custom DHs from this repo. Both seem to pair the button, but don’t receive any events from it beyond that (no parse method call). My ST app is version (“latest version already installed”), on Android 9, running the latest patches on a Samsung Galaxy S8. There are a lot of versions reported, for various subsystems, do if any one of them is relevant or helpful, I’m happy to report it. Similarly, if there’s a better custom DTH to use, please advise. Thanks!