IKEA Tradfri 5-Button Paired..actions all wrong

Easily paired an Ikea 5-button remote to a V2 Hub. When pressing the buttons (push or held) it registers in the app and also in the live logging. I added a single action to each of the 5 buttons. This is where it goes nuts.

Pressing the TOP button…it triggers the actions defined for…
RIGHT Button
LEFT Button

Pressing the RIGHT Button…it triggers the actions defined for the TOP Button.

None of the other buttons will trigger an action.

All of the buttons, like I said, do register Pressed and Held as they should in the app and in the IDE…but the actions don’t seem to correspond.

I have a 2 button Ikea remote (the rocker) and it does a similar thing, where the “Press” event actually triggers the OTHER action; like it’s reversed.

I’ve deleted and re-added the devices and the same behavior happens again, consistently. Any thoughts on where to troubleshoot this next?

Thanks in advance.

1 Like

Maybe wrong print on the buttons? I have 2 of those and they work great

So the presses are correctly identified but the wrong actions are performed?

How are you defining the actions for the buttons? Using the ‘quick actions’ on the device details page? If so do they look correct when viewed from the Automations page? Does deleting the actions stop them happening?

correct…the correct button responds in the app (and also on the live logging) . it just doesn’t trigger the action defined under that button.

Live Logging:
11:53:04 AM: debug Creating event: [name:button, value:pushed, data:[buttonNumber:1], descriptionText:IKEA Remote Control top button was pushed, isStateChange:true, displayed:false]
11:53:04 AM: debug Parsing message from device: ‘catchall: 0104 0008 01 FF 0000 01 36DF 01 00 0000 06 00 002B0500’

In the screenshot below, that should toggle the “Office Overhead - On or off” action, but it actually triggers the actions that are defined for the Bottom Button, Right Button, and Left Button.

Also, if I press the Right Button, it will trigger the action defined for the Top Button (the Office Overhead)


Well, it registers the right button name in the app and in live logging…just doesn’t trigger the action associated with that button press.


Baffled really.

I see odd things happen with quick actions but usually it is things like multiple versions of the action (as seen on the Automations page).

I see what you mean, it seems like the “Quick Controls” are not mapped to the correct buttons (Example: My “Right” button “Quick Control” is actually running the “Top button” action). I’ll report this right away.

I’d recommend using Automations for this, not only because of this issue but because they have much more robust capabilities as well (Example: Inclusion of Location Mode or other variables in the “IF” section).

Thanks for bringing this up.


@garrett.kranz possibly related, on the latest iOS release: you can see the quick control is setup, but when you tap to edit the app acts like you’re starting from scratch.

1 Like

That could be related, as I was finding in testing that the “Quick Controls” aren’t mapping to the correct Button component.

I searched for the resulting Cloud Automation for the “Top button” Quick Control I made, and it is indeed incorrectly mapping to “Button2” which is actually the right-side arrow button of the Remote.

So in your case, @Automated_House I think it is pulling up a different Button component than what you have this existing Automation created (I assume this still works, right?)

Reported this for further review and resolution. Seems to not impact Android in my testing as an additional note.


Confirmed that doing this as an automation works ask expected. I’ll just use automations vs. quick-controls…but would be nice if that worked as expected.

The mapping is also off on the IKEA small remote…which was just backwards, but both up and down buttons still worked.

Thanks. I’ll watch this thread for future updates if the quick controls mapping gets updated.

1 Like

I’m new to Smartthings and having this exact issue. How can I switch to automations from quick controls?

@RMN, Instead of using the Device’s quick control options go to the top left hamburger menu and then Automations, there you need to build the Automation by IF device status and selecting the remote and then the button and the press what you want as a trigger.

Then do the THEN part, basically the action what you want.


I’ve managed to get the 5 button working again by using an older version of the app. My old iPhone still had the old SmartThings app (from late 2020) which allowed me to pair and setup all the buttons flawlessly. I know this won’t be possible by everyone but if you have an old version of the app. Confirmed the new app is the problem (for me at least) by trying to use my current iPhone for the same process and hit the issues listed above in this thread.

It seems that the next button down triggers the programmed action on the 5 button. I’ve also found that I can’t reprogram older ones, which thankfully still work properly. It is positive that the automation supersedes the direct Quick Control assignment since once assigned you can’t remove a selection and this mismatch issue. I just bought a bunch so I’m hopeful this gets resolved.

I just got two of these yesterday. When I set up the first one it paired fairly easily but I configured a quick action and nothing worked with it, I didn’t even see any button presses in the device history. I then removed the remote, factory reset the remote, and repaired it. This time I created a full automation and it worked as expected. For the second remote I paired it the same as the first and went right to creating a full automation. I didn’t have a single issue with the second remote. I am using the new Aeotec hub and the latest iOS SmartThings app.

1 Like

I am having the same issue and not sure where to start. I have deleted and re-added it and the single on/off button. they both will connect to ST but buttons are backwards or upside down. Not sure if fix would be the Ikea hub or maybe different DH? Open to all ideas.


Are you using the iOS app?

Follow this:

Or if on Android, update to the new 2021 app and hope that the bug is fixed.

@Brad_ST, is it fixed?

I think the bug with button quick controls was only iOS? They’ve said it’s fixed in the new app version, which is the big update due soon for iOS.

1 Like

I believe it was IOS as well

1 Like