Ikea 5 button remote no buttons

I’m trying to add an Ikea 5 button remote to ST. I am using the new app and adding a New Device, Ikea, Remotes and buttons. ST finds the remore and adds it as Tradfri remote control. However I see no buttons just the battery level and Activity history which is empty. Is there anything additional that I need to do.

Which hub are you using? The newer Ikea devices require some Zigbee features that some of our older hubs do not support

Im using Smartthings Version 2

@Richard55UK, Try to re-pair it, and meanwhile look at the live logging for any error message.

For re-pairing, put the app into pairing, by selecting the device from the list of IKEA and press 5 times the button on the back next to the battery to reset it. A red LED should come up on the front.

By the way, have you ever tried to pair this device with a custom DH? If yes, then you first need to delete that.

I bought the wireless outlet( plug socket to me), and their 5 button controller today from IKEA in the UK.
Neither were found by scanning from the smartthings app on my phone. However they both now work easy peezy. Here’s how. The plug was easiest, just sel;ect it from the ADD devices, ( I’m v3 hub ), IKEA section. Push a paperclip up the hole on the bottom of the plug, ( don’t worry its also the method explained for their own hub). It connects and works immediately. For the 5 button controller it was a bit more fiddly, but easy. You need to select it in smatthings, then afet putting the supplied battery in, press 4 times quickly the link button inside next to the battery. First time it didnt work and I wasted a couple of hours trying other things. Then I just deleted it from smartthings and redid the process and it works fine, ( for the moment ?). All buttons and I can create an automation to switch the power outlet on and off. One Tip, when it wasnt working, their was NO indication of battery status, NOW it is working, the battery status is fine. I will continue my search for reliable inexpensive add ons to my HUB. Cheers

I have deleted and readded the remote several times in both the classic and new app but with no luck. It does show the battery at 0% even though I have changed the battery for a new one. There are no errors in the IDE log.

Ok I’ve found the problem. There was a custom device handler that I must have tried using in the past and forgotten about it. Now that I have deleted the custom device handler the remote has now added ok and I can see the buttons. Thanks everyone for your help.