Ikea buttons stopped working

I have a new issue since today.
The story began yesterday: My smartthings hub v3 from aeotec didn’t connect to the internet anymore. So I tried to factory reset it, which worked after like 3 hours or so and a router reset. It just did not want to connect. However. With that I lost the functionality of my Ikea buttons. I’m talking about the single button “Shortcut Button” and the 4-button “Styrbar” with push and held functions.

Since ST decided to change everything (I am about 1/2 or 1 year not uptodate anymore).
The old .graph… domain has changed to the new interface my smartthings com and the edge drivers.

Now I want to use the button again of course. I already tried to install many different edge drivers but either they are not for my buttons at all or don’t work at all. Sometimes I also get a http 500 error when installing a driver:
Error uninstalling driver “”. 500 unsuccessful-http-call status=500
(This is one, if I try to uninstall a driver. I have no idea whats goinig on: I could easily install them). But the message is more or less the same.

Does someone know how to fix that i.e. how I can make my buttons usable again?
The “Smart Things” driver doesn’t provide any functionality.

I’ve tried the following:

But I couldn’t get the buttons run.

This Edge driver works for the Shortcut button:

1 Like

After spending another few hours in trying everything possible, the fix for me was it to create a new Samsung account and start from the very beginning. Even though I deleted every device and did factory reset my Hub, for some reason the Ikea bulbs and all other devices (all from Ikea) couldn’t even be connected to the hub anymore (which was possible just a short moment before…): weird glitch because they did as the flashing lights went off but they we’re not included in the cloud so I simply couldn’t use them nor delete them again.

Creating a fresh account did it for me. To make the 4-button switches work I use

But shortcut button was not working. Fix for that was to use the Driver mentioned by @BlackRose67
Thanks for your reply by the way.

This is documented a bit more in detail for the Case that someone else will experience the same issue.

The problem is solved with this.

I’m also having issues with shortcut buttons. They were originally working on zigbee button edge driver.
But stopped.
I deleted and repaired and ended up with just a zigbee thing.
So I tried the driver suggested by @BlackRose67 and it was detected as a button. The issue is that the key presses don’t have any effect.
Any ideas?

I’m also having a kind of the same problem.
It recognizes hold quite good but the press only a few seconds after a hold.
What about you? Does your ST recognize hold?

I don’t have a solution to that yet but will comment it, If i’ll manage to make it work.

Just tested one of my Shortcut buttons and it handles both Pressed and Hold without issue.

I have 2 shortcut buttons.
Neither are registering single double click or held presses.

Update, I deleted and reinstalled the two buttons again. I got them working.
Instead of using scan for nearby devices like before I added devices by brand ->IKEA->IKEA buttons.

I got a warning via this route that the hubs memory was almost full and to delete some devices, but it completed and worked.

I don’t have that many devices, certainly nowhere near the 200 limit.
I have 117 devices including some virtual devices and some smart life scenes which appear as devices.

I have gone to my hub settings and tried to delete all drivers or channels not in use.
I deleted a few but the install wizard still moaned about hub memory full.

Any tips to check or clear this out a big.
Does a reboot release any after drivers are deleted ?