Ihome isp5 Smart Plugs No longer working properly...keeps getting disconnected from ST


(Squatting Hen) #1

I have 5 ihome smart plugs that have worked flawlessly with the ihome app, apple home kit on my phone and with smartthings. I have smart lighting setup and routines that have included the switches and they have worked perfectly. About a week or so ago, I noticed they would become unavailable on smartthings. They would still work with the ihome app and apple homeki, but not with smartthings. They would eventually come back, but then randomly fall off again, sometimes 10 times a day. This didn’t happen until recently. Again, they are only not working in smartthings, ihome app and homekit they are still working 100%.

What happened? How can I fix this? Was there a back end update like wemos? Really need to get this to be working again.

I contacted support and they said they are not officially supported…? Man… What us officially supported with smartthings? I thought these were. So what can I do besides buy all new plugs?

Pretty frustrating… Again. Seems like when one issue resolves itself another one pops up here. I am starting to think my hub is the issue.


iHome SmartPlugs Will Not Connect
Ihome plugs keep losing connection
(Eduardo) #2

The same happened to me, I already tried resetting my smart plug and it didn’t work :rage:


(Squatting Hen) #3

Something must be going on with these then. I know wemos sometimes have connection issues and smartthings corrects them. Hopefully this is the same type of issue. Seems to be but just have to try to get someone to look into it…

These are my main plugs, only plugs, because they have been so reliable. Now though they are useless with smartthings.


(Scott) #4

I have the same issue with both of my iplugs. Working when I got home, will attack to wi fi, but ihome app, nor Alexa will see either. Reset to reconnect to wifi, looks ok, apps can’t see them however.
6/20/17, about 9:00 pm when they both seemed to go off line.


(Squatting Hen) #5

Here is an example. This has been happening not just yesterday. All five of mine have been doing this recently, sometimes cycling like this 5-6 times a day.


#6

I’m sure that’s very frustrating. :disappointed_relieved: Definitely report it to support if you haven’t already.


(Squatting Hen) #7

I did. Their reply was, “To start, please note that the SmartThings platform does not officially support the iHome plugs, so there is no guarantee that the plugs will function properly…”

Yet, SmartThings is listed on the box and:

http://www.marketwired.com/press-release/ihome-and-samsung-smartthings-announce-integration-for-seamless-smart-home-control-2147688.htm


#8

That is really weird.

@tyler do the iHome plugs no longer work with SmartThings?


#9

Sounds like there was a miscommunication somewhere. Yes, we still support the iHome outlets. I’ll follow up internally and see what’s going on.

Hang in there!


(Squatting Hen) #10

Thank you. This is from the developer portal. (not sure if that is the right name for it) All my ihome plugs have been doing this. I just called support, last time I did this by email which is where I was told they were not supported. The tech said they are still supported, but they are still trying to “work out the bugs”. I bet they always say that. lol. He wasn’t sure what was going on, but suggested to remove them from iHome (factory reset them) add them back up and see if that helps. I know that is the default method, but that is time consuming. I guess I can try that, but I will wait to hear back from you first.

Hopefully it’s just an issue like the WeMo’s have every so often, and you guys can get it fixed behind the scenes…


(Squatting Hen) #11

@Tyler

Just received this email response…


#12

Still following up on this, sorry for the inconsistent messaging.

This device is still supported and we’re in touch with the developers at iHome about this issue.


(Squatting Hen) #13

@Tyler Things seem to be back to normal so far today. I do not see any that have been disconnected on the recent history. Were you able to find anything out on this? As you can see from my above screenshots, I had been experiencing issues daily for a little while now. Even though it appears to be working properly at the moment, I am curious as to what was discovered, if anything, and if there were any back end adjustments made. I hope so, as I am not looking forward to having these same issues reappear.

Thank you.


#14

iHome had some sort of outage yesterday and we think it’s related. Glad to hear it’s back to normal. We’re still digging in and if we find anything that was wrong on our end we’ll fix it ASAP.

Thanks!


(Squatting Hen) #15

Thank you. That explains yesterday, but my concern is, and my picture in the post above shows, that I was having issues before yesterday. Maybe the outage and repair of that outage also corrected whatever issues I was having…?

If I continue to receive the disconnects and connection issues like I had been, I will reach back out here instead of emailing or calling customer support.

Regardless, I am happy it is working again. Now if I could just get our phones presence sensors to be more reliable, I think I would be set. :slight_smile:


#16

Sure, I understand that the issues were more than just yesterday afternoon. It sounds like we don’t have all the info yet, but it seems to be pointing towards some sort of platform issue on their end. We’ll keep our ears to the ground. Thanks again!


(Nick Looper) #17

Same exact issue - I’ve removed and re-added my iSP5 plug several times, but it still shows up as unavailable. It works just fine from the iHome app.


(Eduardo) #18

Mine is working again maybe just a minor glitch


(Ron Couturier) #19

I constantly have problems with Alexa and the smart plug from my ihome but yet Apple home always works. There seems to be only a problem with Alexa for me is there a reason or a fix?


(Joel P Dietz Jr) #20

I have 2 iHome smart outlet plugs and they have been doing the exact same thing since this issue was first posted here. Everything was working fine until then. I purchased them as a double pack at Sam’s, model #'s iSP5.
Very, very frustrating.
In a 24 hour period, they connect and disconnect countless times. Looking at my Smartthings app right now it says that the two plugs are connected, but they do not respond (grayed out). When I go to the iHome app I see that there is are red asterisks next to the named devices. So I have to reconnect (lengthy process) through the iHome app
I have a 4 hub wifi mesh system running at 65 Mbps, so I know it is not my wifi.
Today, I figured out what the issue may be! I have both plugs/lights up and running in the iHome app by reconnecting them to the app (red asterisks now gone), then I went to my SmartThings app and they would not respond, I then removed both plugs (using the gear icon) in SmartThings. I then tried to add the plugs… at that point, you are in SmartThings required to link your iHome account with SmartThings. This is when I get an error message that looks like this:

{“error”:true,“type”:“java.lang.reflect.UndeclaredThrowableException”,“message”:“An unexpected error occurred.”}

So IMO it seems there is an issue with SmartThings and iHome connecting accounts and the issue with iHome plugs/outlets constantly needing to be re-added to the iHome app.