iHome Smartplug


(Randywgreen) #1

Is there a way to have the Smartthings v2 hub recognize the iHome SmartPlug?


#2

Not at the present time.

By the way, I had this plug for my HomeKit installation and you have to sign into their app every two or three days or loses connection with the Wi-Fi network. Since I was using a different app for my HomeKit operations, I kept having the plug be unavailable. So I ended up returning it and getting a different brand. Too bad, because I really like the form factor.

Based on the Amazon reviews, I wasn’t the only one who had the same issue with it

edited to update

As @LoganMarshall1 notes below, this device is now officially supported by SmartThings. Also, they’ve made a lot of improvements in it since I ran into the problems, again reflected in the Amazon reviews.


(Randywgreen) #3

Thanks for the reply. Thats what I was afraid of. No wonder I got it on sale.


#4

They doesn’t appear to be an easy way to talk to these. Wink used a cloud to cloud integration to work with them, and iHome is refusing to publish data on how to plug into that. It’d probably take SmartThings talking to them directly to make it work. The plugs make an outbound connection to the iHome servers, and only APPEAR to support homekit locally.

Easier path might be modifying the “Qwirky Connect” code to use Wink as an intermediary.


(Randywgreen) #5

I will take a look at the Quirky Connect code and see if I can find anything useful there. Did you run Wireshark to see the plug making the outbound connection to the iHome servers? Thanks.


#6

I looked at the connections on my router. Couldn’t wire shark the exact commands going to it as I’m on WAP2. Wireshark did show the homekit brodcast chatter though. Doing a port scan on it, only port 80 is open.

It profiles as a AzureWave platform, cant find any homekit dev platforms that use that… So they wrote everything in house it looks.

The qwirky code will need a little work, as it just supports the stand alone devices right now. With a little tweaking you can list the “switch” devices, and then hook into the smartplugs. Homebride did this for it’s wink connect stuff, so if you can read the Node.JS stuff it should provide some guidance.


(Logan Marshall) #7

I think its supported now, FYI. https://support.smartthings.com/hc/en-us/articles/211523263-iHome-Control-iSP5-SmartPlug


(Panapakkam A Ramamoorthy) #8

LM1: I went through the instructions and added iHome account to SmartThings but I do not see the switch iSP5WWC (that is what the box says but iHome has only WC). I had problem even with iHome app in Android 6.0, Note 4 phone (the green light keeps flashing indicating it is searching for WiFi network). I took it closure to the router with no help. Briefly the app says connected to iHome smartplug Y51F2F but then comes up with wrong pin message. The switch shows in my phone WiFi list as connectd with IP address as 192.168.10.2
I have my router under password control and the iHome app is not asking for it. I flashed the router with DD-wrt which does not allow WPS pairing. So, it needs to be done manually but there is not much info on how to enter it in the router. Any help? TIA


#9

Setup the smart plug in the ihome app and have it functioning there first. To do this you can’t use a 5ghz network it must be a 2.4ghz network. I had to forget my 5ghz network in my phone as the phone kept going over to it and messing up the discovery process but once I did it was discovered and configured fine (without wps, I hate that sh*t). After that is as simple as logging into my ihome account in smartthings and my smart plug (isp5) showed up immediately.


(Panapakkam A Ramamoorthy) #10

Thank you and that is my problem (your first statement). It is not being connected with the iHome app itself (pin error). I looked at their app for iPhone in which there is a step to give the router password which is missing from the Android app steps. I wonder if that is the problem (how would the device know what the password is without asking me unless they go through my phone completely which is really dangerous)!


#11

again I ask, are you using a 2.4ghz network because I had similar issues until I did.


#12

Hey, different person, but I’ve tried from both a 5and 2.4ghz network and it hasn’t worked. I’m using a Google Pixel phone, connected to a 2.4ghz as per your suggestion and had to sideload the ihomecontrol app since it won’t show up in the play store (not supported on my device currently). The ihome app discovers my iSP5 plug and then I enter in the pin, it searches for wifi list and switches my 2.4ghz connection to the iHome SmartPlug wifi the plug creates and since it has no internet connetion the ihome app times out trying to connect. I have tried forgetting the smartplug, resetting it, tried with both 5ghz and 2.4ghz connection, and I tried switching the wifi to 2.4ghz after it automatically switches to the iHome SmartPlug one when trying to set up the plug.


#13

Mine took a while to set up too, as I said I had to make sure it was only on the 2.4ghz network. I’d suggest trying to do the activation on another device. I had done it over recently on my tablet and it worked easier than with my phone…not sure why but it worked out.

I find it to be quite u reliable though. It loses wifi connection every few days and doesn’t auto reconnect on its own for some reason.


(Joel W) #14

I have three IPS5’s and one IPS8 with power monitoring. Where do you see the power in SmartThings? I see power in the iHome App.


(Mike Green) #15

My problem is slightly different. I figured out the 5g issue and got the plug setup in the Ihome app. I even got it setup with alexa. My problem is that when I try to link it to smartthings, it doesn’t give me any devices, just a selection for default location. I’m not sure what that is about. The text says the devices will be added automatically. Was I supposed to link accounts before I setup the device?


(Robert Tippett) #16

Exactly the same issue for me. It’s as if it connects fine to iHome cloud but the cloud is not reporting devices correctly.


(Robert Tippett) #17

MjGreenjr, Did you get anywhere with this? I’m having the same issue exactly. It seems to be completely on the Smartthings side of the equation as I’m not having any issues getting the iHome smartplug to be seen by Google Home.


(Mike Green) #18

iHome and Smartthings support both say it’s an issue with iHome. iHome suggested I try using the Wink app (no clue why) but that didn’t work either. All they will say is that they’re ‘working on it’.