IFTTT ST Switches Not Appearing During Applet Setup

SO I’ve read over all the other IFTTT threads and can’t find a resolution so I thought I would start a new one.

I have confirmed that I added ST and the switches properly to IFTTT seeing logs i see the following:

12:30:21 PM: debug [switches:[LG Dryer, LG Washer, Family Room Lamp, Garage 1 Outlet]]

I’ve added it using IFTTT and also confirmed in the IFTTT smart app and both result in the above login output.

Also IFTTT it says ST is active and i’ve confirmed my switches were selected:

But when I go to create an applet in IFTTT when I try to select the switch from ST the list is empty and I connect select any switches

Anyone else experiencing this?

I had something similar. I was setting up my Echo to turn on a hall light when the Echo alarm went off but I wasn’t seeing any lights in the list so I went to the ST app, Automation Smart Apps tab. Selected IFTTT and where it says which switches I deleted everything I have installed in there and added it again. Now it shows up in the IFTTT app.

I’ve tried that to and didn’t help. No mater what I do after I connect ST to IFTTT and add devices I don’t see anything during applet setup.

Ok, under IFTTT, My Applets, Services Tab, scroll to the SmartThings Icon and select it, Then click the Gear Icon and see if it says Status: active. if not you can select the Edit Connection button and put your info back in

yep did that too

I’m facing exactly the same issue. It wasn’t the case when I 1st connected ST to IFTTT. Tried reauthenticating ST in IFTTT and removing and adding devices in the IFTTT smartapp in ST but none worked. Any solution ?

I am also experiencing the same issues here now. With the recent smartthings failure at the beginning of the new year I was forced to factory default my smartthings hub (v2) and set it all up again. I have not been able to integrate ifttt functionality again since. Everything shows working in the app, api, and on the ifttt app and website GUI, however every single time I try to add an applet I see the “please select a switch” option in the drop-down for the smartthings service config. Even deleted ifttt in the smartthings api page and re-added since it said the last update was 2 weeks ago which is when this all began. Updates now show in the ifttt page on the smartthings api when changes are made but I still cannot select any of my devices in ifttt. Is it safe to assume this is an issue with ifttt and not smartthings?

The only thing that fixed it for me was deleting the smartthings ifttt connection and reconnecting all over again. It then worked. Hope this helps

Deleting and reconnecting worked for me. But also make sure to remove IFTTT SmartApp on Smartthings Mobile App after deleting Service. If you have multiple hubs delete SmartApp in all of them.

I’ve gradually been adding Z-wave sensors to a ST hub and Smart Life outlet switch devices to my home automation setup. I had originally added a thermostat and extended sensors and a smart plug to the setup. After including new Z-wave devices and seeing these in the ST app, and ST being active in IFTTT, and several deletions and re-connections of ST in IFTTT later, I was still not able to see the new ST sensors in IFTTT. I then found this thread and found the solution provided by @MANOWAR. I had stumbled on this fix previously but had forgotten where in the setup the sensors were authorized for control by IFTTT. Editing the ST service to authorize IFTTT to control the new sensors as @MANOWAR suggested fixed my problem.