Icon reverted back to default, can't reassign, Echo can't see it

amazon'alexa'echo

#1

I have a Smartthings socket that I plugged a lamp into. I assigned a lamp icon to it, and I now have Echo integrated and it could see it.

But this afternoon, Echo quit seeing this particular device, and the icon in my Smartthings app shows a generic socket…and gives me no option to change the icon. I can’t figure out what happened. I can still turn the lamp on/off via the Smartthings app, but Echo can’t see or discover it. Strange.

Edit: I did a little searching and the icon problem seems like an old one (I found similar posts from Dec last year).

On a side note, my Smarthings Android app has crashed 3 times this afternoon also…that’s new.


List of Community Known Issues
(Mike Maxwell) #2

Not alone…


#3

Interesting. I totally removed the Smartpower Outlet, and then repaired it with Smartthings. I then rebooted the hub. Still no change…I am only offered the default icon. The Smartthings app won’t give me the option of changing the icon.

And Echo can’t see the Smartpower Outlet either…even though it shows up in the Smartthings app, and I can control it via the Smartthings app.

So it seems to be Smartpower Outlet specific…since all of my other devices are fine (and I only have 1 Smartpower Outlet).

Frustrating, because everything was working just fine 4 hours ago, when I initially installed Echo and had it discover my devices.


(Eric) #4

I let Alexa into the ST playground yesterday. Methinks they have something hosed within those efforts.


(Mike Maxwell) #5

The issue with the icons has nothing to do with the echo, I don’t know about that problem.
Apparently the device for the zigbee outlets was updated, and the icon preference was removed. Two separate issues, though the cause may be the same.


#6

Interesting. I do think the issues are related…happened at the same time.

I only figured out the Echo part when I tried to demo Echo to my wife. “Alexa, turn on the Den lamp”…“I’m sorry, there is no device with that name in your list”. After asking Alexa 4 more times, I gave up and tried another device and that worked. My wife is skeptical about Alexa (asked me how much it cost…never a good sign).


#7

My echo integration blew up today. Definitely poltergeists in the cloud, moving stuff around.

Report all weirdness to support@smartthings.com


(The fish is still dead.) #8

'round these parts, we call them “developers”.


(Dawn Fairbro) #9

Thank you all!!! I was going nuts trying to change my icon back thinking that I accidentally hit something. :flushed:


#10

Hey all!

There are (at least) two issues here.

  1. There was an issue introduced sometime last night that caused Echo rediscovery to fail. This issue is fixed as of thirty minutes ago.

  2. There is some issue related to device icons (and possibly other device related preferences) resetting. Our engineers are investigating.


#11

Hey all (again)!

Icons should be back now. Please contact support@smartthings.com if you see anything else.


(Jesse S) #12

I experienced problems with switch icons and Alexa today as well. Any hint as to what the problem was?


(Eric) #13

And now they are back…


#14

My problem is fixed, all of my devices that have the types that they should. Thanks!


(Dawn Fairbro) #15

Proper icons have returned. Thank you very much :grinning:


#16

Thanks Tyler!..my switch Icon is working and Alexa was able to rediscover it.


#17

I didn’t make any changes in the last two days, but my switches changed on their own again in the IDE back to being binary switches, which brokethe logic. So I went ahead and I’m going to take them all out and put them back in and see what happens.


#18

Update: My Smartpower icon is still good, but my Smartpower Outlet is “offline” again according to Echo. It looks/works ok in the Smartthings app. I’ve tried removing it and rediscovering it…Echo discovers it fine, but still says it is “offline”, so it can’t control it. All other devices seem to be ok.

I have GE link light that sometimes isn’t coming on when triggered by a motion sensor, but I think that is unrelated (but they are both Zigbee).


(Dawn Fairbro) #19

Having the exact same problem


(Jesse S) #20

Dito. Alexa sees everything except smart switches.