Smartthings Outlets won't work in app


#1

Anyone having problems with their Smartthings Outlet? I have one controlling a lamp, and I can’t turn on or off the lamp via the app. However, if I look in the live logs, I see communication if I manually turn the lamp on/off, so obviously the Outlet is talking to the hub.

This just started two days ago.


#2

Yes, I have had this happen several times. Try going into the IDE, rename it and then rename it back to see if you can regain control of the outlet.


#3

Tried that 3x…didn’t work.

Alexa can’t control it either, but all other devices are ok.


#4

This happened to me the other day with an Iris plug. It is using the SmartThings device Handler. I had literally the exact same problem. A day later it was working again.


#5

Try changing the device type/handler to the version 1 of the SmartThings outlet and see if that works. I did that and it worked for me although it might just be coincidence. I then later changed the device type/handler back again.

If that still doesn’t fix it, then you will probably need to go through the process of resetting it. Unplug it and then plug it back in while holding down the On/Off button, wait a couple of seconds and then release the button after you plug it in. Go back into the SmartThings app and try to re-pair it. Sometimes, it won’t even show you if it finds it but a new thing will show up. Hopefully, that is a permanent fix. Don’t remove the original device yet because sometimes, it will start working again after a few hours and the new thing stops working. This has been my experience, FWIW.


(Bobby) #6

Mine did the same thing. Try renaming the device in the movile app, like yourdevicename1 and then back to yourdevice name. It worked for me. Also, check out this thread

@JDRoberts do you mind adding outlets in your title?


#7

Quick update…I finally had to do a full reset of the device and set it up from scratch again, after removing the old device from my apps, etc. It’s working fine now, but I shouldn’t have had to do all that.