Editing Modes in IDE?


#1

Sorry if this is in the wrong spot. Mod please move if needed.

I’m pretty new to ST and have been messing around with it for a week or so now and like many I’ve been having issues with arlo pro cams. Question is; I can create new Modes in the IDE but can not for the life of me figure out where to edit them and setup their rules.
Could someone please point me in the right direction.

TIA


(Arn B) #2

Go to the IDE.
Click "My Locations"
click on the name of your location.
About halfway down the page you see Modes (create new)
click "create new"
Add your modes.
Then in the ST phone app “Automations” add new routines and adjust existing routines to use the added modes


#3

Correct I can do that. When I create a new mode it only lets me give it a name. Ill click on the new mode or existing and can only edit the name or delete it. I can add the new mode to a routine, but I have no clue what the mode will do…

I might be confused about what Modes are for.
Also reading up on webcore


#4

Welcome! :sunglasses:

The Mode by itself doesn’t do anything. It’s just a single variable that you can set for your SmartThings account.

The various rules options you can use in SmartThings, such as the official smartlighting feature, routines, many of the smartapps in the marketplace in the SmartThings mobile app, and of course web core, can use the mode so that you can say a rule should only run in a specific mode or not run in a specific mode or maybe start running when the mode changes to a specific mode. But it’s the rule that is controlling what happens, it’s just using the mode as a “filter” if you set up the rule to pay attention to the mode.

So it’s sort of the other way around from what you were thinking of. Instead of creating a mode and then listing all of the things that will happen in that mode, you create a mode once and from then on whenever you create a rule you can decide whether that rule will pay attention to that particular mode value or not.

It sounds like you might also find the following helpful:


#5

Thank you. Yeah I was trying to use modes for the wrong thing.