Huge Delay on On/Off After Migration

I recently migrated to the new app last week and since this past weekend i’ve noticed that there’s been a huge lag/delay in any actions that are happening. A lot of devices are showing with the unavailable cloud with line icon and even when pressing a button or light switch sometimes is taking multiple presses or 20-30 second delay before the device turns on or off.

In addition, I added a Zooz double plug and while the master control works (with a huge delay), the child devices although added show as unavailable (cloud icon with line through it). This means I can’t control each outlet individually.

Is there something going on with the back end or what? Family is starting to get restless with these delays/lag.

3 Likes

I’ve noticed device details page refreshes are painfully slow / full of network errors. I have a temperature sensor that I check regularly, and it takes four or five refreshes and ignoring errors to actually get the data to show up.

I agree. I am having the same experience as you. Once you load the app it takes a good 30 seconds or more for everything to “update” to the proper status. Even then, half of the stuff doesn’t update and clicking to turn a device on or off from the favorites screen doesn’t work half the time unless you press it 2 or 3 times because it hasn’t “refreshed” yet.

This is all in addition to my other problems of delay on automations, on/off actions, etc.

@Brad_ST can you provide any insight on this? It’s starting to get real annoying. For some examples:

I have a switch that when I turn it on is supposed to turn on another switch, this sometimes takes 30 seconds or more to turn on the 2nd switch.

I have a Smartthings button that is used to turn a light on or of and if I press it then it again takes 30 seconds or more to actually turn on the light. If I press it multiple times thinking it didn’t recognize the first press then it will turn on and off in 30 second intervals until it catches up with my presses.

I have a Zooz motion sensor that is either not turning on the specified light when there’s motion or turning it on after a 30 second or more delay which defeats the purpose of having that motion sensor trigger a light.

This is happening with both Zigbee and Z-wave devices, multiple manufacturers, multiple device types, etc. It’s starting to get real annoying.

I guess I’ll keep replying to myself here. But there’s something seriously wrong and it seems directly related to after migration. The SmartThings status page shows everything is fine but it clearly isn’t. No matter what device I try to turn on/off or open/close from the app I get this error:

EDIT: adding also that the Google integration is extremely slow as well. If you tell it to turn a device on or off it take almost 1 minute before the action actually happens.

1 Like

And I’ll keep replying to myself…seems like there’s a lot less ST staff interaction lately than in the past.

I was doing some research on the SmartThings status page and it seems like my problems started right around the date of this outage:

Aug 21, 2020

Issues with Device Control, Automation Execution, and Loading the App

Resolved - The remaining issues with Hubs and devices incorrectly showing as offline in users’ apps have been resolved. Please contact us via support.smartthings.com if you have any questions.
Aug 21, 12:46 EDT

Monitoring - Issues with delays or failures in device control from the mobile apps and automations have been resolved. Certain parts of the mobile apps not loading correctly have also been resolved.

A small portion of users may continue to see Hubs and devices incorrectly showing as offline in their app. We are continuing to work to restore these devices to their correct health state and will provide further updates as they are available.
Aug 21, 02:59 EDT

Investigating - Some users in the Americas may be experiencing delays or failures in device control from the mobile apps and automations. Hubs and devices may also show an offline status and certain parts of the mobile apps may not load correctly. We are currently investigating and will provide updates as available.

While it says the issue is resolved, it does not appear that it is for all users. Definitely not for me as my problems seem to line up with what is being described in that outage.

I can understand they are busy with the migration, but I’d be nice if we could get some help with our issues. I know many people will say contact support but if anyone here has ever contacted SmartThings support, you’ll know that it’s a never ending battle of useless information being requested, suggested, etc. I do appreciate the staff that logs onto the community to help as they are very knowledgeable and usually help very quickly. I hope they can also assist in this matter.

1 Like

@SamsungZell @Brad_ST @jody.albritton Please help, I’m desperate. Family is starting to revolt…

Adding to the errors:

The saga continues…

I decided to try to reboot my hub. It is now showing offline in the app, all devices showing offline in app, yet the green light on the front of the hub is solid and the ethernet connection has a link and is showing activity.

I am also not getting notifications anymore for any of my simple automations or webcore pistons. IE: garage door open or garage door closed.

Ticket Number: 1029534 if that helps. The lady on the phone was very nice but unable to make any changes because her access was read-only. She said that she would escalate but it would take 2-3 days for someone to get back to me.

So I’m asking again for some help…please.

I’ve had slowness for a long time as well… With the new app it’s to the point of useless…
You never know if it’s going to work or not.

1 Like

All of a sudden, I’m having similar issues.
More worrying is that my aeotec wave devices disappear or have the cloud symbol
I’m fed up with the hours of trying to reconnect my devices to only find they stop working and or are so slow to respond that you don’t know if they’re working or not
Fed up

1 Like

@Gabbi_Di_Genua yes it’s getting quite annoying. It’s been about 2 weeks since my problems started, 1 week since I reported it here on the forums and 3 days since I’ve called support and I’ve still not had anyone reach out to me from the SmartThings team here on the community or via phone. In addition, calling support is quite useless as the person I spoke to said that they have read-only access and can’t make any changes to the account even if they were able to find out what was wrong. Having to wait 2-3 days for “escalated” support is kind of ridiculous.

I think I’m more concerned about the level of support received and overall quietness from the ST staff on the community over the past couple of weeks. Normally they are very active and usually respond when you tag them, but lately they have been MIA. A little communication would be nice, especially if there is something going on the back-end that might be causing this issue so we don’t tear our systems apart trying to fix it.

Anyway, I’m still waiting for mine to be fixed so good luck to you.

2 Likes

Still no call back from “escalated” support. I guess SmartThings support has just thrown in the towel. I don’t know any company that can possibly have support be this bad with lack of follow up and get away with it.

1 Like

Well, I finally got a response back from “escalated” support 9 days later, via email:

Thank you for choosing Samsung! We appreciate the opportunity to assist you. I understand since the migration to the new app, you are experiencing delays, we do apologize for the inconvenience. I have checked your account and you do have several device handlers which the new app does not fully support. Sometimes the device handlers work without issue but most of the time they don’t. In order to troubleshoot, you will need to remove the device handler and see if you are still having delay issues before we can move further in the investigation.

I’m not sure if this response is better or worse than support asking me 8 times to delete and reinstall my app.

First of all, why not specify which device handlers the new app does not support? Obviously she took the time to look at my account, so she could’ve easily stated which ones were incompatible.

Second, and most importantly, why did the migration process complete “successfully” if I had incompatible device handlers? Shouldn’t a red flag be thrown up, an error message in the app during migration, a warning, a list of incompatible things, etc that should’ve happened when I actually performed the migration?

Finally, most of my custom device handlers are for Zooz devices. If they are incompatible as they claim and that is what’s causing my issue then that’s kind of ridiculous. Also ridiculous that they are requiring people to remove all custom device handlers before even attempting to look at the actual issue or provide actual support.

Hopefully I don’t have to wait another 9 days for a response back telling me which device handlers she found to be incompatible.

1 Like

It keeps getting better. I got a response back to my email asking which device handlers were causing issue and I was told that absolutely no custom device handlers are supported. This is very interesting considering, as you’ll see below, most of my devices handlers are for Zooz devices which are supposedly supported in the new app. In fact I’ve recently added a couple of Zen21 switches without any issue through the new app. I did however try to add a Zooz Double Plug through the new app (it stated it was supported), but had nothing but issues with the child devices to control the outlets individually. The only way to get it to work is to go into IDE and change the device handler from “placeholder” to the relevant device handler.

If all custom device handlers are not supported, then at least fix your app to properly include devices that you claim on the app are supported.

I’m about ready to switch from SmartThings to something else, it’s becoming a giant hassle and pain to deal with all this, especially with no help from the ST Staff in the community when in the past there was plenty of informative activity.

Also, just an FYI for the below email. The only custom device handlers that are actually in use are the Zooz ones. All of the others are not used in any devices at all. I’m aware that some are really old, but they are not actively being used.

Hello,

Thank you for your reply. We apologize for the delay in a response as we have had an influx in our call volume and tickets, so it is taking longer than normal to get a response. Smartthings does not support ANY custom device handlers. They would have been something that you created and added to your account to use with 3rd party devices that Smartthings does not support. The migration will go through without any errors even if device handlers are added because the platform does not look for them because again we do not support them. With device handlers, it can cause conflicts in the device in regard to functions and delay. Below is the list of device handlers that you have added, along with their status and capabilities.

codersaur : Z-Wave Tweaker Published Actuator, Sensor

desertblade : Enhanced Dimmer Switch Published Actuator, Indicator, Polling, Refresh, Sensor, Switch, Switch Level

doncaruana : Zooz Zen21 Switch v3 doncaruana/SmartThings-doncaruana (master) Published Actuator, Button, Health Check, Indicator, Light, Polling, Refresh, Sensor, Switch

doncaruana : Zooz Zen26 Switch v2 doncaruana/SmartThings-doncaruana (master) Published Actuator, Button, Health Check, Light, Polling, Refresh, Sensor, Switch

doncaruana : Zooz Zen30 Child Switch Published Actuator, Light, Outlet, Switch true

doncaruana : Zooz Zen30 Dimmer Published Actuator, Button, Configuration, Refresh, Sensor, Switch, Switch Level, Zw Multichannel

info_fiend : Osram GardenSpot Mini RGB - Custom Published Actuator, Color Control, Color Temperature, Configuration, Polling, Refresh, Sensor, Switch, Switch Level

krlaframboise : Dome Door Sensor v1.1.6 Published Battery, Configuration, Contact Sensor, Health Check, Refresh, Sensor

krlaframboise : Zooz 4-in-1 Sensor Published Battery, Configuration, Health Check, Illuminance Measurement, Motion Sensor, Refresh, Relative Humidity Measurement, Sensor, Tamper Alert, Temperature Measurement

krlaframboise : Zooz Double Plug Published Actuator, Configuration, Energy Meter, Health Check, Outlet, Power Meter, Refresh, Sensor, Switch, Voltage Measurement

krlaframboise : Zooz Double Plug Outlet Published Actuator, Energy Meter, Outlet, Power Meter, Refresh, Sensor, Switch, Voltage Measurement

krlaframboise : Zooz Double Switch Published Actuator, Button, Configuration, Health Check, Light, Refresh, Sensor, Switch, Switch Level

krlaframboise : Zooz MultiRelay Published Actuator, Configuration, Health Check, Light, Outlet, Refresh, Switch

krlaframboise : Zooz Smart Plug Published Acceleration Sensor, Actuator, Configuration, Energy Meter, Health Check, Outlet, Power Meter, Refresh, Sensor, Switch, Voltage Measurement

pmjoen : Sony XBR Android TV Published Media Controller, Music Player, Polling, Refresh, Switch, Switch Level, TV

pmjoen : Z-Wave Fan Speed Control Published Actuator, Indicator, Polling, Refresh, Sensor, Switch, Switch Level

Thank you for being the best part of Samsung!

Did this ever get rectified? Was a solution ever found?