On the verge of giving up hope

As someone who’s been involved with smartthings since literally the very beginning (Kickstarter backer), I’m getting to the point that I just want to give up. I’m so sick of trying to use the app and have to hit a button… wait 45 seconds (or so) for it to say: A network error occurred then try again, and again, and again before maybe 4-6 minutes later it decides to work. (This is whether I’m on wifi or mobile data, whether I’m standing 10 feet from my hub or miles away.)

I’m sick of asking google to turn off the kitchen light having to wait between 30 seconds to 4 minutes before it shuts off.

I have a handful of wifi switches in my house as well and those are rock solid reliable taking less than a second to respond. Why does the SmartThings environment take so bloody long?

I like having my switch and sensors on Zigbee and Zwave so that:

  1. I don’t have them “clogging up” the WiFi band
  2. I don’t have to have 7-odd different apps handling my wifi routing through who knows what company.

I like that (through Sharp Tools) I have the ability to control stuff through Tasker.

But I’m so, so, so sick of the delay and the SmartThings App which feels anything but Smart.

Please tell me there’s an easy fix for this problem that has plagued me for years. I don’t want to leave Smartthings, but I’m right on the verge of doing it.

2 Likes

I dont have any of the issues you’re describing with my zwave or zigbee devices on ST. Lets try to get an idea of your environment and see what could be going on?

  • What Smartthings Hub? V2, V3, Wifi?

  • What zwave or zigbee devices are you having issues with? Model numbers are important.

  • How many zwave or zigbee devices do you have and how far are they from each other or the hub? Both technologies rely on a strong mesh so each has their own requirements. Zigbee can also be fighting for airtime with nearby WiFi so it may help to know what Zigbee channel your hub is set to.

  • What device handlers are you using with the problem devices (stock built in, custom Groovy DTH’s, or Edge?)

We can help!

2 Likes

I don’t have the Google Assistant delays, but the iOS app is indeed very very very slow. AFAIK there is no way to speed up the app. Lighting groups seems to update faster than the actual devices. I’m very glad I didn’t pay full price for my SmartThings cams, because they are about to get tossed due to how long it takes to pull up a stream in the app.

3 Likes

I don’t have any of these problems, in fact my system has been rock solid and very fast for a good while now. I’m using a an android (google pixel 4) for the app, which now zips along (it DID use to be extremely laggy and basically shit back when the new app launched). Got a mix of ZigBee and WiFi devices, no zwave. V2 hub.

Based purely on my experience I’m confident that you can troubleshoot your issues, unless you’re using the iPhone app, which by all accounts still sounds like a mess. Good luck.

Oh, and one final point, I used to have terrible trouble with ZigBee devices going offline until I moved the hub away from the router, and also angled it so the internal antennae wasn’t pointing directly at an external wall. Solved all my ZigBee issues. This might not be useful info, but hopefully can help someone else that reads this.

1 Like

v1 would definitely have issues since it was shut down :sunglasses:

4 Likes

I can’t say whether there’s an easy fix, as others have suggested, when troubleshooting issues on an individual account you just have to pick a device to start with and work your way through.

One hopeful note: smartthings is right in the middle of a huge transition from a largely cloud-based system to one which will operate much more locally, both with edge Drivers and potentially eventually with matter support.

They could still screw up the app, of course. (For example, they didn’t have to make the current app reliant on the cloud, but they did.) So there’s no way to know for sure that things will get better on that front. But I think it’s reasonable to hope that they might with all the changes that are coming.

All of which is to say: I certainly understand somebody deciding to jump ship right now if the frustration level is just too high. But I can also understand somebody feeling mildly optimistic that things will be better by the end of this year. I know that’s a long ways away for something that you use every day, but if you have a big investment in money and time in your existing setup, some people will think it’s worth waiting to find out.

I am at the point where the app is now completely unusable for me because it’s not voice navigable. The last time it was truly useful was I think in early 2018. Since then, I’ve been reporting the issues with every new release, and I’ve received multiple assurances from multiple staff members that it would get better, at least meeting the W3C minimum accessibility requirements, but it still doesn’t. :disappointed_relieved: I know that only affects a very small percentage of people, but it’s a small group of people who have a very significant use for home automation, and other competing platforms have found it a reasonable target market. But so it goes.

Anyway, only you can decide what will be best for you. There are a lot of choices right now, and a lot of changes coming for everybody industrywide with the potential release of Matter. Personally, I wouldn’t be investing a lot in anything new right now until we see whether Matter can deliver this summer, but again, that’s a personal choice.

Good luck, which ever way you go. I hope you find a system that works well for you.

4 Likes

They already did.

2 Likes

Over the weekend we had a long power outage, and to extend the life of our whole-house backup battery, I shut off things that weren’t necessary. The ST hub was one of them. The other brand hub which now controls all our automations stayed on. When the power came back up, I forgot to plug the ST hub back in… I didn’t notice until 24 hours later when Device Monitor (running in the cloud) told me some automations hadn’t updated - ones I no longer cared about because I’ve replicated them elsewhere (and being monitored by the nearly same Device Monitor smartapp groovy code running locally on my other brand hub). That was when I realized it was all over for me.

When Edge is released and there’s a new working set of tools to build automations, support new devices, etc, I may test it out again. But meanwhile I need a reliable, fast, and supported automation platform - that I can depend upon to work 24/7. SmartThings is currently not capable of being it, and with the coming sunset of Groovy support, things are going to get rockier before they get better.

3 Likes

Hey JD… I remember you from back in the day! Thanks for the info on the changes. I might stick around long enough to see what happens with that.

1 Like

sometimes, not always, but sometimes a simple router restart will help or even fix things.

Thanks, but this is not going to help here. This is an issue that I’ve dealt with for months, if not years. At times the response will be decent when I’m using Google Assistant to turn on/off lights, but much more often than not the app will have huge delays.

This has gone through three different routers over this time period and two different hubs, so it’s not going be an easy fix I fear.

V1, V2, and V3. I’ve had 'em all and I’ve had this issue, to varying degrees, with all of them. I’m running the AEOTEC hub right now that’s ethernet cabled to my router.

Mostly Z-wave devices, I’m unsure of models… The most frustrating time is when usually when I’m trying to get my garage open and I want to say that’s an GE outlet/receptacle, but I’m not 100% sure on that. Generally when I run into this I’ll also try to turn on my kitchen light (which is a GE z-wave switch) and it’ll lag as well.

I have at least 20 z-wave devices. While the garage is not attached to the house (and therefore interference from my house walls and the garage walls of course), it’s actually physically pretty close to the hub. However this also effects other devices which are in the house with virtually no walls between.

Devices handlers are probably all stock. I have no idea what Edge is. Is that the new development environment?

1 Like

SmartThings is in the middle of a transition to a completely new architecture, part of which is called Edge.

The Samsung-hosted free groovy cloud will go away. For hub-connected devices, including zwave, the DTH replacement will be Edge Drivers, which are written in the Lua programming language and will run locally on your own hub.

Here are the official announcements:

Announcement | Changes to our Legacy SmartThings Platform

.

Announcement | SmartThings Edge for Devices and Automations

Edge is still in Early beta and they missed their target transition date from the first announcement so no official timeline details at the moment.

This is great information. What I would ask next is which models of switches are nearest the hub? Are they models that support zwave or zwave plus? Zwave (pre 2014 or so) is pretty iffy. Plus models are much better and should be the “first round” of devices outward from the hub if possible.

Yeah Edge is the upcoming replacement but its good that you’re using all stock drivers. That gives us an baseline to work from.

Have you used the IDE before (https://graph.api.smartthings.com/) to see your hub and device status/logs? We could point you to a few sections in there to capture more information.

Have you tried a zwave repair? You can do it from the IDE or the mobile app UI (Click on the hub, in the submenu there is a Zwave options function, then zwave repair). A repair will tell you if you have so called ghost devices or something wrong where the hub can’t consistently communicate with a device. It will also try and repair routes (esp on pre Zwave plus devices) for devices that have been moved around.

1 Like

Are you using the iOS or Android version of the app?

Try going to my.smartthings.com in a browser and using the functions there. Any difference in speed/consistency?

For the app, there is not a solution. This began in June for me, and I have submitted 6-7 cases without resolution. In other threads you will see it happens to many others as well. I do not believe it to be a genuine “network error” because other things (Scenes, STHM) are controllable instantly when you open the app. It occurs with individual device control, and probably has to do with the device control module updating status.

Signed,
Exhausted Too

1 Like

Better choice is to use https://account.smartthings.com to access IDE… otherwise some users might experience issues with that URL

3 Likes


I have never ever seen this error. Are you iOS?

Yes, iOS. It happens consistently within the first couple of minutes of first opening the app or when the app is brought to the foreground after being in the background for a while. If you are on iOS and NOT experiencing it, I’d love to compare configuration to see if there is something that stands out as different between us that might explain it. This has been happening since one of the app updates in June (the error message is a new addition, but the behavior of inability to control devices is the same).

yeah, it’s a very poorly worded “error”. It the same problem with devices taking forever to refresh on iOS, it jsst now has a poorly worded “error” over it that causes even more confusion.

1 Like