SmartThings Community

Hue delay between bulbs?


(Jake) #1

Hi,

Is anyone else seeing a delay between hue bulbs setting a level? i.e. one has almost finished turning on before the next starts to turn on…

I’m using the standard Hue (Connect) and have a custom smart app running the below line of code

settings.“sDimmers$i”?.setLevel(settings.“sBLevel$i”)

i is a variable (1) in this instance

This doesn’t go through any “each” loops or anything like that, and has been working fine until recently…

The only thing I can think is that I upgraded to “Hue B Connect” 4 days ago and downgraded back to the standard Hue (Connect), I don’t think the issue was at the same time but it’s possible that I just hadn’t noticed…For a day or so…

I assume when I reverted to Hue (Connect) that this was actually a newer set of code which is causing the issue I am seeing… anyone else seeing this or stupid enough to uninstall Hue Connect and re-install to see if they then get the same resultant delays :smile:

Does anyone have any other suggestions?


Dim delay with 2 hue bulbs
Philips Hue lights slow to respond
How to turn on/off all lights at the same time?
Smart lighting + Hue - delaybetween lights when turning on
Hue lights turning on and off in a parallel
Lighting Group Creation
CoRE? SceneMachine? Other? Looking for Synchronized Dimmer
Hue Advanced (Connect)
How can you group devices so one command turns on multiple lights at the same time without a popcorn effect?
[RELEASE] PlexPlus - Control Lighting with Plex Play Status
Hue Lights Refresh/Status - Do you schedule poll under 5 minutes?
(Jake) #2

So should have tried this first… I setup a basic piston to achieve the same thing and still seeing a significant delay when setting the level, so clearly this is either Hue or Hue(Connect) related, I see that from git hub a portion of the code was depreciated, but kept in place for old DTs I suspect anyone moving to the new DTs will get the same issue…

Any suggestions guys? Might have to trawl through GitHub and find the version of code that works better!


#3

The first thing I do is try an alternate means of control. Something that doesn’t need SmartThings at all. So a third-party app or an echo group if you have the hue bridge connected directly to echo without smartthings, or a Hue scene.

If you still see the delay there, the next step is to unplug your smartthings hub (including taking out the batteries if it has any) and then repeat the third-party test. If the delay goes away, then the problem is likely polling from SmartThings to Hue. I mention this specifically because last month there were some people seeing this problem.

If you’re still seeing the problem even with the SmartThings hub unplugged, then check to make sure that your hue bridge is up-to-date. If so, then unplug the hue bridge for at least 15 minutes and then plug it back in. This will refresh its own mini network that it has with your bulbs.

Finally, if none of that helps, you’ll need to talk to support if you haven’t already. :disappointed_relieved:

https://support.smartthings.com/hc/en-us


(Jake) #4

Will give these steps a go, I don’t have any other external means of control only Hue app and remotes, and Hue is on latest software, even manually triggering each light manually in ST with my finger makes the switch quicker…

Will try pulling the juice on the ST hub and leaving the hue hub unplugged for 15 minutes… anythings worth a shot…

If that doesn’t work then I’ll have to go through and find an old version of hue connect and see if that happens to fix it…


(Kevin) #5

Yes. My kitchen i have 5 hue br30’s that turn on to 100% on motion. It steps, 1,2,3,4,5 from bulb to bulb. Was going to point it out at some point just haven’t posted yet. These are paired to hue, controlled though ST using the stock smartlighting app.


(Jake) #6

Interesting! Had it always been that way or has it changed recently?


(Kevin) #7

Not really. There was some delay but nothing super perceptible when I first put these in about a month ago. About a week maybe 2 weeks ago this seemingly changed. Almost all my lights do this now. At least those through Hue, which is almost all my lights. Since the bug of too many zigbee bulbs, I paired almost everything with Hue. Now it acts like you say, a for loop of waiting for one to complete. Used to be the 7 lights in my kitchen would turn on almost instantly. The 2 cree bulbs paired to Hue, would react first, then the 5 br30’s next maybe half a second later. Now, its like I can count 1,2, 3, 4, 5 as each comes on


#8

thread added to the first bug reports section in the community-created wiki. Continue to report individual problems to support, the wiki is just for community use and is not monitored by SmartThings staff.

http://thingsthataresmart.wiki/index.php?title=Bug:_First_Reports


(Jake) #9

@KevinH @JDRoberts

So looking through code…

Seems there was a commit 20 days ago, adding setupDeviceWatch()…

Although can’t see how this may be impacting this…

Also perhaps something to do with updateInProgress() delaying actions…

I’ve raised a ticket now anyway and encourage anyone else having issues to do so…


(Ben W) #10

Hue also released a firmware update a couple weeks back.

There was a pretty nasty defect that allowed a worm to spread between bulbs.


(Jake) #11

Yeah, but needed to be deployed in proximity to the lights, although if it’s the only hue firmware released recently then I don’t think this caused the problem as I’ve only updated my firmware after seeing this issue.

Good point worth raising though!

As a side not setting scenes in the hue app work flawlessly…


(Kevin) #12

Here’s what I’ve been seeing for easily 2 weeks. Maybe more. @slagle Is this a known issue?


#13

Popcorn effect. :scream:

What’s the brand and model of the lights and are they connected directly to the hub?


(Kevin) #14

LOL guess I just hinted at it in the prior reply

2 bulbs closest are Cree connected, paired to Hue bridge. Can lights are Hue br30 color paired to Hue. All my hue paired lights are doing the ‘popcorn effect’. Master bedroom is 3 bulbs, and it goes 1, 2, 3. And I swear its in order of how they are listed in the SmartLighting rule. I might be wrong there. But the Kitchen does that EVERY time in that order. Bar lights are fast-ish but not at the same time, then 1,2,3,4,5 for the Hue branded bulbs.

But because of the crappy zigbee bug, I dont pair hardly any smart bulbs to the ST hub anymore. I have like 6-8 zigbee lights on it and all other bulbs go to Hue. Living room popcorn’s as well, 2 hue br30 and 2 cree’s. Bedroom is 3 hue color. Its acting like its a for loop just iterating through.


#15

If you unplug the SmartThings hub ( so it won’t do any polling of the bridge during this test) and then run a scene through the native Hue app for the same lights, do you still see the popcorn effect?


(Taimur Asad) #16

I’m having exact same issue. Been a week it has been like this for me. Everything works flawlessly using Siri or Hue app. But SmartThings app and ST Motion Sensor has this 1,2,3,4,5… delay issue. It’s very annoying. I haven’t changed anything. Just happened out of no where. I have been in contact with ST support for the last 3-4 days. They have so far not been able to identify the cause or fix the problem. Anyone else in the same boat?


(Jake) #17

My support tickets gone dead past the first question, I had offered for them to take control of my lights, any idea if they have managed to replicate the issue?


(Jake) #18

To add to this, I have installed “Hue B Smart” today, and still seeing the delay between bulbs.

So either both SmartApps have the same bug or the issue is with ST / Hue and how events are sent/ received.

Obviously the potential solution is just to set a Scene in Hue B Smart or one of the previous iterations, as this will be executed directly on the Hue hub…


(Tony - SmartThings Unpublished Contributor ) #19

You can avoid this by using either a Hue scene or a Hue group.


(Wayne) #20

I’ve been seeing the exact same thing as your video since the beginning but it’s just a lot worse than it used to be.
What is frustrating, is that when I have my bulbs connected to the lightify gateway, all lights switch on and off simultaneously very very quickly, so the technology is definitely capable. It’s just a shame there’s not smartapp to connect the lightify gateway even though there are apparently published REST APIs for their product.