HUB won't get IP anymore

Hi all,

So I had an unexpected power outage to my primary Ubiquiti switch which happens to power my other Ubiquiti switch which my SmartThings Hub hangs off, no big deal, fixed the power issue all came back OK, except the hub… I’ve now tried power cycling it, moving it to another switch, changing VLANs, removing it’s DHCP reservation, etc. but no good. It seems to be sitting there trying to get an IP, appears to get it for a moment, then drops down to a 169.254.93.* IP. After doing this for a bit it gives up and reboots, same thing.

The hub itself didn’t even lose power which is the annoying thing… After much googling I found an old reddit thread (https://www.reddit.com/r/SmartThings/comments/b6naaf/hub_offline/) with a comment from u/posborne stating it was a known issue with Ubiquiti routers (I’m running the Ultimate Dream Machine Pro) so I figured maybe this bug has reappeared?

According to the historical info in my app my hub is:

SmartThings Hub, Firmware version 000.038.00010, Z-Wave DSK 48420-05892-21471-32393, 62044-03618-24804-58271, Controller version (2.2.9-3).

Anyone got any suggestions on what I can do to get this back to how it was? Already sick of opening and closing all my blinds manually :stuck_out_tongue:

Tagging @posborne

1 Like

Hmm, no recent changes to our connectivity manager. I run a UDM pro myself these days for my home network and have not been experiencing any issues but there are likely differences in how our networks are configured as well as this particular scenario.

I’ll ping the team and we may reach out via DM for additional information to diagnose.

2 Likes

Try powering down the hub for a few minutes. Remove the batteries if you havre a v2 hub.

2 Likes

I have the same suggestion plus add a reservation for the hub in your router based on MAC address and have it be different than what you used before. When you power the hub back up, hopefully it’ll take what you assigned.

1 Like

Hi all, thanks for the replies. I originally had a DHCP reservation, I’ve already tried moving and removing the reservation to see if that improved things, no change. No batteries in my hub that I’m aware of but I’m keeping it on my desk unplugged for a while. I’m also going to try throwing it into anther VLAN which runs off a my back-up WAN connection, see if that changes anything for me.

OK so left the hub off for over 10 minutes, plugged it back in, no change. Removed the DHCP reservation (it’s usually set to 192.168.0.242/24), no change. Moved it to another VLAN, the UDMP reports it suddenly appearing in 192.168.2.242/24 (although this never replies to pings going on a continuous attempt from my PC) then jumps back to it’s 169.254.171.139 address.

Other details - LED wise it’s always just flashing blue, it seems to have minor network activity but that could just be broadcast traffic coming in via that port. I’m about to try it on a different network all together (an open wireless network I run which has a few ports hanging off the back of one of the WAPs) to see if that works, just trying to find a replacement power source I can test it with there (both as a fault finding step and as it’s all wired in to my rack super neat and I really hate redoing my cabling).

If no luck there I’ll try making a new network in that 169 range and seeing if I can at least communicate with it then.

This post was flagged by the community and is temporarily hidden.

Hi all, sorry for the slow reply. I found another PSU for it finally, tried that, no change, new cable and port, no change.

So I moved it to a semi isolated network I have which is basically run by a crappy ISP modem/router and it stopped it’s blue flashing straight away and went to solid blue. Took about 5 minutes and then it was back online via the SmartThings app (and the LED went Green). It picked up an IP no worries and was fine for a few minutes, then went back to a blue LED again (solid not flashing) and is offline again…

So it seems it’s somewhat related to the UniFi DreamMachine Pro? What I don’t get is this all started with a power outage to the network device it was plugged into, but not it’s power. The port it’s on doesn’t even have the ability for PoE so it’s not like it got a jolt from a misconfiguration there, etc. If it had failed like this during a full power outage I would have put it down to getting spiked but this is just weird…

By the time I had written all the above it had come back as Green again. I just checked and all the version information is still the same as it was (unless the app takes a bit to refresh? I reloaded the app just to be sure and it hasn’t upgraded itself or anything).

I’m going to attempt to plug it back into the UDMP controlled VLAN now and see what happens (my DHCP reservation is removed so it should just get any old IP).

So now it seems to be all better. It is in a different port but they are all configured the same and another device worked fine in that port. I don’t know what it’s issue talking to the UDMP was but once it had a break talking to something else it seems it was more than happy to come back and talk to the UDMP now.

I tried rebooting the switch again with a power outage to see if that changed anything, no different.

Thank for all the assistance everyone. I guess I’ll put this down as a random intermittent unrepeatable bug in either the SmartThings Hub DHCP handling or the UDMP somewhere.

2 Likes