Hub v2 will not connect with new Motion Sensor

Sorry - it finally did sync; not sure how to delete a thread.

So I’ll just say that I LOVE the new sensor - it’s so much smaller than the previous version!

I have a v2 Hub that I’ve been using for several weeks.

Today I got a new ST motion sensor (the new one) but can’t seem to get it to connect to the hub.

I’ve taken the battery out, pushed the connect button as I put the battery back in.

The sensor lights blue, then I go into the app and choose to look for new device. The light on the hub starts blinking green.

The light on the sensor changes to green, but nothing else happens - the hub continues to blink green and it never finds the sensor.

I’ve moved the sensor right to the hub. I’ve also tried (in the app) to add a new device as well as tried to add a new motion sensor (specific device).

Any other suggestions? :frowning:


Glad you figured it out. When you edit your post you’ll see 3 dots for “more”, or may be the trash can (I can’t remember off hand). You can delete it that way.


Like JKimery my motion sensor will not connect take the battery out then put it back in while holding the reset button and I get a orange light or a green light when in find mode on the app :(. Please help

@jonathan_porter, you might want to be close to the hub. Also, I’ve had to reboot my hub at times because the inclusion process just sits there and does not ever stop until it times out.


I have done all of the above.

The motion sensor connect first time and wouldn’t work and I had to remove it from the app. Then I can’t seem to get it to connect again.

When I add a new room and add a device it comes up with the motion sensors with the first name I typed in, but I have delete that from the app. So it seems like it kind of connect it.

Can you still see it in the ide?
Perhaps you need to delete it there.
What type/manufacturer is it?