Hub v2 keeps going offline and back online every 2-3 mins

Nope, I’m still having the same issue multiple times a day. Seems to happen in clusters where it will blip on/off several times over ~10 min then be good for a few hours, then repeat.

I have not had time to troubleshoot this yet so I’m just putting up with getting tons of ST push notifications. Not helping the WAF though as she gets them too.

@taskforce20 and @Snuffy2, ST has tracked down my ticket and someone is looking at this. All of ours may be related, so if you haven’t at emailed support, please do and reference my ticket #719090

Thanks. My hub is still on and off now. It has been happening for few days now

Hi, Any traction on this issue? mine hub is still online and offline constantly. It actually affect my lighting.


I’m still experiencing this too, and it’s impacting me as well now. ST has reached out pretty consistently so far, which has been great. My hub logs aren’t providing much for them, so I’ve been asked to do a soft reset when I get home from work tonight. I have to pull power from the V2 (batteries too), then hold down the button on the back and plug in power and wait until the LED strobes amber and then release the button. That process should only take a few seconds.

A soft reset will blow away all local configuration in the flash and will trigger the hub to re-download the firmware update and sync down local automations again. My devices and mesh network will not be impacted from how it was explained to me.

I’ll update this discussion with my results later today.


Hi @taskforce20, I just did the soft reset and it only took a minute or two for the hub to come back. So far I’ve not seen a message I typically get titled “Not responding to polls” for one particular zwave plus device, so maybe that’s good news. All my devices work just fine too.

The true test will be if I stop getting the disconnect/active events in 1.5 to 2 hours. Stay tuned.

Bad news. The soft reset didn’t help at all. Back to the drawing board.

I did that several times and the connection is still very bad. It is unusable at this point. I’m thinking of getting Hub V3 and setup everything again. Please tell me if I should not do that :smile:

I also did a re-set and replaced the network cable. The hub came back on line after the re-boot and after an hour is back offline again. I am afraid the hub is not reliable at this point. Considering other options and possibly different Z-wave configurations other than ST.

Hi @taskforce20 (fyi to others like @Automated_House and @Lui and @Snuffy2)

So my issue seems have been resolved, but it had nothing to do with the hub. I had the hub plugged into a wifi switch on a surge protector, and the wifi switch is crapping out. The wifi switch is in the trash and the hub hasn’t disconnected/restarted in over 2 hours (it was happening every 1.5 hours for me).

My hub is hanging on a wall behind a cabinet, so I rarely see or touch it, and I totally forgot about that wifi switch. Kudos to ST support for digging deep on this one to exhaust many ideas and not just telling me to replace my hub and rebuild everything.

If you are having these kinds of problems, perhaps trying a different power supply may help?


This is what I found with my V2 Hub. I had the exact same problem going Offline and online frequently.
The Hub is connected to a router with 4 network ports on the back (one port for the ST hub). After a recent configuration change, one of the ports was connected to a network cable located in a different room. This cable was still unfinished on the other end as the configuration change is still not finished. I decided to disconnect this unfinished network cable from the router and reboot the ST Hub one more time. Since then, the ST is working perfect and stable. It appears this guilty cable created some strange condition within the router which in turn affected the ST Hub operation. Once I finish the other room and have a finish network cable there, I will try to reconnect and see what happens. But for now, the cable for that port is off the router and the ST V2 is back to normal. Recommend to isolate the ST HUB within your connection point by connecting it first, then move into re-connecting the other items one by one and see if one will cause the ST to go offline.

My issue seems to resolve now. I reset my router and everything works great again. I’m not sure why resetting the router resolve the issue even though internet is working great.

I figured this out accidentally. I have been resetting the hub, the switch but nothing works. And, I was so frustrated that I went and bought a V3 hub. I accidentally reset the power strip and it restarted everything including the router and hub v2 reconnected and worked great since then


Wow, yup it’s really amazing how finicky the ST hub is with stuff like this. I’ve read about so many other examples like ours that I really shouldn’t be surprised. Glad you’re back up and working.