Hub update broke automation


#1

There was a hub update in the last 6 weeks that broke my home automation. Ever since this update my standing light which is z-wave switch controlled will not turn on automatically per schedule. If I check the status the switch is reported as “unavailable” with a small red dot displayed. However there is nothing physically wrong with the switch since I can turn it on manually via the SmartThings app. Once turned on it does automatically turn off, but the next evening at the scheduled “turn on” time it’s reported as unavailable again. I verified the schedules as being correct and saved the “on” and “off” automation, but this has no impact. The device is a Monoprice on/off plugin that has worked flawlessly before the hub update.


(Jimmy) #2

Have you tried a z-wave repair?


#3

I don’t know what that is, but as I mentioned I can manually turn it on and it turns off automatically so I don’t think it’s a “z-wave” issue per se.


(www.rboyapps.com - Make your home your butler!) #4

Worth trying it - nothing to lose, I can’t count how many times folks have reported being able to control things manually but automation fails because of mesh issues. Automations may be sending fast/multiple commands over the mesh and a weak mesh can cause lost/dropped commands which you don’t see with manual commands.

Open your IDE, click on My Hubs, click on View Utilities -> Repair Z-Wave network.

Also worth trying is before repairing your network, power cycle or reboot your hub. You can reboot your hub from the IDE, View Utilities -> Reboot hub

These 2 things tend to solve most timing issue that crop up suddenly.

If not you can move one step closer to debugging what’s going on by looking at your IDE live logs at the time of the schedule. Is the command being sent? Is the device responding? etc