Hub reset questions

Recently I had a minoston zwave 2 channel plug disconnect from the ST v3 hub, and no matter what I did I could not reconnect it. I moved my hub near the plug, connected the hub to an ethernet nearby, and excluded and re-paired that zwave plug.

I then unplugged my hub and moved it back to the utility/router closet, and that is when my problems began. No matter what the hell I did, I could not get the hub to reconnect to my network. I reset my ISP/router and tried to run diagnotics on it, but nothing was wrong with the home network.

I decided to reset the hub, as I was out of options. I still could not get the hub to connect to the router/network. I decided to connect it to wifi which I was able to do, but now pretty much all of my 80 some odd devices are not reconnecting to the hub. I ran a zwave “repair” command, but nothing is coming back online.

I still cannot figure out why the hub will not connect to the network via ethernet.

When you reset the hub, does it delete the edge drivers and connections to all of your devices? If so, I am ready to cry. I cannot imagine having to rebuild this entire automation network.

Unfortunately reseting the hub deletes everything so you will have to start over. Reseting the hub sb the very last resort after you have exhausted all other trouble shooting steps.

The last thing you wanted to do was reset the hub. I wish you would have asked here before doing a hub reset. All of your devices and routines have been wiped and can not be restored.

1 Like

My recommendations…

  • Never reset a hub if only a device or two are not connecting. It may and probably will not resolve the issue in many cases.
  • if the hub is not connecting … check the led light on the front of the hub (green is connected, other colors have different meanings)
  • power it off for 5- 10 minutes, reboot your router
  • try a soft reset which only resets the network settings on the hub. (power off, hold reset button and keep holding as you plug the power cord back in, wait until you see the led on the front of the hub start flashing yellow and let go of the reset button)
  • switch to wifi if you were using Ethernet or vice versa
  • ask the community for advice before deciding to go down the road to resetting your hub
  • contact ST support

When I ran into trouble, I was just getting flashing blue light, which I believe means “looking for network”. I tried powering off for +10 mins, repeated that a bunch, no dice. Reset home router/gateway twice…no dice. That is when I tried to reset, BUT maybe I did a “soft” reset? THe procedures I followed was what the ST app walks you through when adding a hub, basically holding the reset button down with a pin, when powering up, and holding it until the solid yellow light turns to alternating red/green. That didn’t work on ethernet, but when I did use the wifi option in the app, it connected after installing updates.

When I go into the settings of the hub in the ST mobile app, I am still seeing a list of a dozen or so edge drivers I had d/l. What is odd is I am still seeing icons of a ton of my devices under the hub “connected” list in the mobile app. But the tiles all say disconnected (and so does the IDE interface) and no on/off commands are working on any zwave or zigbee stuff across the entire house.

With that said, before I dig an even bigger hole, any suggestions on what to do now?

yep… that is the hard reset and wipes out everything.

stopping at yellow is the soft reset and only clears the network settings and forces the hub to try and contact the ST servers which can take up to 10 minutes. But even doing the soft reset in this case probably would not have resolved it. Usually switching from ethernet to wifi does.

Sorry that you had to go through that.

You will need to reset any zigbee devices and exclude any z-wave devices and you are then able to add them back to your hub. You will need to recreate all your Automation. This is not going to be fun with 80 devices. hope you had no plans for memorial day weekend.

You can contact ST Support and see if they can verify that you did indeed perform a hard reset… just in case. never hurts to speak with them first (recommended)

I honestly can’t tell what kind of reset I did. The instructions said to release the reset button when the flashing yellow turned solid yellow. I believe that is what I did. My dozens and dozens of scenes and automations are still there in the app as are all of the edge drivers. This is all so royally fucked up. I excluded a single inovelli switch and added it back to the hub. It picked up the correct inovelli channel. But the hub won’t control the switch at all as far as simple on/off commands.

Last I checked IDE there were 88 device line items, although some were placeholder/virtual devices. I have all of my devices mirrored in Alexa’s app, and a shit ton of voice and location triggered scenes. So I’ll have to delete one by one out of Alexa and re add, or just readd everything and delete out the bad devices from Alexa. Fun.

But right now there is something fundamentally wrong with whatever is going on with either the app or the hub. I’m not aware of any nuclear button that would wipe EVERYTHING out, but at this point I’d almost prefer to start over from scratch vs. unpair/add every single device back, but i’m not sure thats possible.

When I hit the icon for the single inovelli switch i’ve excuded/added back I get a “This device hasn’t updated all of its status information yet. Check back again later” message. Not encouraging. I excluded and readded that switch about two hours ago.

I’m not going to move forward with anything until someone can help me figure out why my hub is not controlling anything.

sign out of the app and sign back in.

and contact ST support if still not functioning.

Couldn’t find a sign out in the app so I uninstalled, reinstalled and signed in. I am excluding and readding inovelli red switch dimmers as they are the easiest with QR codes but so far I’ve only been able to get one out of 3 to function from the app. At this rate I will have this entire system rebuilt by 2026, maybe. I will have to hit the breakers all over the house for the gen 1 inovelli switches I have (fun).

I am ready to give up on ST entirely. If i’m going to go through this much work I might as well pull the plug now. What is funny is I’m seriously looking at some of these zwave switches and thinking about putting the old manual switches back in. I could probably rewire even some of the 4 way switches I have faster than getting the old “smart” switch to function again. If that isn’t a sign of a complete failure on this automation technology in general, I don’t know what else is.

I contacted customer support and they were utterly useless, other than telling me that yes, I did a hard reset. I couldn’t get an intelligible explanation as to why my drivers, routines, and scenes are still visible. Maybe those are backed up on a server, and reinstalled when the hub reconnects, who knows. Escalating my ticket for a call back.

I’ve noticed a “Leave Smartthings” option in ST settings. Does anyone advise that I simply do that and then open a new account. I would prefer that I not do that and readd devices, as all of my automations and scenes are still there. But I’m really thinking that the size of my old build as far as 3rd party integrations, routines, scenes, etc. is just simply too large to ever fix this system now that the hub crashed.