Hub offline and not back


(ilker Aktuna) #1

My hub became offline approximately 7 hours ago and till then it is offline.
Its led is blinking purple and I can ping its local IP address.
When I disconnect its Ethernet cable, led blinks blue. When I reconnect, led blinks purple again.

What is wrong with the hub ?


(Nathan Davis) #2

There was a firmware update today. Try rebooting the hub. It should reconnect after that.


(ilker Aktuna) #3

is it a good idea to reboot if the upgrade is going on ?


(Nathan Davis) #4

Most likely it updated 7 hours ago and just didn’t reboot correctly. There were other users who reported the same issue as yours and after they rebooted their hubs everything was working again. If a reboot doesn’t fix it then you will need to submit a ticket to SmartThings.


(ilker Aktuna) #5

how do you reboot ?


(Nathan Davis) #6

Unplug power and batteries and reconnect. See this thread…


(Alan) #7

From the email:

On Friday, April 7, between 12:00 pm EDT and 6:00 pm EDT, we will automatically update your SmartThings Hub to the latest firmware (version 17.12). The update is expected to take 15-30 minutes, although in rare cases, it could take as long as an hour. During this time your SmartThings Hub will temporarily go offline and events scheduled for this time will not be processed. The update will cause the hub to reboot a number of times and change LED color, including periods where the LED may be off. Please do not remove power from the hub during this time. To verify your Hub has updated, please see ‘Is my Hub’s firmware up to date?’

Since the release of the Samsung SmartThings Hub two years ago, our team has strived to minimize service interruptions. We understand that having your Hub offline for any length of time is difficult and have included some additional details about the update here. A brief summary of the changes is as follows:

Numerous stability improvements and bugfixes
New diagnostics for hub problems
Ability to selectively enable automatic updates for some devices
New, more reliable update delivery mechanism
Thank you,
SmartThings Support


(ilker Aktuna) #8

After the reboot , the hub is still downloading upgrade.
I didn’t understand why this takes too long. When I check on my router, I see 2 way traffic between my Hub and the Amazon servers. So it seems to be downloading.
How big is the firmware itself ?


(ilker Aktuna) #9

finally it finished. It took about 12 hours.
12 hours of DOWNTIME.

This is really unacceptable.


(~voice of reason~) #10

I’m in the same boat… hub has been down for over 12 hours and I can’t bring it back to life.


(Bob) #11

I would respectfully suggest you contact support before trying anything.
If you start fiddling, which is always my problem, you may make the situation worse.
Give them a call, there may be an easy fix.


(~voice of reason~) #12

I’ve been in contact with them already although no fix yet. It almost seems that once a firmware update is attempted, there is no going back to normal operations. I would much rather download a firmware update on to a USB drive and update the hub manually.


#13

If you are one of the people who had your Hub v.2 firmware updated to 17.12; please report any and all issues directly in this thread:
https://community.smartthings.com/t/hub-firmware-release-notes-17-12/83722?u=lmosenko


(Rachelle) #14

Ten minutes ago my hub went offline. Flashing purple. I phsycially rebooted. Turned solid blue, went to flashing purple quickly. Not happy.


(Nick Stevens) #15

This is the migration, you need to let it finish. This will take up to 30 minutes.


(Rachelle) #16

Ok thank you. I hadn’t taken into account this was on eastern time and thought it had all happened while I was at work. Apparently, is happening now. I will be watching for it to come back up. Thanks for your reply.


(Rachelle) #17

All running just fine now and apologies for the stupid panic post. Next time I’ll look at the clock and try to remember where I am in this country. :slight_smile: Thanks for your work, I do so love my ST.


(Rodney Yates) #18

My hub is a version 17.12. My hub has been offline for a week. Not restarting, resetting has fixed it yet. I don’t know if it was down before our power outage but it hasn’t worked since!


(Nick Stevens) #19

I did some checking and your Hub was online with the 17.12 update from April 8th until April 10th (I’m guessing that’s when your power went out), so it did complete the update successfully. If you haven’t already, please reach out to SmartThings Support and let them know the problems you’re having and they’ll get you fixed up. Make sure to include information about what the LED on the front of the Hub does when you plug it in since that can be very helpful in debugging.


(Rodney Yates) #20

Thanks for the quick response! Blinking blue, already reset the router and hub a few times over the past few days and it doesn’t change.