Hub Offline after Firmware Update

After the firmware update my hub (3rd generation) went offline and the LED on the front is solid red. I unplugged it several times but still comes up with the red light. I contacted support and they say the hub is INACTIVE and to either try using another outlet or if that doesn’t work do a hard reset. They said a hard reset will wipe basically everything I’ve programmed and all my devices and really don’t want to go direction.

Is there any other thing I can do to get the hub online or a way to save my programming? Will my Webcore automation be saved if I do a hard reset?

soft factory reset by following these directions:

  1. Disconnect the power cable from the Hub
  2. Using a pin or a small tool, hold down the reset button on the back of the Hub
  3. While continuing to hold down the reset button, replace the power cable
  4. When the LED on the front starts flashing yellow, release the button

But you may want to wait and see if one of the ST members replies to you

Tagging @Brad_ST

And by red light… do you mean solid red or blinking red?

I sent DM to @Brad_ST already. It’s a solid red light. I also tried hooking up the hub to ethernet but it’s still showing the red light. Still gonna hold off to do a reset.

I saw where another user had the same issue. One of the options @posborne recommended was a soft reset

It’s not really a ‘soft’ reset if it’s destructive and removes all devices; I’m hoping not to have to do that - excluding a bunch of in-wall Z-Wave devices is going to be a right PITA!

No, the soft reset only resets the network settings and forces the hub to contact the ST server and download the firmware again. The hard reset wipes everything out.

1 Like

Support didn’t even give me a soft reset option. They said do a hard reset (bringing it back to factory options). I have a lot of devices and some code that I do not want to redo.

@Phil.Dye it looks like my last activity was a few minutes after yours. It’s obvious that this firmware update messed up our hubs.

@jkp, I would keep this in mind, but might have changed since.

1 Like

Read both my posts please… I stated they should wait for someone from ST before proceeding and then my second post was from an ST staff member from this afternoon recommending a soft reset for a user with the same issue. I also tagged that staff member in hope they would confirm for the user. :slight_smile:

1 Like

@jkp, I have read both of yours/all the posts. I understood your intention of the answer, but the user’s concerns regarding the “soft” reset is valid.

But anyhow it is bricked, at the end of the day, it has to be reseted somehow. Or worst case, reseated to the nearest e-rubbish bin.

1 Like

Again, the soft reset does not wipe out devices only the hard reset does. I have offered the advice to others in the past, asked them to contact support first, and each of the users reported the soft reset worked and no devices were reset. Choice is good, users can do what is best for them. And again, I always recommend speaking with support first.

I’m out! Good luck to those with problems


These steps are accurate and it is still true that soft reset will not alter your paired devices or automations. You will lose your Wi-fi configuration if it is a hub v3 and you previously configured it for Wi-fi.

In these situations, note the status of the LED on the front (color and blinking vs steady) and try a soft reset. I also typically check the ethernet port’s status LEDs for activity when connected via ethernet.


So as soon as you see the flashing yellow release the button? If it goes from flashing yellow to solid yellow it’s too late and a hard reset was done?

Yes that is correct. If you accidentally hold it too long and don’t want to hard reset, you can keep holding until the LED goes out and the hub will reboot and won’t factory reset.

UPDATE The hub is working now when connected to ethernet. Will have to play around with it to get back on wifi.


Did you do the soft reset, or did it recover on its own?

Had to do a soft reset. Also was able to get the hub back on wifi.

Did your hub go offline after the firmware update also?

I’m still waiting for a response from Support, so I’ve tried the soft-reset procedure described; the LED rapidly flashes yellow upon restoring power, and then immediately goes off as soon as the reset button is released. The ethernet link LEDs never light, so it can’t be restoring firmware from online.

It seems it’s totally bricked.

Just checking… have you tested with a different Ethernet cable and also tried plugging in to another port on the switch/router?

Yes, cable & switch port (swapped with known-good ones from another device), and also a different (5v 2A) power supply.