Hub is no longer talking to devices


(Eric Fowler) #1

Ok last night I got an open close sensor from monoprice. I paired the device but it didn’t show up properly as an open close sensor. I stupidly deleted the device from smartthings without doing the exclusion. This is when my problems began. After this was done my Smartthings hub refused to talk to other devices, garage door sensor, light bulbs, nothing. It still shows the devices inside my interface and smartphone app, minus the one I deleted, but it does not control them (ie. i cant turn lights on and off anymore) I’ve rebooted the device, tried a repair of the z-wave network, everything I Can think of from my end to fix it. Any idea what I can do from here? Don’t know why Smartthings is not talking to my devices anymore after removing that one sensor.


(Eric Fowler) #2

I want to add that after I deleted the device I tried to do the exlusion by setting Smartthings in exclusion mode to see if that would fix the problem. So far it has not. I have rebooted the switch this morning since then hoping everything would return to normal. Still having problem.


(April Wong) #3

Hey Eric,

Oh man :frowning: ! Have you reached out to support? Id so, pm me your support ticket, and I’ll let the team know.


(Eric Fowler) #4

I have not reached out to support. I was hoping there was something I was missing.


(April Wong) #5

:slight_smile: perhaps a fresh pair of eyes can help. If you don’t hear back from the brilliant community members, support is there to happily assist you, and they will be able to troubleshoot it along with you.

Cheers


(Todd Wackford) #6

@ericf1975,

Try rebooting hub, but leave it off for 10 minutes. You should get an offline message on your mobile device. After 10 minutes plug it back in. You should get another message that the hub is back online. Let support know the info from doing this.

Twack


(Bruce) #8

I’ve seen the same problem when there is a messed up z-wave inclusion / exclusion, i.e., the hub is basically crashed. As @wackware says, reboot the hub after power off, and it should clear up. If need be you should be able to force delete the device if you can’t exclude it normally. There is a small chance you could end up with a zombie z-wave device (one that the hub thinks exists but isn’t listed in devices). Do a z-wave network repair after your hub is functioning again.


(Bruce) #10

It appears that z-wave network repair stops all other z-wave activity, including things like runIn if it commands a z-wave device. For example, if a light is turned on with a “Turn off after some time” queued, and then a z-wave network repair is started, the light will not turn off (assuming the z-wave repair is still running when it should turn off, which for me is usually the case).

I spent weeks trying to heal my z-wave network unsuccessfully until I went to the full 15 minute power off to the hub before each repair. Then, it started healing, and it took several more repairs before I finally got 3 clean ones in a row. Along the way I discovered 2 or 3 devices that evidently had not been included correctly, including a z-wave lock. Those I excluded, re-included, and then they were OK in subsequent network repairs.

Here’s the funny part: I got tired of going to unplug the hub and then plugging it back in after 15 minutes. So, I grabbed an old WEMO switch out of my ST mausoleum box, and installed it with the WEMO app – not part of ST. Now I can turn my hub on and off from my desk without running around the house.


(Ben Edwards) #11

You seem to know a lot about this. The Z-Wave repair utilities that can be accessed from int he mobile app will reform the network. Not sure that is the exact same things as healing. It can take a while for larger networks.


#12

it happens to my hub couple of weeks ago.
try to heal couple of time and it says finish repair, but still have numerous issue operating zwave devices.
when it says finish repair on the log, take it with a grain of salt … give some time for the hub to back to work. on my case, around 1-2 hours later, things back to normal.


(Eric Fowler) #14

OK I’m back up and running. When I re-added the sensor (and it still works) it shows up as “Z-Wave Sensor” When I have the magnet next to it to show closure it shows Inactive but when I move the magnet away it shows Active. Here is the frustrating part though. Smartthings added it in automatically but doesn’t recognize it as a open/close sensor. How can I reconfigure this, now that its added, as an open close sensor in Smartthings?


(Eric Fowler) #15

Haha never mind. I found the edit button for the device and redefined the type of device it is. It was definitely the 15 minute wait that got everything back up and running. Thank you all who posted!!