Hub Firmware Release Notes - 18.18


(jkp) #522

In regards to you still showing 18.20…


(Realy Living Dream) #523

That makes the hub going offline for a while yesterday even more “interesting” LOL

Also leads me to think issues are related to the cloud update and not hub.


#524

So since the update to 18.21, none of my triggers will fire - regardless of whether they are the native SmartThings, CoRE or webCoRE. I have rebooted the hub twice and power cycled it once. I also tried adding a new simulated swith to attach the trigger to and even tried attaching it to a real physical switch. Nothing seems to make a difference. I can still perform actions manually or via Routines but no SmartApps triggers work at all no matter what I do. Anyone else experiencing this? The actions that I have set up rely on Simulated Switches if that matters. I haven’t seen mention of a similar problem but there are a ton of messages in this thread and I couldn’t read them all.

On a separate note, I’ve only been using the SmartThings hub for a bit over 6 months but I have seen a lot of messages of people running into a lot of problems with various updates, including some having to start from scratch. Is SmartThings just that unreliable? I don’t mind getting my hands dirty but I don’t have the time to have to routinely start from scratch because they don’t know how their own products work.


#525

Confirming your findings …

I just checked some of my switches’ event logs and, yup, no more interactions under the source column since the 18.21 update :angry:


(Geekmax82) #526

My Schalge Zwave door lock continues to show status unknown. Do I need to push some sort of update to the lock? My hub is running 18.x as of yesterday. @smartthings_support


(Duncan) #527

You’re right, the local handler for Z-Wave switches isn’t populating the physical/digital field. We actually intended to deprecate and remove that functionality before this release, but that fell through the cracks. I apologize for the communication failure.

The reason we’re not continuing to support the physical/digital field is that it only works on a subset of switch devices, and even then it’s basically just a hack for most of those. For example, on most switches it doesn’t work through repeaters. We’ve also had issues with false positives.

For now, you’ll have to use a custom DTH to continue to get that functionality. I’m hopeful we can replace it with a capability like Button that more precisely represents the device’s behavior, but I don’t know what kind of priority that will have.


Double Tap not working after Hub Update
Linear Dimmers / Switches
After Latest Update: GE 12722 Switch Double Tap fails
After Latest Update: GE 12722 Switch Double Tap fails
UPDATED 10/7/2015 -- "Double Duty" - Use redundant switch presses to control other lights. You paid a lot for those switches, make them work Double Duty!
Switch Events Stopped Working, Help?
How to cancel a Piston
#528

Fair enough, thank you for the informative answer. Although changes like these can tend to be annoying, being able to roll your own custom DTH and SmartApps are a testament to the flexibility and extensibility of the SmartThings platform. Keep up the good work ST!

Can you please point me to where I can find the prior version of these DTHs (that continue to report the physical/digital field, prior to yesterdays rollout) ?

Do the latest versions in the SmartThingsPublic github repo accurately report the physical / digital field? They seem to be (in glancing at the code), but I just want to be sure:

Z-Wave Switch:

Z-Wave Relay:


(John C) #529

@duncan, do I read correctly that local support for Z-Wave switches is being removed? That meaning Smart Lights automations switching security lighting using Z-Wave switches will fail to execute in the absence of internet connectivity to the ST cloud? :thinking:

Boy, I sure hope not…


(Tony) #530

With my Iris motion sensors, I had to click ‘Check now’ in the device portion of the IDE (where it shows the firmware level) before it eventually showed that a firmware update was available. I notice that of the 5 Iris motion sensors I have, one does continue to report its original 67% battery level that it had before the update; the other four went to 100%. Odd.


#531

And now, 24+ hours later, a bit after posting a message on here, suddenly my triggers start working again… Seems like quite a coincidence…


#532

Those should work.

I created a new DTH for my switches by just using one of the Z-Wave Switch templates (From Template, then selected the 2nd Z-Wave Switch) … and now I have the interactions back in the logs, after I updated my GE switches to use the newly created DTH. Of course, now execution location is now in the cloud.


#533

So you changed core api functionality without even mentioning it in the release notes?


(Paul Osborne) #534

Nope, not at all. The code supporting these switches (and other locally running devices) is different, but we only plan to expand the set of devices that are supported locally over time – expect to see several more devices supported locally with subsequent hub releases (including 19.x).


(Kebel87) #535

Like in hub v3 or rather v2 running on future firmware?


(Paul Osborne) #536

Future firmware releases.


(jkp) #537

I believe you mean 19.x not .19… correct?


(John C) #538

Thanks for the clarification, Paul! This is one of those times I’m happy I was wrong :yum:

And new locally supported devices are always welcome!


(Brad) #539

If you look at the firmware version in app or the IDE you’ll see 000.018.00021. So technically 000.019.x is the next major firmware version.


(Brad) #540

Hmm, you’re on 18.20 which is the beta so you didn’t get an update yesterday. If you reach out to support we can help you out.


(www.rboyapps.com - Make your home your butler!) #541

I’m really looking forward to running custom DH and SmartApps on local :slight_smile: