Hub Firmware Release Notes - 17.12/17.13/17.14

If you have multiple hubs, it is possible that they are split across days. If a hub was supposed to update today but is still reporting the old version, you may need to disconnect/reboot the hub to get it to report the new version as has been noted elsewhere in this thread.

1 Like

Thanks, Paul! Looks good now…

My hub currently is having a lot of activity under “events” in the IDE. Both my app and IDE state the old firmware but it was supposed to be updated between noon and 4pm today. Devices are also actually unreliable right now. Could an update be happening now? What’s all the event activity listed as Ssdp Term that’s ongoing?

You will see additional SSDP traffic as a result of the LAN SuperConnect features that were launched a few weeks ago. The only LAN related changes on the hub with this release were some minor fixes and increasing the supported number of concurrent LAN connections slightly.

Due to the offline time during the update, some ZigBee devices may have changed routes which could cause increased/decreased stability depending on the devices that end devices end up choosing for parents/routes. Are the problems related to a specific subset of your devices?

Feel free to file a support ticket to help trace down the problem (this thread is pretty chatty).

Thanks Paul. I guess my core question was why the hub didn’t update during the original timeframe of noon to 4p today and if the update was slower to roll out and could still be updated today. My hub is currently online but it did reboot today, but the firmware didn’t update. I’m have smart lighting rule issues, that’s all, it’s not troublesome right now.

We ended up rolling a little past the window as we had to slow things down in order to avoid overloading the cloud. The aforementioned overloading of the cloud resulted in an issue for some hubs (particularly ones connected to the NA01 shard – see FAQ: How to find out what "shard" (cloud slice IDE URL) your Account / Location is on?).

If your hub went offline for a period and is now online but reporting the old version, you are likely updated. You will need to trigger a disconnect or reboot your hub in order to get the data in the cloud up to date.

1 Like

You’re correct, I rebooted my hub (it took longer than normal) but now shows the updated firmware. Thanks for the guidance!

Upgraded and everything seems normal only arrival sensor logged an alert as getting disconnected but reconnected afterwards

I’m in the UK and have two hubs at different locations.
Both went down at about 17.30 BST but only one came back. Of course the one that didn’t is 200 miles away, so no I can’t just press the reset button!
The one that has stopped responding was on 16.14 and the one that is working is reporting 17.12.
Pain in the a**…

my hub is down for more than 10 hours now.
this is really unacceptable service level. Samsung STOP the firmware upgrade if you won’t be able to HANDLE it with CARE !!!

I have rebooted the hub 3 hours ago and it restarted firmware download. Still downloading.
When I check on my router, I see 2 way traffic between my Hub and the Amazon servers.
How big is the firmware itself ?

I’m pretty sure that if the hub has a gender, it is female. And a mean and jealous one at that.

True story: so, the afternoon passed and I kept checking the hub for the imminent update during the afternoon, but nothing happened. TIme passed and my GF came back from work, happy with the workday and very happy to see me as well it seemed, as we ended up in the sofa.

Right about when we were about to get down, the hub decided to fire off flashing lights and presence sensor notifications that triggered the stereo (that was playing smooth R&B) to announce “someone is arriving” 3 times after each other.

Of course we thought my daughter came home early from the stable, and scrambled around to get dressed thereby ruining the moment. I could almost hear the hub snicker from its place downstairs…

I would like to re-iterate my request to have a user preference to not accept automatic updates.
ST: how are you planning to remedy me and this situation? Pardon my French, but techology c*ck blocking is for real! :wink:

Damage control afterwards: I have lost one ST motion sensor and all LIFX lamps had to be turned off/on to register correctly with the hub. Dinner planned for the evening to give my GF the attention she deserves. The hub remains on the shit list for a long time.


I received the hub update yesterday but following the update the Alexa Integration with Lighting stopped working. I rebooted the hub, rebooted the philips hue hub and still not working. I have a couple of Fibaro dimmers and they also stopped working with Alexa commands. Wemo was working with Alexa commands. Weird.

Anyway I tried re-scanning for all devices in alexa app, deleted and re-discovered and still not working.

I then removed and re-added the Smarthings skill in the Alexa app and that seemed to fix it.

Hardly a seamless upgrade from my point of view.

Just posting to help any others who have similar issues after the Hub upgrade.


Brilliant :slight_smile:

1 Like

3 of my sensors have been offline since the update.

Hub reporting 7.12.

Rebooted the hub but they have still not re-connected.

This is coinciding with one of my sensors going crazy for the last few days and waking us up a bunch.

It’s slowly becoming normal in our house for SmartThings to be prefixed with other “ing” words…

finally my hub is back online. It took about 12 hours.
12 hours of DOWNTIME !!!

This is really unacceptable.

With all do respect, it would’ve been nice to know this before the update. So that we’re not going around the house popping batteries in and out. Did ST maybe talk about the possibility of having a bunch of sensors with red “device unavailable” triangles after the update?

Something really odd going on here as well after the firmware update. I open the ST app (iOS) and everything looks fine, all sensors online and working. Then I tap into any of the ST-branded sensors and navigate to the ‘Recently’ tab. Scrolling down I can see two events from several hours ago indicating the device went offline and then online just a few secs after (this is the case for every ST sensor on my hub). Then I navigate back to the sensor list screen and that sensor suddenly appears with the red triangle as unavailable! I can repeat these steps with any other ST sensor with the same result. Now, closing and reopening the app (or just sending it to background and back to foreground) sort of ‘refreshes’ the screen and all the devices are shown as online again. Doing the pull-to-refresh gesture does not fix this though.

What the hell is going on?

All of these posts are from that last couple hours. ST doesn’t care. They just need to get this update out the door so they can meet some arbitrary deadline. What happens to you or how it impacts your experience doesn’t matter to them. If it did matter they would be handling this differently.

I’d like to take this moment to report my main concern with this.

Popping the batteries out of the Things (I’m withholding the Smart until it’s all working again) sensors is a total pain. Sometimes literally!

This is directly at Eric/whoismoses:

If I didn’t care, would I have gotten barely 3 hours of sleep last night because I’m trying to do right by people having problems, helping individuals in the community here and wherever I can? Would I have taken my Saturdays and Sundays to write detailed communications for the community because I truly believe in being open and transparent. Do you honestly think that that everything we do is somehow to spite our customers, for who knows what reason?

I’ve bitten my tongue enough times, troll. Go troll somewhere else. You are bringing down the otherwise extremely high quality of communications happening in this forum.