Hub Firmware Release Notes - 0.32.7

i rebooted the hub several times with the ide. i watched live logging and its saying no devices to add.

I always go back to device handlers… you say there are no custom device handlers installed for z-wave sensors or ecolink?

non for this ecolink door/window device. (though there is rboys ecolink freeze/water device custom handler.)

Possible it could cause an issue. Open that device handler , publish for me. Then exclude and try to add.

yup, just did that. also, although right next to the hub, i tried a zwave repair and first thing it said was failure for device 07, i dont see a device 07 in the zwave list.

Network repair for device [07]: Could not update neighbors

That can cause issues as well…

1 Like

So, how do i remove that ghost device 07 if its not on the table. will the zwave repair remove it?

Read the thread I posted above. It should have instructions.

1 Like

okay so i got the zwave mesh table cleaned up and all the routers/repeaters online with a good path back to the hub.

though the ecolink zwave plus door/window device is still not pairing. i see the include search being initiated on the hub events. the led stops blinking on the device as if it paired.

upon excluding in the hub events i see “zw removed device: 70”

so, it does appear to be pairing, just not showing as so in the app.

re-publish every single custom dth you have an try pairing again

did that and one gave a sever 500 error, but then i refreshed and was able to re-publish it

this time when i excluded the hub events said “zw removed device: 71”

and what do you know… it paired!

thank you!

My hub seems to have rolled back to the previous firmware now so I’m back online. Hope that happens to the rest of you!

1 Like

If it was the app why would the IDE be wrong and Alexa? Highly of the generate changes and the idea, app and Alexa are unusable yet webCoRE and the old app fine.

i’m guessing one of the custom DTH had a fingerprint that was picking up your device. Custom DTH go “stale” and cause the symptoms you saw where the device actually pairs, but never shows up in smartthings.

Glad your hub is back online but to clarify, your hub never received the update nor rolled back. Except in extremely rare circumstances hubs do not roll back firmware.

Sounds like the hub’s online/offline status was out of sync somewhere so that the IDE, Classic app, and Groovy SmartApps (such as webcore) had the hub marked as online while the source of the hub’s status used by the new app and the Alexa integration had the hub marked offline. This can also happen with devices. Powering off the hub for several minutes and then powering it back on will generate new hub health events and usually corrects the status.

2 Likes

Good to know, thanks! Curious! I admit I did assume it must have been firmware related given Ive never had the problem of the hub failing to boot a few times, and everything showing offline in the app. Never mind, back now, thanks!

Hi

It was powered off yesterday for a few mins but nothing changed when I tried even a few hours later. But this morning the new app has sprung back to life. Will test Alexa when the house is fully awake.

Hurray - yesterday, after three days of my hub being offline (solid blue light despite 15 restarts and soft resets) I did one more normal power cycle and the hub came back online with solid green, app is online and integrations with Alexa working again.

1 Like

Has the rollout of 0.32.7 been stopped? My v3 hub hasn’t updated yet.

The firmware rollout is not scheduled to be completed until Oct 2nd

1 Like