SmartThings Community

Hub Firmware Beta 24.10


(Jimmy) #21

here’s a snip from my hub logs when trying to do a zwave replace


(Tom Manley) #22

We’re doing our best to keep them working. It’s tough since they don’t fully follow the specs and there are a number of different versions.

Unfortunately probably not for this beta but we can consider it for a future release. If your use case would work with the Virtual Switch instead then that does already run locally.


(Tom Manley) #23

I updated the first post but the new plan is to release 0.24.10 shortly without the Samsung sensor FW update. We didn’t find any problems with it but want to do more internal testing before we release it.

Update: all the hubs are now updated


(Jimmy) #24

update received. z-wave power cycled 4 times. once for each device that can’t be pinged.


(Kianoosh Karami) #25

Unfortunately, we are aware of the power cycle issues. Couple of things to remember, I am not sure if you answered this but somehow I missed this.

So these faulty nodes, have you tried to exclude them via the normal exclusion path? We have seen these “bad” nodes with old nodes that have been added very long ago.

Were these added recently? I think you said No.

So replace will not work with these bad nodes, because before we replace or force delete a device, we have to ping the device to see if it is functioning, if it is functioning properly, then the radio will not allow us to remove the device from the network unless you go through the normal exclusion path, this is very important to maintain the healthy level of the mesh, it is in the Z-Wave spec. So if we contact these devices, and they crash the radio, the replace/force delete operation is lost. We are unfortunately aware of this issue, not much we can do besides asking the user to go through the exclusion path and remove the device, and then re-adding them.

I understand that exclusion and re-add is not ideal with respect to automations, but given the limited amount of options, I am not sure what else we can do until the Z-Wave manufacturer can provide us a new firmware that can fix these nodes which might not be for a while.


(Jimmy) #26

Install dates are May 1018, February 2018, March 2016 and March 2016. So a mix of old and new devices. The 4 devices have been marked offline 4-5 days now (9/30 for one and 10/1 for the other 3). Here’s two changes in my system that have occurred recently.

  1. I did have to force remove a z-wave device around 9/25. (Bathroom Fan switch I uninstalled and forgot to do an exclusion). Dates don’t really line up with this, but figured I’d mention it.
  2. I have two outdoor plugs i use for holiday decorations. I leave them installed in SmartThings, but put them back on the shelf when not in use. I obviously normally get errors for them during z-wave repair when not in use. But i leave them as devices in smartthings so i don’t have to re-do scenes and automations every holiday. I recently plugged one of them back in on 9/30 to test for Halloween (ZFront Outdoor Switch). This timing aligns with when my trouble started.

(Borristhecat) #27

I haven’t seen any ‘bad node’ event’s my devices just don’t respond correctly any more. They have been on since 6/2017 is there still only one option to break it down and re add them in?


(DavidK) #28

@tpmanley

How about momentary contact relay to be local?

If I have a zwave relay, running it as a relay is supported as local, but if I need smartthings to turn it on and off as a momentary contact, it then runs in the cloud.

Thanks!


(Jimmy) #29

@Kianoosh_Karami z-wave exclusion nor z-wave force remove are working for these devices. Do I need to delete them from the IDE? If I do, will I be able to perform a general exclusion on them to get them added back?


(Jimmy) #30

update: was able to remove each device by pulling the air gap or cutting power to it and then force removing. Then was able to exclude and re-add. Quite the PITA, but z-wave repair is clear now and working on getting my automatons and scenes set back up.


#31

@Kianoosh_Karami,

I updated BUG-0183 (Zwave device ONLINE status several hours old compared to just an hour )

The resolution you mentioned did not seem to resolve the issue.


(Anthony S.) #32

I’m seriously getting sick of all the issues these firmwares are causing… I mean seriously one minute it’s zwave issues now a bunch of zigbee sensors are offline… please resolve these damn issues


#33

To be fair, if you are running a beta you can’t expect stability. They are going to be changing a lot of moving parts as things go along.


(Anthony S.) #34

I’m aware of the risks of using beta!
I’m highly irritate because It’s the same crap all the time though.
Every update feels like a step backwards instead of moving toward stability.

My devices are the worse they have ever been. It’s not much to ask for a platform that actually works 80% of the time. Instead i spend 80% of my time babysitting all my devices and automations…


(Benji) #35

Dude, I have a lot of respect for you but come on man, if you feel like this you shouldn’t be on beta firmware.


(Anthony S.) #36

I’m really not trying to be an ass I am only stating my frustration.
In all seriousness though can any of you say with a straight face that that these beta’s are progressing the platform toward stability?


(Jimmy) #37

I would say through all the betas so far, they have had an acceptable amount of issues for a beta. By the end of each beta period, my system is just as stable as the public firmware preceding it.

and each hub beta has been infinitely more stable than the new app that’s available to the public :slight_smile: If there were ever a beta for the new app i would go hog wild in the bug reports.


(Jameson) #38

The addition of local execution to a majority of my devices has been great. That is probably the most noticeable change i have seen for the better .

I have noticed that the more inventive an automation I have, the more likely it is to break. I really try to stay with stock DTH as I can. Less than 5 webcore pistons and NST manager is about all I run on custom DTH and smartapps, with over 100 devices. This seems to do well with betas as i have few issues. I haven’t seen the Zwave and Zigbee device problems many are having this go around. Not sure why.

I agree about the app beta, can’t believe there isn’t one. Would love to be apart of it


(DavidK) #39

Actually beta’s have been fairly stable for me. A few weeks ago there was an issue that I thought was the beta, but it turns out it was a cloud platform thingee.

And 2 weekends ago there was also some cloud stuff.

Everything that I have that is local processing is quite stable.


(Joel W) #40

OK folks what am I missing. Beta installed but things running local no longer interact with IDE. Example I turn on a device that runs local it doesn’t show in the Live Logging. Not even showing the device as being activated. Is this something planned. Or do I have something wrong? When I usually turn on my Den Dimmer or Den Lamp it interacts with WebCore and speaks through my Samsung R1. Well nothing happens. within IDE.