Hub Firmware Beta 0.29.8

Version: 0.29.8

Hub Target:

  • Samsung SmartThings Hub (Hub v2)
  • Samsung SmartThings Hub (Hub v3) (2018)

Release Date: 28 Feb 2020

Release Notes:


  • Minor reliability and stability improvements to Zigbee and Z-Wave.
  • Address issue impacting stability of cloud communication channel for some workloads.

Updates rolling out now; should be complete in the next 30 minutes.


So far haven’t experienced any issues yet. All seems fine. Some battery powered untracked devices went HUB DISCONNECTED, even though that they have been used since the hub disconnect event. But I haven’t tried to reboot the Hub yet to resolve that.

I will try to pair some zigbee devices during the afternoon and let you know how is it working.

1 Like

Same here for battery devices.

Thanks for the updated reports on this; for this next GA release we are going to monitor and attempt a workaround/repair as we roll out. Longer term changes to the related cloud services are planned which should address this class of problem long term.


FYI @posborne. Something is odd with how Zigbee devices are joining now that I was not having with any previous firmware release. I submitted a support ticket now that this is in production. For your reference, it’s:

Support request #912500: Zigbee devices not joining correctly causing issues in the new app and missing Current State and Data elements in the IDE (repeatable issue)

Here’s the detail:

SmartThings hub v2 version 000.029.00008
SmartThings app v1.7.44-21
Devices attempting to join : Iris button (zigbee) model 3460-L (
Device names : “Garage Door Smart Button” (new one) and “Panic Button” (existing)
Device Handler used : ZigBee Button (ST default) for both
When joining another device of the exact same model and firmware release of another existing device, the IDE does not have the same “Current State” capabilities or “Data” values. This results in the device not having the same functionality in the new app, such as Quick Controls for the button(s). See the attachments.

“garage_button_ide_settings.jpg” shows the missing capabilities to allow this button to work correctly in the new app, such as the Quick Controls section (and Data). This is the new device I’ve joined. I’ve tried joining this multiple times, through both the new app and Classic.

“panic_button_ide_settings.jpg” shows how the device is suppose to look with the correct current states and capabilities. This is the existing device that works fine:

“Screenshot_20200303-170504.png” shows the device in the new app attempting to load the Quick controls section.

“Screenshot_20200303-170511.png” shows the failed loading of the Quick Controls section.

This is also happening on other devices that I just tested with: (Innr Smart Plugs model SP 224 and works with SmartThings through your new app)
“Garage Door Opener” is newly joined, but missing Data values compared to the three exact same devices below:
“Sunroom Outlet Left” is correct.
“Sunroom Outlet Right” is correct.
“Front Sidewalk Outlet” is correct.

Please note that the Garage Door Opener joined with the proper device handler, like the other Innr plugs use, but I just changed it to use a custom handler to act like a momentary switch, BUT the problem still exists with data values missing. My biggest concern are the Iris buttons, so please focus on those.

EDIT: I’m about to add another Zigbee Smoke Sensor (HEIMAN), and I suspect I’ll see the same results. I’ll edit this reply with an update.

How can I get out of this beta? I rarely use this hub anymore and don’t really want it running a beta firmware.