SmartThings Community

Hub Firmware Beta 0.25.24

(Chris Baumler) #1

For those who are part of the 0.25.x beta test, we are releasing new firmware:

Version

  • 0.25.24

Hub Targets

  • Samsung SmartThings Hub (Hub v2)
  • Samsung SmartThings Hub (Hub v3) (2018)

Release Date

  • 3/18/2019

Release Notes

  • Fix issue with Wi-Fi onboarding
  • Fix issue with Z-Wave network repair cancel command getting ignored
3 Likes
Hub Firmware Beta 0.25.22
(DavidK) #2

Thanks, what are the symptoms of cancel being ignored?

How would I test this?

(Jeffrey) #3

What is the best way to get out of the beta program? I have some apps that some manual intervention everytime there is a reboot and it’s finally getting to the point of being annoying to me :slight_smile:

Thanks!

(Chris Baumler) #4

You can leave the program via the Account Settings menu item in Centercode.

Note that since we’re in the middle of a beta, this isn’t the same as opting out prior to a new beta. We can’t roll your firmware back to 0.24.x. However, we can make a note to no longer send beta firmware updates to your hub. You will stay on 0.25.22 until the 0.25.x firmware is released to production. Is that what you’d like?

2 Likes
(Jeffrey) #5

Yes no rollback needed at all. I just have been having some pain points on some outside integration every time the hub gets rebooted.

Also what did I click exactly? Is it “Remove Your User Account” or do I need I need to remove the platform?

(Chris Baumler) #6

I’ve made a note not to send you further firmware updates for 25.x. So if that’s all you wanted, then you don’t need to take any further action. If you no longer wish to participate in future beta tests, then you should click “Remove Your User Account”.

(Jeffrey) #7

Awesome thanks! Maybe someday I will figure out how to fix this integration mess :slight_smile:

(Chris Baumler) #8

If you initiate a network repair from the classic app, and then you hit the “back” button, the repair should be canceled. You can determine that it was in fact canceled by verifying that your nodes are communicating again and that network repair related messages are no longer appearing in your hub event log in graph.

(Realy Living Dream) #9

“Fix WiFi Onboarding” is this why my LifX bulbs are showing as offline in the ST app but still responding to ST automations and app commands?

(jkp) #10

anyone receive 25.24 yet?

(Jimmy) #11

Not yet. …

#12

I looks like it tried but I’m still on 25.22? @cbaumler?

(Allan) #13

I was hoping it has something to do with actually being able to change the Wi-Fi settings on the 2018 hub. It doesn’t seem to appear to work and nobody has an answer other than to hard reset the hub.

@cbaumler - what exactly is “fix Wi-Fi onboarding” and if it’s not to be able to change the Wi-Fi settings will that ever be fixed?

Hub Firmware Beta 0.25.22
(Chris Baumler) #14

Firmware 0.25.24 will be released shortly.

1 Like
(Chris Baumler) #15

The Wi-Fi onboarding fix was a change made to prevent the firmware from crashing during heavy loads.

@RLDreams The change should be unrelated to your LifX bulbs.

@vseven I would suggest you ask your question regarding Wifi Settings in the forum thread you linked. The ST Staff active in that thread would have a better answer than I would.

(Allan) #16

Unfortunately no one has a answer in that thread and the staff has stopped responding. And the “official” instructions don’t work nor does tech support know how to make it work, if you read that thread you’ll see that. Oh well.

1 Like
(Michael Leonardo) #17

Brad has chimed in over there and is going to take a look at my logs tonight - FYI. I would start following so that you can stay updated if my situation improves.

I can tell you that phone support told me the reason that “Update Wifi settings” was grayed out in the new app is that it is only meant to update wifi settings for devices/appliances that connect to the network. Why on earth it doesn’t apply to the actual smartthings hub is beyond me. They told me my only options was a hard reset. I said no thanks as I have about a hundred devices and 20 smartapps and no interest in redoing it all… I’ll leave it plugged in with ethernet for now.

I’ve been with smartthings for 3 years now and love so much about it but they’re kind of getting one upped these days by decent and fresh products. Hubitat to name one. Please ST, don’t let us down!

(Alex) #18

I have lost count of the network repairs I have run… and the errors never go away. Volume goes up and down without any apparent pattern. Am I the only one?

Things seem to be working but those errors bug me :skull_and_crossbones:

(Bob Kerr) #19

What actions are you taking to resolve these errors? Running the repair over and over again and expecting a different result is not going to solve your problem. Your hub sends commands to these devices and they don’t respond. Knowing why, would solve your problem.

(DavidK) #20

@aruffell

I recently had an issue with one in wall dimmer that was causing all devices to fail network repair.

I turned the breaker on and off for the room that the in-wall dimmer was in and then the repair worked without any errors.

Not sure how to find out which device was causing the problem.