SmartThings Community

Hub Firmware Beta 0.20.14


(Zach Varberg) #1

Version

  • 0.20.14

Hub Target

  • Samsung SmartThings Hub (Hub V2)

Release Notes

  • Fixes a bug which can prevent streaming from LAN video cameras
  • Fix BUG-0083 where simulated switches didn’t work when they have a 2 or 4 digit DNI
  • Fixed rare Z-Wave crash

Release Date

  • Saturday January 13

#2

What time do you think this will go out?


(Zach Varberg) #3

Should be the next couple of hours.


#4

Thanks @Zach_Varberg. FWIW, I’ve noticed a significant performance improvement with device response - zigbee or zwave.

I’ve got a Samsung cam in ST, so glad to see this fix go out. Thanks!


#5

Just got the update, and tested with my Samsung camera. This fixed the streaming issue, thanks! Before it would stream for a couple seconds and die, and now it’s streaming perfectly.


(Zach Varberg) #6

Everyone on the beta should now be at 0.20.14, which contains the hotfix going out to everyone else as 0.19.20.


Hub v2 Update to 19.20 (No advance notice)
Questions from Wink user thinking of moving to SmartThings--multiple locations?
#7

Anyone else experiencing zwave locks not working on this beta? I will do more testing, but so far none are working after this new firmware. I will fill out a big report later today. Just curious if anyone else experienced this.


(Alex) #9

What brand /model locks do you have? What is not working?

I have 3 Schlage Connect locks and they all work fine.


#10

I am not sure what happened. I went out to do some errands after I posted. I came back and all my locks were working normally.

So I will monitor it for a while to see if anything changes.


(Chris Donovan) #11

I seem to have lost all control of my Leviton zwave switches. The dimmers work fine, but none of them that appear as zwave relay devices are working. I tried unpairing and re-pairing as well as a repair on the zwave network, which results in errors from the relay devices. Any ideas?


(Ray) #12

Woke up this morning and no controllable devices working but sensors were OK. Hub showed active but won’t reboot with IDE.
Hub with green led and a hard power cycled with batteries removed. Hub led turned Red and showed disconnected. Second power cycled brought it back to life.


Hub Firmware Release Notes - 0.24.11
(Working on a secret project, are we, sir?) #13

All my Zigbee devices will not work.

Forced removed a Iris door sensor… reset the device and placed back into pairing mode and hub will not detect it.

Bought a brand new one at Lowe’s and same thing.

The beta firmware update broke my hubs zigbee some how.

Is it possible to reflash the hub with the firmware? Or maybe go back to the version before the beta ?


(Working on a secret project, are we, sir?) #14

One other thing… I lost control of the only 2 hue bulbs also.


#15

Did you create a new bug report in Centercode?

Nevermind - you did :slight_smile:


(Alex) #16

Anyone having issues triggering Scenes using SmartLighting and the Aeon Minimotes on 0.20.14? I see the button presses in the events list of the minimote but nothing shows up in the Live Logs and the Scenes do not get triggered. I don’t know whether this is a new issue as I am only attempting this now after being sick of Alexa telling me that ST is not responding when I try to trigger a Scene (directly, not using a Routine as was necessary at first).


#17

Someone is reporting things going in and out on na04-useast2. I’m on na02-useast1 and no issues today.


(Dave) #18

Hi, all–

Bit of life has gotten in the way of my help in the beta. How can I request an opt-out and reflash of my firmware back to the public version? Thank you.


(Working on a secret project, are we, sir?) #19

I created a couple simulated switches and both works.

1 tester said that they couldn’t control hue lights but I just tested this again just a few minutes ago and it worked for me. Created switch used smart light app to link the hue lights to it and tested the on/off and the lights did exactly as programed.

So this issue must be isolated and to just give a blanket closure to the bug report with a comment the local sim switch would be removed is premature at best.


(Realy Living Dream) #20

Did you do this Hue test right before you posted this last night ? If so, this was about the same time I ran Goodnight and NONE of my Hue lights turned off/on as they should have. SHM showed as armed, ST in Night mode, but all my routines were still running as if in Home mode. I wound up rebooting the ST Hub a couple times and then everything turned off/on as it should have.
Until last night I was noticing a vast improvement in the time it took to run Goodnight. I press the button and it’s done before I take 2-3 steps, whereas before it would take 30seconds to a minutes before everything turned off.

No issues here with mini-motes at all .


#21

I don’t know if anyone tried this but I did turn device health back on with this firmware and I am not having any issues with it. Under the last production firmware I had to turn it off as it was impacting a few devices.

Good news!