Hub Firmware 25.x Beta

I added a Zen Thermostat back to SmartThings that I had moved to another platform in order to test this firmware update. Unfortunately, that was before I read this post. But I see it’s in yesterday’s update still. Is it still a problem? If it’s not believed to be a problem, I definitely have some: most of the “smart” functionality on my thermostat no longer works after upgrading, including changing the setpoint, and changing the mode to/from off/heat/cool, or properly reading the idle/heating/etc. states (“idle” actually does seem to be read correctly, but I’m not sure about the rest). Functions that do seem to work include the reporting of the current temperature, changing the fan state (auto vs. on, though I’m not sure the tile properly updates), and battery reporting.

If this is supposed to be working now, I guess this is my report that it’s not. Otherwise, hopefully we’ll have a new update that will restore this functionality or the ability to downgrade to a working version. :slight_smile:

It looks like you’re running the new Zen firmware. So we would have expected your thermostat to be working fine. Please log a bug in Centercode, and we’ll seek a resolution as quickly as possible.

1 Like

We’re about to release 0.25.16 to the remaining beta testers who haven’t received it yet. Please let me know if you don’t receive the update today.

1 Like

Note that we’re still not releasing the beta firmware to Zen thermostat users in light of the issues reported by @BertABCD1234. We’re investigating that issue now and will let you know when we have a path forward.

@pjam73

3 Likes

@Kianoosh_Karami at this point should we be able to successfully pair devices using S2? Or is everthing falling back to S0 until the app update?

Yeah Jimmy, I will keep you in the loop but for now let’s just say we are targeting April-May timeframe to release S2 functionality in the App.

Sounds good. Just making sure we aren’t supposed to be seeing any successful networkSecurityLevel for S2 at this point.

Anyone seeing “this device is unavailable” on NYCE Open/Closed Sensors? I’m still getting it on 25.16 although opening and closing the door fixes it temporarily…

yes, but that isn’t a hub firmware issue. Something it up with that device handler and/or device health.

@Kianoosh_Karami, @cbaumler, @Zach_Varberg

Check out BUG-0031 please.

Firmware : 25.17

Title : Manually using any zwave device does not update the mobile app or the IDE

I’ve tested with almost ALL of my zwave switches, and the results are the same. Here are just a few so far:
Nook Ceiling Lights
Downstairs Lights
Guest Room Fan
Screened Porch Fan (Leviton)
Screened Porch Fan Lights (Leviton)
Master Bedroom Reading Lights
Master Bathroom Mirror Lights (and every other zwave switch in the Master Bathroom Group)
etc, etc, etc

This is happening on any kind of GE zwave device I have (brand new or old: zwave, zwave plus, dimmers, fan controllers), as well as my Leviton device. I believe my Aeon micros too, but I can’t verify.

I honestly don’t know when this started but I just noticed this morning. Using the device manually works fine, but it does not update in the IDE or mobile app (Classic).

But:

If I tap on the refresh tile in the mobile app, the IDE will update and so will the mobile app. Seems like the Refresh tile must be used to properly reflect the device’s state.

This is easily repeatable. Going to need some help on this one guys because I’ve never seen this behavior before.

EDIT : Looks like my Linear garage door controller is doing this too.
EDIT : Looks like my August Pro Lock is doing this too (Front Door Lock)

Without knowing proper device states, ALL my automations and SmartApps are currently unreliable and not useful.

1 Like

Did you try to reboot your phone? Sometimes I’ve noticed it’s an issue with the sync with the ST mobile server.
To verify you can open the IDE and check the latest device state for your device. If it’s showing the correct value there then it’s a ST mobile server sync issue. If it’s showing the wrong value in the IDE it’s most likely to do with the hub.

It’s wrong in the IDE and the phone (all phones and my tablet).

I’m thinking 25.17 introduced something because I don’t remember this with .15 or .16. Hopefully I’ll hear back soon from ST.

@johnconstantelo

I just tried it with some zwave devices and do not see this. But I would like to ask you about battery reporting and your August smart lock pro.

Is the battery reporting in SmartThings accurate.

Mine states 100% battery and has not changed.

Does it always show 100% even when low or is it in fact reporting battery status?

Hi @professordave,

I have lithium batteries in mine, and i haven’t seen any change in a very long time. The August app doesn’t show battery level either that I’ve found.

Since you’re not having the same zwave issue, I’ll try rebooting…

I’m seeing the same thing with z-wave

I just tested with some ge switches and my August smartlock (though it is using my custom dth) and an not seeing any problems with status in the android classic app.

I just tried a reboot, and that didn’t help. Still word from ST, but it is the weekend…

hey @johnconstantelo and @Automated_House

I just took a look at your Networks, and things seem to be functioning. Can you DM me when this exhibits itself, hopefully I am around that I can take a look.

1 Like

Also, May I ask folks here that if you have new issues to report, use the 0.25.17 Thread instead of this one? Thanks for your help, means a lot to us.

1 Like

You bet. Check your PM in a minute. Still happening.

1 Like